Go to advanced search

by Jzhou187
Fri Feb 13, 2015 9:47 pm
Forum: Troubleshooting
Topic: DS18B20 temperature sensor won't detect on Pi2
Replies: 4
Views: 1271

Re: DS18B20 temperature sensor won't detect on Pi2

Thank you very much!
by Jzhou187
Fri Feb 13, 2015 3:53 pm
Forum: Troubleshooting
Topic: DS18B20 temperature sensor won't detect on Pi2
Replies: 4
Views: 1271

DS18B20 temperature sensor won't detect on Pi2

when I do the following command on my Pi2 the temperature sensor didn't show up but it works perfectly on B+
sudo modprobe w1-gpio
sudo modprobe w1-therm
cd /sys/bus/w1/devices/
ls


Please help! Thanks you
by Jzhou187
Sat Feb 07, 2015 4:30 pm
Forum: General discussion
Topic: Webiopi doesn't work on Raspberry Pi 2
Replies: 38
Views: 40143

Re: Webiopi doesn't work on Raspberry Pi 2

croston wrote:Looks like the setup() function and a couple of new #define lines at the top.
sorry I still can't get it to work :(
by Jzhou187
Sat Feb 07, 2015 1:47 pm
Forum: General discussion
Topic: Webiopi doesn't work on Raspberry Pi 2
Replies: 38
Views: 40143

Re: Webiopi doesn't work on Raspberry Pi 2

croston wrote:Compare gpio.c with:
https://sourceforge.net/p/raspberry-gpi ... format=raw
and apply the base address differences.
the gpio.c from the link is a lot different than my one. Which part should I change? or should I just copy everything?

Thanks
by Jzhou187
Sat Feb 07, 2015 1:26 pm
Forum: General discussion
Topic: Webiopi doesn't work on Raspberry Pi 2
Replies: 38
Views: 40143

Re: Webiopi doesn't work on Raspberry Pi 2

It's using Ben Croston's code to access the GPIO pins through memory mapping with /dev/mem. If you look in the install package at ../WebIOPi-0.7.0/python/native/gpio.c you should be able to patch that code to work with the new base address for the RPI2. Hint: #define BCM2708_PERI_BASE 0x20000000 ne...
by Jzhou187
Fri Feb 06, 2015 11:03 pm
Forum: General discussion
Topic: Webiopi doesn't work on Raspberry Pi 2
Replies: 38
Views: 40143

Webiopi doesn't work on Raspberry Pi 2

I bought 3 Pi2 and try to replace one of my Pi B+ which is running webiopi but I got error with the Pi2: [email protected] ~/WebIOPi-0.7.0/htdocs $ sudo webiopi -d -c /etc/webiopi/config 2015-02-06 17:02:36 - WebIOPi - INFO - Starting WebIOPi/0.7.0/Python3.2 2015-02-06 17:02:36 - WebIOPi - DEBUG - Mappin...

Go to advanced search