Go to advanced search

by exander
Thu May 23, 2019 12:41 am
Forum: Advanced users
Topic: USB gadget using libcomposite
Replies: 1
Views: 826

USB gadget using libcomposite

I want to create USB gadget with ethernet, serial and keyboard, I have the following code, but it is not working, usb0 is created, but it is down without any connection, the keyboard does not work, but the device hidg0 is present. Could you point to me any errors? #!/bin/bash -e set -x #set -euo pip...
by exander
Fri Feb 23, 2018 11:11 pm
Forum: Troubleshooting
Topic: Trouble reading RW1990 iButton.
Replies: 0
Views: 287

Trouble reading RW1990 iButton.

Hello, I am stuck. I am trying to read (and write) RW1990 iButton using probe. I have this RW1990: https://www.aliexpress.com/item/10pcs-lot-rewritable-RFID-Touch-Memory-key-RW1990-iButton-copy-card-Sauna-key/1880208741.html?spm=a2g0s.9042311.0.0.EOjFS1 I have this probe: https://www.aliexpress.com/...
by exander
Mon Jan 09, 2017 2:38 pm
Forum: General discussion
Topic: STICKY: USB boot now working on Pi3
Replies: 546
Views: 278158

Re: USB boot now working on Pi3

Not working for me. Tcpdump: 15:29:25.705381 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from b8:27:eb:59:6f:88 (oui Unknown), length 320 15:29:25.705868 IP xxx.bootps > 255.255.255.255.bootpc: BOOTP/DHCP, Reply, length 314 Syslog: Jan 9 15:29:25 xxx dnsmasq-dhcp[26606]: 65346028...
by exander
Mon Dec 14, 2015 1:52 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: I2S Success (at last) !
Replies: 111
Views: 54158

Re: I2S Success (at last) !

Hello, I am trying to record using I2S, compiled the module presented here, I am using PCM1803 in Master mode. But the recorded audio file is all zeroes. Any ideas?
by exander
Mon Dec 14, 2015 1:52 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: STICKY: The I2S sound thread.
Replies: 926
Views: 471947

Re: I2S sound: Anyone got it running? (answer is yes!)

Hello, I am trying to record using I2S, compiled the module presented here, I am using PCM1803 in Master mode. But the recorded audio file is all zeroes. Any ideas?
by exander
Thu Sep 24, 2015 1:08 am
Forum: General discussion
Topic: Raspberry Pi shuts down instead of reboot
Replies: 0
Views: 230

Raspberry Pi shuts down instead of reboot

I am building custom image based on: Ubuntu Vivid, Ryan Finnies PPA (https://launchpad.net/~fo0bar/+archive/ubuntu/rpi2) and custom kernel based on rpi-4.1.y (https://github.com/raspberrypi/linux) Everything seems ok now, but if I do reboot (sudo reboot) then system shuts down. This is really buggin...
by exander
Mon Jun 22, 2015 11:17 pm
Forum: General discussion
Topic: How to make PWM pin high on boot
Replies: 2
Views: 412

Re: How to make PWM pin high on boot

What is the tolerance (in ohms) on pull up resistor? How is it computed?

Edit: Got it from https://learn.sparkfun.com/tutorials/pull-up-resistors.
by exander
Mon Jun 22, 2015 10:55 pm
Forum: General discussion
Topic: is this a fake raspberry pi 2
Replies: 17
Views: 3225

Re: is this a fake raspberry pi 2

jpezz wrote:"Most of customer will send email to ask question about customs.I'd like introduce our terms for you. We will write a lower value on the order pacakge to help you avoid customs."

Criminal act in most countries.
Probably not in China...
by exander
Mon Jun 22, 2015 10:22 pm
Forum: General discussion
Topic: How to make PWM pin high on boot
Replies: 2
Views: 412

How to make PWM pin high on boot

Hi, what is the easier way to set PWM pin high on boot? I am using PWM to control display back-light, it works fine, but while Raspberry Pi is starting the pin is low and I don't see boot, when system boots I set brightness using PWM. Is it possible to set it in config.txt, or hack a bootloader or s...
by exander
Thu Feb 12, 2015 3:20 pm
Forum: General discussion
Topic: WebRTC V8/WebM
Replies: 9
Views: 9004

Re: WebRTC V8/WebM

ghans wrote:Tried the official driver instead ?

Code: Select all

sudo modprobe bcm2835-v4l2
ghans
Tried that, it worked once. But it is not working now.

Also, when I turn on camera, my display goes black. Could it be low amps powersource? I have 2A.
by exander
Thu Feb 12, 2015 3:18 pm
Forum: General discussion
Topic: WebRTC V8/WebM
Replies: 9
Views: 9004

Re: WebRTC V8/WebM

towolf wrote:Chromi does not (yet) support H.264 in WebRTC.
Yes, I figured that out, so I am mainly testing in Firefox.
by exander
Tue Feb 10, 2015 6:59 pm
Forum: General discussion
Topic: WebRTC V8/WebM
Replies: 9
Views: 9004

Re: WebRTC V8/WebM

Anyone has any knowledge about this?
by exander
Sun Feb 08, 2015 10:21 pm
Forum: General discussion
Topic: WebRTC V8/WebM
Replies: 9
Views: 9004

WebRTC V8/WebM

Hi, what is the support of WebRTC in Firefox or Chromium?

When I do:

Code: Select all

uv4l --driver raspicam --auto-video_nr --encoding h264 --width 640 --height 480
Camera is correctly recognized in Firefox (getUserMedia), but not in Chromium, but then I get an error.

Go to advanced search