Go to advanced search

by jpsa
Mon Jan 22, 2018 3:21 pm
Forum: Camera board
Topic: Mode 1 video processing & size rounding
Replies: 7
Views: 1192

Re: Mode 1 video processing & size rounding

Actually, I only want the y plane, so that's easy :)
Thanks again!
by jpsa
Mon Jan 22, 2018 2:34 pm
Forum: Camera board
Topic: Mode 1 video processing & size rounding
Replies: 7
Views: 1192

Re: Mode 1 video processing & size rounding

Thank you for the replies. I don't want to resize, as I'm keen to retain as much resolution as possible, and any resizing seems likely to introduce at least a little blurring (either that or aliasing artefacts, which would also be bad). I may also be performance limited, so if there were any CPU cos...
by jpsa
Mon Jan 22, 2018 11:54 am
Forum: Camera board
Topic: Mode 1 video processing & size rounding
Replies: 7
Views: 1192

Mode 1 video processing & size rounding

Hello, I'm trying to perform live processing on a video stream using mode=1 (documented as being 1920x1080 pixels from the middle of the sensor) on a camera V2.1. I'm starting with the code #!/usr/bin/env python3 import time import picamera class FrameHandler(object): def write(self, buf): pass def ...
by jpsa
Sat Mar 26, 2016 11:08 am
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

Some more information which may or may not be relevant... if I give the following command LIBGL_DEBUG=verbose mathematica >m.txt 2>&1 from the real screen & keyboard, nothing is written to the m.txt log file. If, however, I give it from the remote desktop I get libGL: OpenDriver: trying /usr/lib/arm...
by jpsa
Sat Mar 26, 2016 10:25 am
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

I've reinstalled wolfram-engine, just in case, and it made no difference. I've reconnected my pi3 to a screen & mouse, and Mathematica works fine, as before, if I use those. Remote desktop in to the same machine and it still crashes out during Mathematica startup. Right-click>About on the window ban...
by jpsa
Thu Mar 24, 2016 9:51 am
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

How do I do that? On my machine apt-get doesn't have a reinstall operation... [email protected]:~ $ sudo apt-get reinstall wolfram-engine E: Invalid operation reinstall ...and a quick check through its help options doesn't suggest anything similar. So all I did to my pi3 after unpacking it was Connect it to HD...
by jpsa
Wed Mar 23, 2016 11:17 pm
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

There's no line like that in my config.txt either.

By the way, what RDP client are you using? I'm using the built-in Remote Desktop Connection client on Windows 10.
by jpsa
Wed Mar 23, 2016 1:24 pm
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

OK, I've done that. Now at versions [email protected]:~ $ mathematica --version 10.3 [email protected]:~ $ xrdp --version xrdp: A Remote Desktop Protocol server. Copyright (C) Jay Sorg 2004-2011 See http://xrdp.sourceforge.net for more information. Version 0.6.1 [email protected]:~ $ uname -a Linux pi3 4.1.19-v7+ #858 SMP Tue Mar 1...
by jpsa
Wed Mar 23, 2016 1:08 pm
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

Curious! My pi3 also had libgl1-mesa-glx (I think it's the hardware accelerated version of the library) installed to start with, i.e. when Mathematica was failing, but it was uninstalled automatically when I installed libgl1-mesa-swx11. I had also done an "apt-get dist-upgrade" before posting in the...
by jpsa
Sun Mar 20, 2016 3:02 pm
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

OK... if I've understood this properly, the effect of that installation is to replace the Pi's hardware-assisted 3D rendering library with a pure software version. This will presumably adversely affect performance (though, poor performance is better than a crash!). Presumably this suggests that the ...
by jpsa
Sun Mar 20, 2016 2:45 pm
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

Oooo... worked for me too :)
by jpsa
Fri Mar 18, 2016 12:57 am
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

Yes, it works on my B+ too, but not on my 3 :(
by jpsa
Fri Mar 04, 2016 7:37 pm
Forum: Mathematica
Topic: Mathematica start-up crashing RDP session
Replies: 36
Views: 31123

Re: Mathematica start-up crashing RDP session

This happens for me too, on my brand new shiny RPi 3. Clean install of raspbian from NOOBS, then install xrdp. Remote desktop in from a Windows 10 machine and try to start Mathematica. The remote session disconnects, and after reconnecting there's no sign of Mathematica running. :( Any suggestions w...
by jpsa
Wed Feb 04, 2015 8:49 am
Forum: Troubleshooting
Topic: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.
Replies: 335
Views: 366492

Re: Breakage after rpi-update? Read this.

I did an apt-get upgrade (*not* an rpi-update) yesterday, and found that me 1-wire temperature probe had stopped working. After quite a bit of Googling, I fixed it by adding # 1-wire settings dtoverlay=w1-gpio,gpiopin=4 to the end of my /boot/config.txt. I'm puzzled, though, that the advice given in...
by jpsa
Wed Feb 04, 2015 8:33 am
Forum: Troubleshooting
Topic: Breakage to cifs mount
Replies: 2
Views: 2207

Breakage to cifs mount

I've been successfully using a cifs mounted file system (actually a flash drive plugged into my router) for a few weeks, but after an "apt-get upgrade" yesterday this stopped working. The solution for me seems to be to add sec=ntlm to the mount options in fstab. Presumably this used to be the defaul...

Go to advanced search