Go to advanced search

by tpbholm
Fri Feb 20, 2015 1:10 am
Forum: HATs and other add-ons
Topic: Gertduino & Arduino IDE on RPi2
Replies: 3
Views: 6003

Re: Gertduino & Arduino IDE on RPi2

Thanks for responding Gert.
You were right. When I remove the reset jumper the blink program runs.
I'm afraid I'm very much a beginner and have no idea how to go about setting the GPIO pin high in SW, but at least I know what the cause of the problem is.
Thanks again.
by tpbholm
Tue Feb 17, 2015 5:13 pm
Forum: HATs and other add-ons
Topic: Gertduino & Arduino IDE on RPi2
Replies: 3
Views: 6003

Gertduino & Arduino IDE on RPi2

I've posted this issue already on the Troubleshooting forum but realised it would be better to post here. After finally getting my RPi2 to recognise the Gertduino I have a frustrating issue with the Gertduino and the RPi2 GPIO / Arduino IDE. I can compile and upload a sketch to the Gertduino but alt...
by tpbholm
Sun Feb 08, 2015 8:43 pm
Forum: Troubleshooting
Topic: RPi 2 - Gertduino / GPIO issues.
Replies: 3
Views: 771

Re: RPi 2 - Gertduino / GPIO issues.

Ok here's an update on this issue and a partial fix: 1. Make sure you're not running the Arduino IDE 2. Open the Arduino preferences text file - /home/pi/.arduino 3. Scroll down to find this line: serial.port=com1 and edit it to read serial.port=/dev/ttyACM0 4. Save and close the file then reboot yo...
by tpbholm
Sat Feb 07, 2015 1:41 am
Forum: Troubleshooting
Topic: RPi 2 - Gertduino / GPIO issues.
Replies: 3
Views: 771

RPi 2 - Gertduino / GPIO issues.

When trying to program my Gertduino using the Arduino IDE on my Pi2 I get the following error message: 'Serial port 'COM1' not found. Did you select the right one from the Tools > Serial Port menu?' There are no other options in in the Serial Monitor - selecting it just produces the error message ab...
by tpbholm
Fri Feb 06, 2015 2:24 am
Forum: Troubleshooting
Topic: Gertduino on Pi2
Replies: 1
Views: 362

Re: Gertduino on Pi2

Ok. I think the issue is with the avrdude code. I have now set up the Gertduino using the guidance here: https://projects.drogon.net/raspberry-pi/gertboard/arduino-ide-installation-isp/ This sets up the pi to use an Atmega 328 on a Gertboard and when I used avrsetup it recognised the chip on my Gert...
by tpbholm
Fri Feb 06, 2015 12:25 am
Forum: Troubleshooting
Topic: Cant get i2c set up!
Replies: 5
Views: 2542

Re: Cant get i2c set up!

I had this problem when setting up my PiGlow after updating the latest version of Raspbian. You can enable i2c in raspi config:

sudo raspi-config

Select option 8 - Advanced Options, then A7 to enable automatic loading of i2c.
by tpbholm
Thu Feb 05, 2015 5:10 pm
Forum: Troubleshooting
Topic: Gertduino on Pi2
Replies: 1
Views: 362

Gertduino on Pi2

! am unable to get my Gertduino board working on my Pi2. I've successfully installed the Arduino software and the Gertduino software but the board itself doesn't seem to be connecting to the Pi - no flashing LED's on startup and when I run ./avrsetup I get the Oops! Something went wrong error messag...
by tpbholm
Thu Feb 05, 2015 4:44 pm
Forum: Troubleshooting
Topic: Pi2 Error message on startup
Replies: 5
Views: 1180

Pi2 Error message on startup

Help - When I boot my Pi2 into the GUI I get the following error message:

GDBUS.Error.org.Freedesktop.PolicyKit1.Error.Failed:Cannot determine user of subject

What does this mean and what do I need to do?

Go to advanced search