Go to advanced search

by sora03
Sat Feb 29, 2020 4:35 am
Forum: Advanced users
Topic: htop temperature monitor option
Replies: 8
Views: 636

Re: htop temperature monitor option

lmarr wrote:
Thu Feb 27, 2020 1:18 pm
sora03 wrote:
Wed Feb 26, 2020 3:53 am
it looks interesting. You could also try to install

Code: Select all

glances
it displays temp and ip address
I doesn't have CPU Freq, but it's ok :)
Thanx :)
look at the glances documentation, maybe it is implemented.
by sora03
Sat Feb 29, 2020 2:45 am
Forum: Troubleshooting
Topic: How to enable SSH from internet to RPi4 WiFi AP?
Replies: 2
Views: 44

Re: How to enable SSH from internet to RPi4 WiFi AP?

We have configured our RPi4 as an WiFi access point to work at a remote location. We need remote SSH access to the Raspberry, too. So far we have succeeded in making either SSH from internet work OR the Wifi AP to work. Both at the same time does not work. We have tried both https://raspap.com/ and...
by sora03
Sat Feb 29, 2020 1:57 am
Forum: Beginners
Topic: pihole and pivpn
Replies: 1
Views: 45

Re: pihole and pivpn

Hi, So what i got is a Raspberry Pi 3 and a Pi 4 (4GB). I have Pihole installed on the Pi 3 and want to install pivpn on the Pi 4 ( because i want to use nextcloud and a minecraft server). I had everything set up with the pihole on the pi 3 and nextcloud and minecraft on the pi 4. What i did was fi...
by sora03
Sat Feb 29, 2020 1:50 am
Forum: Troubleshooting
Topic: RPi 3b WiFi DHCP issues
Replies: 1
Views: 29

Re: RPi 3b WiFi DHCP issues

Are you using a headless raspbian?
Have you tried executing this to get DHCP lease:

Code: Select all

$ sudo dhclient wlan0
Try to also add this lines to /etc/network/interfaces:

Code: Select all

auto wlan0
iface wlan0 inet dhcp
by sora03
Fri Feb 28, 2020 1:35 pm
Forum: Beginners
Topic: Make the onboard LED blink using python - RP3B+
Replies: 1
Views: 66

Re: Make the onboard LED blink using python - RP3B+

I did a search and deduced the onboard LED can be made to blink 10 times using the following python code. os.system('echo gpio | sudo tee /sys/class/leds/led0/trigger') for j in range(10) os.system('echo 1 | sudo tee /sys/class/leds/led0/brightness') # led on time.sleep(1) os.system('echo 0 | sudo ...
by sora03
Fri Feb 28, 2020 1:24 pm
Forum: Troubleshooting
Topic: Flashing Python onto esp32
Replies: 6
Views: 101

Re: Flashing Python onto esp32

Hi, I am trying to load Micropython onto an ESP32 but no matter what I do I keep getting an error I open a terminal and put the following code in esptool.py --chip esp32 --port /dev/ttyUSB0 write_flash -z 0x1000 /home/pi/ Downloads esp32-idf3-20200226-v1.12-195-gb16990425.bin But i keep getting the...
by sora03
Fri Feb 28, 2020 1:20 pm
Forum: Beginners
Topic: pure-ftp no longer works: clients say "connection refused"
Replies: 2
Views: 49

Re: pure-ftp no longer works: clients say "connection refused"

I set up pure-ftpd to allow uploading files to /home/pi/ftp. Everything was working fine. I attached an external USB hard driver and I used the "pure-pw usermod" option to change the home directory to /media/pi/8697cc2d-4687-4103-a254-1928cfa699f8/, and now nothing works at all. Whenever I try to c...
by sora03
Fri Feb 28, 2020 1:13 pm
Forum: Troubleshooting
Topic: Random Pi Shutdowns
Replies: 4
Views: 82

Re: Random Pi Shutdowns

What type of shutdown are you experiencing? Instant shutdown/reboot or just not responsive pi? To further detect whether the Pi is dead, I want you to add this line to /boot/config.txt dtparam=act_led_trigger=heartbeat Reboot the pi and notice the green LED or called activity LED, blink like a heart...
by sora03
Fri Feb 28, 2020 1:02 pm
Forum: Troubleshooting
Topic: Pi4 - USB wifi failing with USB drive
Replies: 3
Views: 85

Re: Pi4 - USB wifi failing with USB drive

Hi, I have a PI4 with Raspbian buster. I use it from an iPad Pro so I can manage Linux servers from the PI. To connect to the PI I have configured the onboard WiFi with NetworkManager to be a Hotspot. I bought an USB WiFi dongle that is supported by the PI and recommended for network monitor and pa...
by sora03
Fri Feb 28, 2020 10:27 am
Forum: Troubleshooting
Topic: Agressive Roaming for WiFi
Replies: 4
Views: 123

Re: Agressive Roaming for WiFi

Have you tried using the generated psk with the tool wpa_passphrase? Instead of using the plaintext password psk=password. Just try if it works.

Code: Select all

$ wpa_passphrase WiFiAP password

network={
	ssid="WiFiAP"
	#psk="password"
	psk=e8631c0cece01baadc1ea0ae111882c26548e9fb05a28527a89a6953ef029a44
}
by sora03
Fri Feb 28, 2020 3:01 am
Forum: Beginners
Topic: Remove a public key from pi?
Replies: 5
Views: 144

Re: Remove a public key from pi?

What do you mean by public key? Public key is Public. Maybe you mean regenerating your PI's new Private SSH Key?
by sora03
Fri Feb 28, 2020 3:00 am
Forum: Other languages
Topic: FILIPINO
Replies: 6
Views: 11774

Re: FILIPINO

Wala na bang ibang Filipino pa dito?
by sora03
Fri Feb 28, 2020 2:50 am
Forum: Troubleshooting
Topic: Unable to detect mouse or keyboard on Raspberry Pi Zero W
Replies: 8
Views: 135

Re: Unable to detect mouse or keyboard on Raspberry Pi Zero W

have you tried different microUSB to USB adapter?
It looks like a faulty microUSB to USB adapter or a cable.
by sora03
Fri Feb 28, 2020 12:31 am
Forum: Troubleshooting
Topic: Boot from USB mass storage fail using 'bootcode.bin' only with 'timeout' on SD
Replies: 5
Views: 159

Re: Boot from USB mass storage fail using 'bootcode.bin' only with 'timeout' on SD

Many thanks for the replies, clearly sora03 and HawaiianPi you are both right. I take onboard HawaiianPi's advice about that USB cable/adapter which looks the business. It is of course a case of improve this and improve that and try again. If I drop the rootwait command it wouldnt boot even with fu...
by sora03
Fri Feb 28, 2020 12:11 am
Forum: Troubleshooting
Topic: rpi4 usb issue
Replies: 12
Views: 415

Re: rpi4 usb issue

Hi, I'm sure no message from ssh before the crash. Tested a couple of times with a pc connected via eth0. spinning down the hdd is necessary during the day, the night and all those hours when no one is at home. Accessing the hdd via eth0 works without issue, ~30MB/s. I haven't tested to underclock ...
by sora03
Fri Feb 28, 2020 12:09 am
Forum: Troubleshooting
Topic: I can’t get back into Raspbian.
Replies: 8
Views: 170

Re: I can’t get back into Raspbian.

in the tty, try to execute

Code: Select all

 $ startx
to start the GUI.

Can you just burn a fresh install of raspbian to the sd card?
by sora03
Thu Feb 27, 2020 3:05 pm
Forum: Advanced users
Topic: Powering my RPi projects using buck converters
Replies: 9
Views: 231

Re: Powering my RPi projects using buck converters

rpdom wrote:
Thu Feb 27, 2020 2:54 pm
sora03 wrote:
Thu Feb 27, 2020 2:38 pm
Nice build but based on the photos, you seem to bypass the polyfuse of the Pi's?
The Pi 4B does not have a polyfuse.
Good to know, is there still any protection from over current (or other danger)? (Does this mean it is safe to bypass my Pi 3B+ polyfuse?)
by sora03
Thu Feb 27, 2020 2:59 pm
Forum: Troubleshooting
Topic: Message "Drive was removed without ejecting" with sudo eject
Replies: 4
Views: 107

Re: Message "Drive was removed without ejecting" with sudo eject

I don't use eject anymore, I just use udisksctl

To eject/safe to remove:

Code: Select all

$ sudo udisksctl power-off -b /dev/sdX
After unmounting the drive.
by sora03
Thu Feb 27, 2020 2:58 pm
Forum: Troubleshooting
Topic: Agressive Roaming for WiFi
Replies: 4
Views: 123

Re: Agressive Roaming for WiFi

Dear Community, I'm a little bit desperate. I setup the Raspberry Pi 4 with Debian Buster (Rasbian Buster) and setup the WiFi with wpa_supplicant (see the configuration file down below this post). I use the Raspberry Pi as Thin Client (xfreedesktop) in our hospital on a mobile station (desk with wh...
by sora03
Thu Feb 27, 2020 2:48 pm
Forum: Beginners
Topic: Chromium browser installation error
Replies: 1
Views: 53

Re: Chromium browser installation error

Hi, I bought Raspbbery Pi 3 model B, I connect hdmi and power cabels, I used the program for formatting, and formated my own SD card(I did not buy one from raspbbery) I followed the instractions to installation. The installation does 2/3 of installing procces and then crashes with this message : xz...
by sora03
Thu Feb 27, 2020 2:38 pm
Forum: Advanced users
Topic: Powering my RPi projects using buck converters
Replies: 9
Views: 231

Re: Powering my RPi projects using buck converters

Nice build but based on the photos, you seem to bypass the polyfuse of the Pi's? Is it not dangerous to do so.

I too used the MP1584 for my Pi 3B+, no problems with undervoltage ( as long as you use thick microUSB cables), I do not want to bypass the polyfuse.
by sora03
Thu Feb 27, 2020 2:35 pm
Forum: Troubleshooting
Topic: rpi4 usb issue
Replies: 12
Views: 415

Re: rpi4 usb issue

Are you sure that the command suggested by epoch1970 does not yield results? This command specifically: On your PC open an SSH session to your pi and execute this command,, so we can trace the Pi crash: sudo tail -F /var/log/messages This command will stream dmesg until you encounter your problem, i...
by sora03
Thu Feb 27, 2020 2:26 pm
Forum: Networking and servers
Topic: Can't ping google or any external hostnames from Pi
Replies: 8
Views: 175

Re: Can't ping google or any external hostnames from Pi

This is a DNS issue, you can try to edit network connections in Network Manager and Specify manual DNS if you are using a graphical interface. If not then you can do the following with terminal emulator to manually specify DNS forcefully by locking down /etc/resolv.conf. As you may now, the file /et...
by sora03
Thu Feb 27, 2020 10:37 am
Forum: Troubleshooting
Topic: Raspberry pi zero USB hat not working
Replies: 2
Views: 65

Re: Raspberry pi zero USB hat not working

Does the USB hat work with Raspbian?
This is a hardware so, I guess the software OS does not have any relevance to it's use, AFAIK.
by sora03
Thu Feb 27, 2020 10:36 am
Forum: Troubleshooting
Topic: Rpi 4: USB keeps Failing/Locking, faulty?
Replies: 11
Views: 242

Re: Rpi 4: USB keeps Failing/Locking, faulty?

Are you using all the official peripherals (eg. official PSU, official casing etc.) According to dmesg, the USB keyboard and other USB devices gets disconnected. Can you check whether you are having undervoltage or CPU is throttiling? $ vcgencmd get_throttled Have you tried other type of USB devices...

Go to advanced search