Go to advanced search

by nitschkecm
Wed Oct 11, 2017 5:33 pm
Forum: Raspbian
Topic: Gstreamer on latest Raspbian
Replies: 16
Views: 47116

Re: Gstreamer on latest Raspbian

I am quite sure that there is a bug since I have had the same sympton and it used to work just fine. Would be great to get GSTREAMER back to work correctly since it was much more efficient and faster than ffmpeg.
Please keep me posted if you find a solution!
by nitschkecm
Sat Oct 07, 2017 9:37 am
Forum: Raspbian
Topic: Gstreamer on latest Raspbian
Replies: 16
Views: 47116

Re: Gstreamer on latest Raspbian

I have a similar problem. The video plays in VLC but I uploading it to youtube the video processing gets stuck at the very beginning.
by nitschkecm
Sat Sep 16, 2017 8:18 am
Forum: Troubleshooting
Topic: NFS mounts drop on Raspbian Jessie
Replies: 3
Views: 534

Re: NFS mounts drop on Raspbian Jessie

Hi

I am using Ethernet
by nitschkecm
Fri Sep 15, 2017 10:26 am
Forum: Troubleshooting
Topic: NFS mounts drop on Raspbian Jessie
Replies: 3
Views: 534

NFS mounts drop on Raspbian Jessie

I am experiencing since some days problems with NFS mounts which I have mounted via /etc/fstab on my raspberry pi. -The share are all mounted well on boot - after some time I can still ls the shares but I am not able to write to them sudo systemctl restart rcpbing sudo systemctl restart nfs-kernel-s...
by nitschkecm
Mon Sep 11, 2017 3:54 pm
Forum: Raspbian
Topic: NFS problems on Raspbian Jessie
Replies: 0
Views: 329

NFS problems on Raspbian Jessie

I am experiencing since a few days problems with my NFS mount. I have a Synology running DSM 6.1.3-15152 Update 4 I have several Shares with NFS enabled which worked fine till now. Raspberry Linux 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l GNU/Linux I was able to move files from my ras...
by nitschkecm
Tue Jul 05, 2016 9:09 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1483
Views: 345190

Re: PiKrellCam: motion vector detect + OSD web interface

Hi, worked like a charm !!!

one more question: Has anybody integrated this with the Synolgoy Surveillance Station and what are the parameters used.
Thanks in advance!
by nitschkecm
Mon Jul 04, 2016 1:54 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1483
Views: 345190

Re: PiKrellCam: motion vector detect + OSD web interface

Hi,

I have just installed and so far it runs like a charm. I was wondering if somebody has implemented an email trigger which is easy to implement. I would like to have and email sent in case of a motion event, if possible with the thumbnail generated.
Many thanks for the hint!
by nitschkecm
Mon Jun 13, 2016 7:06 am
Forum: Camera board
Topic: Generate timelapse from JPEGs, gstreamer hangs
Replies: 5
Views: 2802

Re: Generate timelapse from JPEGs, gstreamer hangs

I have had a Gstreamer Pipeline working for over 1 year but for some reason something must have changed. Whilst my pipe gst-launch-1.0 -v multifilesrc location=image_%04d.jpg caps="image/jpeg,framerate=\(fraction\)30/1" ! jpegdec ! queue ! videoscale ! video/x-raw, width=1296, height=976 ! queue ! o...
by nitschkecm
Tue Jun 07, 2016 9:40 am
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

Hello again, after several month of working like a charm, I have now a new problem. Probably it is not directly related to the Streamer app but... I still create my video but when I upload to youtube I have the following anomalies. The video takes ages to process Youtube shows me that the video is l...
by nitschkecm
Thu Aug 13, 2015 4:36 pm
Forum: Graphics, sound and multimedia
Topic: [Tutorial] Making time-lapse video with Raspberry Pi
Replies: 55
Views: 60772

Re: [Tutorial] Making time-lapse video with Raspberry Pi

Hi for updating the movie file with each frame you take take a look at the link posted. The OpenMax Demo has a script that does exactly that. The frame is automatically appended to the video file. However I have not been able to get the jpg out for a website for example. That is why i went back to t...
by nitschkecm
Wed Aug 12, 2015 4:51 pm
Forum: Graphics, sound and multimedia
Topic: [Tutorial] Making time-lapse video with Raspberry Pi
Replies: 55
Views: 60772

Re: [Tutorial] Making time-lapse video with Raspberry Pi

Hi

check out this thread. Maybe this is what you are looking for
viewtopic.php?t=70105&p=508895
Cheers
by nitschkecm
Sat Jul 04, 2015 9:51 am
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

That did it !!!! Many thanks !!!!!!!!
;) ;) ;) ;)
last question what is the impact does the target-bitrate have ?
by nitschkecm
Fri Jul 03, 2015 10:18 am
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

I have checked my images and there was a mistake in the way I renamed them. Problem solved and now I can encode rather fast the video of 852 pictures (that is the test I have made). The only issue I have left is that the video seems to be stuttering and if I would apply the logic of 25fps than I sho...
by nitschkecm
Wed Jul 01, 2015 8:47 am
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

What I did: - I took a new set of pictures since I made some changes to my timelapse. Pictures are attached here https://www.dropbox.com/s/82xhi900uccjjt8/Archive.zip?dl=0 then I ran your command an the good news is that it worked (finished) and produced a video file The log is here https://www.drop...
by nitschkecm
Tue Jun 30, 2015 6:18 am
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

I re-ran the test. First with Image series from image_0000.jpg to image_0009.jpg the output stopped for more than 5 minutes just before the "^Chandling interrupt." gst-launch-1.0 -v multifilesrc location=image_%04d.jpg do-timestamp=true caps="image/jpeg,framerate=\(fraction\)20/1" ! jpegdec ! queue ...
by nitschkecm
Mon Jun 29, 2015 7:15 am
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

Hi thanks again for the support on this. However the result was not positive of this latest try running the mentioned command results in Setting pipeline to PAUSED ... Pipeline is PREROLLING ... /GstPipeline:pipeline0/GstMultiFileSrc:multifilesrc0.GstPad:src: caps = image/jpeg, framerate=(fraction)2...
by nitschkecm
Tue Jun 23, 2015 5:37 pm
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

Hi i have all images in the series but I will make it a smaller one (just 10 for the try) it is RPI 1 B+ I will take out the rescale of the command you have provided and will try again. Come back to you !!! I checked the files and there was a problem with one missing in between. I took a new series ...
by nitschkecm
Fri Jun 19, 2015 9:45 am
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

Just tried your command on a fresh raspbian install (latest version) after update / upgrade and installing the Gstreamer tools 1.0 gst-launch-1.0 -v multifilesrc location=image_%04d.jpg ! jpegdec ! videoscale ! video/x-raw, width=1296, height=976 ! progressreport name=progress ! omxh264enc target-bi...
by nitschkecm
Wed Jun 10, 2015 2:02 pm
Forum: Raspbian
Topic: Gstreamer on latest Raspbian
Replies: 16
Views: 47116

Re: Gstreamer on latest Raspbian

I ran the command like this gst-launch-1.0 -e multifilesrc location=image_%04d.jpg ! image/jpeg, framerate=12/1 ! decodebin ! video/x-raw, width=1296, height=976 ! progressreport name=progress ! omxh264enc target-bitrate=15000000 control-rate=variable ! video/x-h264, profile=high ! h264parse ! mp4mu...
by nitschkecm
Mon Jun 08, 2015 3:48 pm
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

Hi, I just ran gst-launch-1.0 -e multifilesrc location=image_%04d.jpg ! image/jpeg, framerate=12/1 ! decodebin ! video/x-raw, width=1296, height=976 ! progressreport name=progress ! omxh264enc target-bitrate=15000000 control-rate=variable ! video/x-h264, profile=high ! h264parse ! mp4mux ! filesink ...
by nitschkecm
Mon Jun 08, 2015 2:00 pm
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

Hi
I am having problems with the Pipeline and and cannot get it to work correctly. Would you be able / mind to share your working image ? I basically need this to encode video fast for a time-lapse script I have. Happy to share with you.
by nitschkecm
Mon Jun 08, 2015 12:43 pm
Forum: Raspbian
Topic: Gstreamer on latest Raspbian
Replies: 16
Views: 47116

Re: Gstreamer on latest Raspbian

I reinstalled Rapsbian (latest release) on a new Pi B+. All is updated to the latest version. I have installed as well the gstreamer1.0-tools when I run the above command to make the movie I am getting now a different error Setting pipeline to PAUSED ... Pipeline is PREROLLING ... ERROR: from elemen...
by nitschkecm
Mon Jun 08, 2015 11:12 am
Forum: Graphics, sound and multimedia
Topic: Issue with Gstreamer pipeline
Replies: 21
Views: 7015

Re: Issue with Gstreamer pipeline

Hi
have you ever gotten it to work ? If yes can you share how you did it ?

Go to advanced search