Go to advanced search

by micksulley
Sat Aug 22, 2020 11:46 pm
Forum: Troubleshooting
Topic: Re: modprobe fails on os version - Solved
Replies: 6
Views: 406

Re: modprobe fails on os version - Solved

I did do an upgrade to Buster by editing /etc/apt/sources.list and /etc/apt/sources.list.d/raspi.list, and apt update upgrade and reboot more times than I can remember, but I think it must be related to that.
Thanks for your help.
Mick
by micksulley
Sat Aug 22, 2020 9:44 pm
Forum: Troubleshooting
Topic: Re: modprobe fails on os version - Solved
Replies: 6
Views: 406

Re: modprobe fails on os version - Solved

Thanks PillE that fixed it. Any idea what could have caused it?
by micksulley
Sat Aug 22, 2020 7:51 pm
Forum: Troubleshooting
Topic: Re: modprobe fails on os version - Solved
Replies: 6
Views: 406

Re: modprobe fails on os version - Solved

I have a strange problem where modprobe fails, this is what I see control@pi-solar-old:~ $ sudo modprobe i2c-bcm2708 modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.9.35-v7+/modules.dep.bin' modprobe: FATAL: Module i2c-bcm2708 not found in di...
by micksulley
Thu Aug 20, 2020 6:21 pm
Forum: Troubleshooting
Topic: Python Code Won't run on Raspbian
Replies: 15
Views: 417

Re: Python Code Won't run on Raspbian

Don't know if this helps but on my systems I have beautifulsoup4 Desktop 4.8.2 Pi 4.9.1 pytz Desktop 2019.3 Pi 2020.1 yahoofinancials both 1.5 As Desktop works and Pi doesn't is it worth installing the older versions of beautifulsoup4 and pytz ? And if it is can you give me a clue how to do that ple...
by micksulley
Thu Aug 20, 2020 3:32 pm
Forum: Troubleshooting
Topic: Python Code Won't run on Raspbian
Replies: 15
Views: 417

Re: Python Code Won't run on Raspbian

Thanks anyway for trying.
by micksulley
Thu Aug 20, 2020 2:33 pm
Forum: Troubleshooting
Topic: Python Code Won't run on Raspbian
Replies: 15
Views: 417

Re: Python Code Won't run on Raspbian

OK I have run it on both, output attached in a zip

Mick
by micksulley
Thu Aug 20, 2020 12:48 pm
Forum: Troubleshooting
Topic: Python Code Won't run on Raspbian
Replies: 15
Views: 417

Re: Python Code Won't run on Raspbian

Thanks for the replies. I had seen https://github.com/JECSand/yahoofinancials/issues/71. There are actually two problems there, I have applied the fix changing version = 'Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11' to version = 'w3m/0.5.3+git20180125' w...
by micksulley
Thu Aug 20, 2020 9:01 am
Forum: Troubleshooting
Topic: Python Code Won't run on Raspbian
Replies: 15
Views: 417

Python Code Won't run on Raspbian

I have some python3 code which runs fine on my desktop but fails if I run it on my Pi. Desktop is Mint20 and Python 3.8.2, Pi is running Buster and Python 3.7.3. How can I fix it? #!/usr/bin/env python3 from yahoofinancials import YahooFinancials yahoo_financials = YahooFinancials('VOD') pd = yahoo_...
by micksulley
Mon Jun 01, 2020 2:35 pm
Forum: Raspberry Pi OS
Topic: Pi OS - Cannot save setup
Replies: 1
Views: 225

Re: Pi OS - Cannot save setup - Fixed

Tried again with another SD card and it works, so assume it was a faulty card
by micksulley
Mon Jun 01, 2020 10:53 am
Forum: Raspberry Pi OS
Topic: Pi OS - Cannot save setup
Replies: 1
Views: 225

Pi OS - Cannot save setup

I have downloaded Raspberry Pi OS (32-bit) Lite, burnt to SD and booted my Pi. It opens up a window for initial setup, set new password, select language etc. I go through that, looks OK, I tell it to reboot and it does. When it restarts, however, it displays the initial startup screen again. How do ...
by micksulley
Fri May 29, 2020 8:42 am
Forum: Troubleshooting
Topic: Unison sync error
Replies: 1
Views: 193

Re: Unison sync error

I have done more testing and it errors for any Unison sync which includes a Pi. I am all Linux, Mint for desktop & Ubuntu server. I can run Unison desktop > server and server > desktop and it is fine, but sync between server and Pi, desktop and Pi, or Pi to Pi fails with - Fatal error: Fatal error d...
by micksulley
Mon May 25, 2020 10:45 pm
Forum: Troubleshooting
Topic: Unison sync error
Replies: 1
Views: 193

Unison sync error

I am hitting an error when trying to sync with Unison. I use it on other machines, Mint & Ubuntu, without problem, but I get an error on my Pi's. I just tried a simple case pi to pi. Both are updated, both running Raspian 4.19.97 and unison version 2.48.4 When I run it I get pi@pi4A:~ $ unison utest...
by micksulley
Sat Dec 07, 2019 11:38 am
Forum: Troubleshooting
Topic: Pi3 Will Not Boot
Replies: 2
Views: 211

Re: Pi3 Will Not Boot

Pin 1 measures 5.5 mV pin 2 is 5.05 V

So it looks like it is off to Pi heaven.

Thanks for your help anyway
Mick
by micksulley
Sat Dec 07, 2019 10:42 am
Forum: Troubleshooting
Topic: Pi3 Will Not Boot
Replies: 2
Views: 211

Pi3 Will Not Boot

I have a Pi3 B+ which was working but now will not boot. I have downloaded a fresh Buster lite to my SD, the SD works in another Pi. Pin 2 on GPIO measures 5.05 volts. When I power it up the red led comes on but nothing else. Also the power supply works fine with another Pi. Are there any other fixe...
by micksulley
Mon Dec 02, 2019 9:56 am
Forum: Troubleshooting
Topic: Failed to start Backend server for 1-wire control
Replies: 5
Views: 1419

Re: Failed to start Backend server for 1-wire control

Sorry I had missed this post. I am running with a Sheepwalk adapter. A basic config file (/etc/owfs.conf) is ! server: server = localhost:4304 server: device=/dev/i2c-1 # for modern Pi's, very early ones use i2c-0 You can also test with a fake adapter with server: fake=10.053C8A010800,10.2AFE8901080...
by micksulley
Sun Sep 15, 2019 6:13 pm
Forum: Troubleshooting
Topic: Failed to start Backend server for 1-wire control
Replies: 5
Views: 1419

Re: Failed to start Backend server for 1-wire control - Fixed

OK I think I have fixed it. Looks like my /etc/owfs.conf file was screwed up. I was expecting it to have the default file with the fake server, but that wasn't there. I deleted that and created a new one and it is working again.
by micksulley
Sat Sep 14, 2019 10:40 pm
Forum: Troubleshooting
Topic: Failed to start Backend server for 1-wire control
Replies: 5
Views: 1419

Re: Failed to start Backend server for 1-wire control

Thanks for the reply Dave, at least it is not just me:) I have just rebooted a couple of times, made no difference. I also tried reinstalling owserver and it shows an error - pi@pi-solar-old:~ $ sudo apt-get reinstall owserver Reading package lists... Done Building dependency tree Reading state info...
by micksulley
Sat Sep 14, 2019 8:03 pm
Forum: Troubleshooting
Topic: Failed to start Backend server for 1-wire control
Replies: 5
Views: 1419

Failed to start Backend server for 1-wire control

I have just done a fresh install of Buster and updated. I ran raspi-config and enabled 1-wire and i2c. I have installed owserver ow-shell At first it worked, I could see devices with owdir, but it has stopped working, owdir returns nothing I have run "sudo systemctl enable owserver.service" but I se...
by micksulley
Tue May 21, 2019 1:50 pm
Forum: Troubleshooting
Topic: i2c Enable causes fatal error
Replies: 4
Views: 769

Re: i2c Enable causes fatal error

Yes just done that and it all looks fine now.
by micksulley
Tue May 21, 2019 9:37 am
Forum: Troubleshooting
Topic: i2c Enable causes fatal error
Replies: 4
Views: 769

Re: i2c Enable causes fatal error - FIxed

Yes that has fixed it. Don't understand why, but there are more important things to worry about :)
Thanks for your help
by micksulley
Tue May 21, 2019 8:28 am
Forum: Troubleshooting
Topic: i2c Enable causes fatal error
Replies: 4
Views: 769

i2c Enable causes fatal error

Just did a fresh install of 2019-04-08-raspbian-stretch-lite When I run raspi-config and enable i2c it says it is OK but when I exit I get this message pi@raspberrypi:~ $ sudo raspi-config modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.14.98...
by micksulley
Tue May 14, 2019 8:31 am
Forum: Troubleshooting
Topic: WiFi drops out and will not reconnect
Replies: 15
Views: 3611

Re: WiFi drops out and will not reconnect

Andyroo, this is my /etc/init/ssh.config, I don't believe that I have ever changed it. Is that the file you meant? # ssh - OpenBSD Secure Shell server # # The OpenSSH server provides secure shell access to the system. description "OpenSSH server" start on runlevel [2345] stop on runlevel [!2345] res...
by micksulley
Mon May 13, 2019 10:57 pm
Forum: Troubleshooting
Topic: WiFi drops out and will not reconnect
Replies: 15
Views: 3611

Re: WiFi drops out and will not reconnect

It doesn't look like it pi@pi-porch:~ $ tail -f /var/log/auth.log May 13 23:40:01 pi-porch CRON[1703]: pam_unix(cron:session): session opened for user pi by (uid=0) May 13 23:40:01 pi-porch CRON[1703]: pam_unix(cron:session): session closed for user pi May 13 23:42:01 pi-porch CRON[1715]: pam_unix(c...
by micksulley
Mon May 13, 2019 10:13 pm
Forum: Troubleshooting
Topic: WiFi drops out and will not reconnect
Replies: 15
Views: 3611

Re: WiFi drops out and will not reconnect

It has just happened again, but this time it is slightly different. What I see this time is mick@Mint19Desk ~ $ ssh pi@pi-porch ssh_exchange_identification: read: Connection reset by peer If I use verbose mode mick@Mint19Desk ~ $ ssh -v pi@pi-porch OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n 7 D...
by micksulley
Fri May 10, 2019 10:16 pm
Forum: Troubleshooting
Topic: WiFi drops out and will not reconnect
Replies: 15
Views: 3611

Re: WiFi drops out and will not reconnect

Thank you both for your help, I now have a script that I think works, but cannot figure out the @reboot bit. My script has a line at the begining /usr/bin/logger "##### start of WiFiWake.sh ######" If I run the script directly I see that message in /var/log/syslog I have tried adding the line @reboo...

Go to advanced search