Go to advanced search

by presish
Thu Dec 05, 2019 6:53 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

Re: custom settings no longer working on Buster

From your duplicate thread (now locked) Hi all, I just installed a Buster OS (release date: 2019-08-26) on the Pi4. I did "apt update" and "apt upgrade" and "rpi-update". I am still unable to change my resulting images auto-white balance gain values. I have read reports on the AWB algorithm not wor...
by presish
Tue Dec 03, 2019 7:25 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

Re: custom settings no longer working on Buster

It was a firmware fix several months ago. I changed nothing, just tested it. Did it work on raspistill? Also, posted requested info in reply above. Do you have a detailed procedure to follow so I can test out the same image/updates/etc... you did? Not sure why my setup isn't working. NOTE: I would ...
by presish
Mon Dec 02, 2019 6:43 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

Re: custom settings no longer working on Buster

It was a firmware fix several months ago. I changed nothing, just tested it. My version using "sudo vcgencmd version" is: Sep 24 2019 17:36:31 version cd3add54955f8fa065b414d8fc07c525e7ddffc8 (clean) (release) (start_x) ------ Did you get it to work with raspistill? Command I am running: sudo raspi...
by presish
Fri Nov 29, 2019 5:47 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

Re: custom settings no longer working on Buster

Is this a fix for raspistill? I will post the version results Monday as I am away from the setup currently.

Does this work for any buster release? I have the release with the Desktop option.
by presish
Thu Nov 28, 2019 2:03 am
Forum: Camera board
Topic: AWB Off does not work and fixed whitebalance gains cannot be set
Replies: 15
Views: 1360

Re: AWB Off does not work and fixed whitebalance gains cannot be set

The PiCamera fix that was reference as available 4 Sept 2019 does indeed allow the gain to be adjusted manually on the Pi 4, but, setting gain controls back to auto after setting gains manually now does not work(gains stay fixed). Also setting the camera mode up to use ISO above 200 now produces st...
by presish
Thu Nov 28, 2019 1:27 am
Forum: Camera board
Topic: Pi4 AWB values not working
Replies: 1
Views: 104

Pi4 AWB values not working

Hi all, I just installed a Buster OS (release date: 2019-08-26) on the Pi4. I did "apt update" and "apt upgrade" and "rpi-update". I am still unable to change my resulting images auto-white balance gain values. I have read reports on the AWB algorithm not working on this new version. Is there a fix ...
by presish
Thu Oct 31, 2019 8:48 pm
Forum: Networking and servers
Topic: Raspberry Pi 3B+ WiFi Adapter
Replies: 2
Views: 416

Re: Raspberry Pi 3B+ WiFi Adapter

How do you know which WiFi chip it is using? Is there a way to determine priority? From your testing it seems the dongle gives your more range than default Pi WiFi chip. Do you have specs on the Pi WiFi chip vs yours?
by presish
Tue Oct 29, 2019 8:29 pm
Forum: Networking and servers
Topic: Raspberry Pi 3B+ WiFi Adapter
Replies: 2
Views: 416

Raspberry Pi 3B+ WiFi Adapter

I know the Pi 3B+ already has WiFi built-in. Can I improve WiFi range/signal strength by using a dongle instead? What are the specs of the WiFi already on the Pi? How easy is it to setup a dongle as priority for WiFi connectivity?
by presish
Tue Oct 29, 2019 5:51 pm
Forum: Networking and servers
Topic: Raspberry Pi 3B+ WiFi adapter Range
Replies: 3
Views: 597

Re: Raspberry Pi 3B+ WiFi adapter Range

Is it possible to improve WiFi strength with an external USB dongle on the pi?
by presish
Thu Oct 24, 2019 8:48 pm
Forum: Other programming languages
Topic: command line expand pi filesystem
Replies: 2
Views: 692

Re: command line expand pi filesystem

If you don't really need a shell one-liner, I'd recommend using gparted, which has a nice GUI and is more foolproof. Otherwise, this *should* work, but as always you should have a backup if you're not prepared to lose what's on that partition. Also, I'm assuming your USB-attached disk is on /dev/sd...
by presish
Thu Oct 24, 2019 7:56 pm
Forum: Other programming languages
Topic: command line expand pi filesystem
Replies: 2
Views: 692

command line expand pi filesystem

I have my image on a USB and need to expand the filesystem ideally with a ONE liner. The commands I have to manually execute, that I would like help combining, are below: sudo bash sed -E 's/mmcblk0p?/sda/' /usr/bin/raspi-config | bash raspi-config --expand-rootfs I basically have to tell raspi-conf...
by presish
Thu Oct 10, 2019 9:53 pm
Forum: Networking and servers
Topic: Raspberry Pi 3B+ WiFi adapter Range
Replies: 3
Views: 597

Re: Raspberry Pi 3B+ WiFi adapter Range

Yes I notice in house I hardly if ever have issues. For some reason outdoors is not stable. I am starting to wonder if it could just be a power issue instead of a signal issue (since my phone outdoors records 2Mbps WiFi connection where the unit is).
by presish
Wed Oct 09, 2019 6:52 pm
Forum: Networking and servers
Topic: Raspberry Pi 3B+ WiFi adapter Range
Replies: 3
Views: 597

Raspberry Pi 3B+ WiFi adapter Range

Hi Group, I am curious if there is any data on this. I have a Pi that works fine indoors 20 feet away from WiFi as expected. I take the Pi outside maybe 100 feet away and it fails to catch a signal. What is the range the WiFi adapter can still hold/detect a signal? Is there a chart on performance by...
by presish
Thu Sep 26, 2019 7:00 pm
Forum: Camera board
Topic: awb off, awbg custom not working on BUSTER
Replies: 0
Views: 127

awb off, awbg custom not working on BUSTER

Hi group,

I turned off awb on raspistill and am using custom awbg raspistill command but no matter the awbg values the images all look the same. Using same command format from Jessie. I have already done update, upgrade, and rpi-upgrade. What can I do to make awbg work again?
by presish
Tue Sep 24, 2019 5:24 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

Re: custom settings no longer working on Buster

sudo apt update sudo apt upgrade Looking at the current distribution, the package was updated 19th August. I'd need to check whether the AWB gains fix was included in that, but it's simpler for you to upgrade anyway and check for yourself. If it's not fixed, then you could use "sudo rpi-update" to ...
by presish
Fri Sep 20, 2019 10:01 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

Re: custom settings no longer working on Buster

Just did an "rpi-update" and still nothing. no matter the awbg values i put its all the same image.
by presish
Fri Sep 20, 2019 9:44 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

Re: custom settings no longer working on Buster

I did:

sudo apt update
sudo apt upgrade

awbg settings still are not changing image colors. So you suggest "rpi-update"??? I just remember this being a death sentence in prior OS
by presish
Fri Sep 20, 2019 5:15 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

Re: custom settings no longer working on Buster

Please update and provide the output from "vcgencmd version". There was a bug related to the new awb algorithm, but that should have been fixed and I believe released through apt. Jul 9 2019 14:42:57 Copyright (c) 2012 Broadcom version 6c3fe3f096a93de3b34252ad98cdccadeb534be2 (clean) (release) (sta...
by presish
Thu Sep 19, 2019 9:27 pm
Forum: Camera board
Topic: custom settings no longer working on Buster
Replies: 12
Views: 639

custom settings no longer working on Buster

Hi Group, I have been using fully customized settings on my Jessie OS for image capture (-awb off... -ISO 200 -ss 1000000 -awbg 8,8....). No matter what I change the images all look the same color wise on my Buster OS. The ISO does effect the image but the gain values no longer do. Is this a bug or ...
by presish
Thu Sep 12, 2019 9:41 pm
Forum: Other projects
Topic: Pushbutton multiple inputs
Replies: 12
Views: 702

Re: Pushbutton multiple inputs

THANK YOU! That appears to have fixed it. I used the Pull down Circuit. Wiring the open circuit to GND was the part I needed to hold the signal LOW.
by presish
Fri Aug 30, 2019 10:27 pm
Forum: Other projects
Topic: Pushbutton multiple inputs
Replies: 12
Views: 702

Re: Pushbutton multiple inputs

So I need to connect a resistor between the GPIO pin and one of the Ground Pins on the Pi to keep it at 0?
by presish
Fri Aug 30, 2019 10:26 pm
Forum: Other projects
Topic: Pushbutton multiple inputs
Replies: 12
Views: 702

Re: Pushbutton multiple inputs

by External Ground I mean the Ground for my Power supply for the Pi .
by presish
Fri Aug 30, 2019 5:24 pm
Forum: Other projects
Topic: Pushbutton multiple inputs
Replies: 12
Views: 702

Re: Pushbutton multiple inputs

Would the external pull down resistor connect GPIO on Pi to GND on Pi? Or External Ground?
by presish
Thu Aug 29, 2019 11:56 pm
Forum: Other projects
Topic: Pushbutton multiple inputs
Replies: 12
Views: 702

Re: Pushbutton multiple inputs

So basically you are saying if the button was wired to 3.3V and GPIO from the beginning with PD resistor enabled via SW, I should not see random inputs triggered on that pin?
by presish
Thu Aug 29, 2019 10:16 pm
Forum: Other projects
Topic: Pushbutton multiple inputs
Replies: 12
Views: 702

Re: Pushbutton multiple inputs

Will that wiring cause interrupts to be triggered? Do you advise 5V+divider+SW pull down or GND+SW Pull Up?

Go to advanced search