Go to advanced search

by BitHead
Wed Jun 26, 2019 11:47 am
Forum: Networking and servers
Topic: DHCP-HELPER ... not helping
Replies: 7
Views: 640

Re: DHCP-HELPER ... not helping

Agh! This issue is only about DHCP requests not forwarding/returning - all's good with static IP.
LLT-Responder/Mapper set to enable 'domain' and 'public' does not help.
Maybe it IS DCN - it's not on Win7.
Am giving up. Dasvidania!
by BitHead
Wed Jun 26, 2019 11:16 am
Forum: Networking and servers
Topic: DHCP-HELPER ... not helping
Replies: 7
Views: 640

Re: DHCP-HELPER ... not helping

It seems that Win10 has 'LLDP" things that aren't in Win7 or Stretch. Link-Layer Topology Discovery Responder Link-Layer Topology Discovery Mapper I/O Driver and... Microsoft LLDP Protocol Driver - which is a MS Data Center Networking (DCN) thing - so maybe not relevant. I see LLDP can be apt-get'ed...
by BitHead
Tue Jun 25, 2019 5:11 pm
Forum: Networking and servers
Topic: DHCP-HELPER ... not helping
Replies: 7
Views: 640

Re: DHCP-HELPER ... not helping

Update... Premature 'All's good'. I AM writing this on Win10-64 machine through cable to the Pi to the Wifi router, but... this is the ONLY machine that does it. I can not get another Pi to work. I can not get a Win7 ultimate-32 machine to work. When I 'fing' on this machine it shows ALL the Host 19...
by BitHead
Wed Jun 19, 2019 11:55 am
Forum: Networking and servers
Topic: DHCP-HELPER ... not helping
Replies: 7
Views: 640

Re: DHCP-HELPER ... not helping

So... I WAS sort of right - there WAS something I needed to do that was not mentioned in the Debian Wiki. I needed to create/enable/start a parprouted.service - as per the excellent guidance given by Ingo on raspberrypi.stackexhange.com's question #88954. As per Ingo's instructions, I created file '...
by BitHead
Fri Jun 14, 2019 2:01 pm
Forum: Networking and servers
Topic: DHCP-HELPER ... not helping
Replies: 7
Views: 640

Re: DHCP-HELPER ... not helping

Thanks for the redirect! Now that there is 'ProxyARP failure' and your old post prompting another look into tunneling, I will give PiVPN http://www.pivpn.io/ a try. ... OMG - how easy was that! ( curl -L https://install.pivpn.io | bash ) However, while this is fine for the glued-to-the-bench PC, my ...
by BitHead
Fri Jun 14, 2019 1:35 am
Forum: Networking and servers
Topic: DHCP-HELPER ... not helping
Replies: 7
Views: 640

DHCP-HELPER ... not helping

Yay! I followed the steps outlined in the Debian-WIki BridgeNetworkConnectionsProxyArp and it works... almost. I have a Windows PC getting internet from RPI(2B) via eth0 via wlan0(tiny generic 802.11n USB plug) via WiFi router on other side of building! But... only when the Windows PC has IPv4 addre...
by BitHead
Fri Mar 22, 2019 6:44 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: POE on B+ pinout confusion
Replies: 2
Views: 260

POE on B+ pinout confusion

Hi all - I'm looking for something I would think would be a simple thing to find... A document/image with an arrow pointing to Pin#1 (and maybe #2,3,4) of the POE header on the B+. I have seen the schematic - I have seen a picture of the GPIO pins, and ... (Sorry - if this forum allowed images from ...
by BitHead
Fri Nov 17, 2017 3:59 pm
Forum: Python
Topic: Code for LED matrix with shift registers.
Replies: 8
Views: 1901

Re: Code for LED matrix with shift registers.

Use that 8x8 matrix code and 'pretend' it is going to LED matrix - but really write it to an 8x8 array in ram. Then, using a timer-interrupt, write a routine that reads that array and turns bit positions into 'Y' register columns for each of your 8 'X' register rows. 20mS human eye flicker perceptio...
by BitHead
Tue Oct 07, 2014 12:08 am
Forum: Other programming languages
Topic: Gambas - run `aplay' while Ser.Port=OPEN
Replies: 1
Views: 912

Gambas - run `aplay' while Ser.Port=OPEN

Can't receive characters via VCP ( FTDI-USB-Virtual-COM-Port ) (aka Serial Port) and play a `.wav' file using aplay without an eventual freeze-up. (As in "Sorry. No logged info/clues." ) It seems to run aplay fine if I `SerialPort.Close' first - but then I don't see any characters for the duration. ...
by BitHead
Sun Oct 05, 2014 11:25 pm
Forum: General discussion
Topic: `Play Audio' -AND- `Serial_Port=OPEN' ?
Replies: 0
Views: 282

`Play Audio' -AND- `Serial_Port=OPEN' ?

Have you done that? Say, plug an FTDI-based Arduino-on-a-stick that's sending out little message strings into the USB port, write your program to open the serial port, post the messages to a text box or something and THEN play a WAV file with aplay. Does it work a couple of times and then freeze-up?...
by BitHead
Thu Oct 02, 2014 7:10 pm
Forum: General programming discussion
Topic: Raspi freezing - running aplay & FTDI serial port=open
Replies: 1
Views: 811

Re: Raspi freezing - running aplay & FTDI serial port=open

Addendum... in case it matters - it's running Linux ver. 3.10.25+ (Jan. 2014 Wheezy). Also, the random number of successes before freeze-up may be due to the random timing of incoming messages to the VCP receive buffer - which generate an interrupt call to the SerialPort_Read() function. Mostly I'd ...
by BitHead
Wed Oct 01, 2014 2:02 pm
Forum: General programming discussion
Topic: Raspi freezing - running aplay & FTDI serial port=open
Replies: 1
Views: 811

Raspi freezing - running aplay & FTDI serial port=open

I'm trying to find out if this is a Raspi thing or a GAMBAS thing. My GAMBAS program would like to audibly announce the arrival of a matching string from the USB-connected FTDI Virtual Com Port (VCP). With GAMBAS3.5.2, I run `Exec[ "usr/bin/aplay","my_wav_file.wav"] WAIT' just fine - if I close the ...
by BitHead
Wed Oct 01, 2014 1:13 pm
Forum: Other programming languages
Topic: Problem with html and usb key
Replies: 3
Views: 806

Re: Problem with html and usb key

It's time to expeiment... can you change the link to include more of the path - like `/home/pi/media/key/file01.html' - and report back?
by BitHead
Fri Sep 26, 2014 5:07 pm
Forum: Python
Topic: Error in sound over HDMI via a Python script
Replies: 1
Views: 1221

Re: Error in sound over HDMI via a Python script

Yeah, it's a few months later, but I just had an anecdotal observation... My similar problem involves using Gambas3.5.2 to issue `Exec ["usr/bin/aplay /home/pi/sounds/ding.wav"] Wait ' commands at the request of a routine that looks for a string match on the characters coming in the Serial Port. I d...
by BitHead
Wed Sep 03, 2014 1:21 pm
Forum: General discussion
Topic: Micro SD card corrupt [solved]
Replies: 13
Views: 4657

Re: Micro SD card corrupt

Found this - http://www.instructables.com/id/How-to- ... iginal-si/ - perhaps it needs the re-partition treatment?

Go to advanced search