Go to advanced search

by raspiCAM
Tue Jun 21, 2016 8:14 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Changing CLK frequency on pin GPIO_CLK
Replies: 13
Views: 3196

Re: Changing CLK frequency on pin GPIO_CLK

Thanks Joan. Have a nice day :) Hi Joan, To answer my previous question, I do a sleep time_sleep after second wave. Then second wave changed to PI_WAVE_MODE_REPEAT_SYNC, let it repeat for 5 seconds. Program will jump to wave 3 for ramp down after 5 seconds. Please advise me if there are better solut...
by raspiCAM
Tue Jun 21, 2016 3:48 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Changing CLK frequency on pin GPIO_CLK
Replies: 13
Views: 3196

Re: Changing CLK frequency on pin GPIO_CLK

Hi Joan, To answer my previous question, I do a sleep time_sleep after second wave. Then second wave changed to PI_WAVE_MODE_REPEAT_SYNC, let it repeat for 5 seconds. Program will jump to wave 3 for ramp down after 5 seconds. Please advise me if there are better solution from your side. Thanks. Leav...
by raspiCAM
Mon Jun 20, 2016 9:18 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Changing CLK frequency on pin GPIO_CLK
Replies: 13
Views: 3196

Re: Changing CLK frequency on pin GPIO_CLK

Hi Joan, Please check if this code correct? From the scope it looks good to me, I will test with motor ASAP. I do ramp up with one shot sync,then I always loop until I need to stop the wave. I can't use repeat sync, it will always repeat at ramp down wave. One more question, how to let the wave keep...
by raspiCAM
Mon Jun 20, 2016 5:37 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Changing CLK frequency on pin GPIO_CLK
Replies: 13
Views: 3196

Re: Changing CLK frequency on pin GPIO_CLK

[/quote] The Python I posted should be smooth to 200kHz and beyond and uses DMA.[/quote] Hi Joan, I have tried your "gpioWaveChain" & "gpioWaveTxSend". gpioWaveChain work well with different pulse wave accordingly to setting such as 255,3 loop forever or loop how many times. gpioWaveTxSend work well...
by raspiCAM
Wed Feb 24, 2016 2:41 am
Forum: Compute Module
Topic: pi freeze up when I2C1 is running together with raspistill
Replies: 1
Views: 755

pi freeze up when I2C1 is running together with raspistill

Hi All, Good day. I'm using compute module kernel version Linux raspberrypi 4.1.13+ #826 PREEMPT Fri Nov 13 20:13:22 GMT 2015 armv6l GNU/Linux. I'm running this code with connection GPIO2 & GPIO3 which is I2C1. I2C = wiringPiI2CSetup(0x51); wiringPiI2CWriteReg8 (I2C, 0, value) ; If I2C1 is running t...
by raspiCAM
Mon Feb 15, 2016 7:10 am
Forum: Compute Module
Topic: compute module USB failure can't do rpiboot
Replies: 0
Views: 618

compute module USB failure can't do rpiboot

Hi, I have 2 CM and 1 compute module development kit., 1 of both CM suddenly failed on USB and LAN networking (can boot up and running x window etc). No light on Ethernet socket and both USB not working with custom GPIO board that using LAN9512. So I insert this CM on development kit to re-flash OS,...
by raspiCAM
Thu Jan 21, 2016 7:39 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Changing CLK frequency on pin GPIO_CLK
Replies: 13
Views: 3196

Re: Changing CLK frequency on pin GPIO_CLK

Hi Joan & jdb, Thanks for answering my question. If I reduce my requirement to toggle an IO pin maximum 6khz speed. Is this easier to achieve? I have tried to toggle via wiringPi. So far so good but stepper will stall if I access to LCD touch screen or do something in raspi. I suspect Linux task sc...
by raspiCAM
Thu Jan 21, 2016 6:49 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Changing CLK frequency on pin GPIO_CLK
Replies: 13
Views: 3196

Re: Changing CLK frequency on pin GPIO_CLK

Hi Joan & jdb, Thanks for answering my question. If I reduce my requirement to toggle an IO pin maximum 6khz speed. Is this easier to achieve? I have tried to toggle via wiringPi. So far so good but stepper will stall if I access to LCD touch screen or do something in raspi. I suspect Linux task sch...
by raspiCAM
Thu Jan 21, 2016 10:00 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Changing CLK frequency on pin GPIO_CLK
Replies: 13
Views: 3196

Re: Changing CLK frequency on pin GPIO_CLK

It won't be smooth if you keep stop/starting the clock. What are you actually trying to achieve, i.e. what are you trying to drive? Hi Joan, I need to generate frequency for stepper motor driver. It need to start from low frequency and slowly increase frequency to increase motor speed. Around 5khz ...
by raspiCAM
Thu Jan 21, 2016 9:40 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Changing CLK frequency on pin GPIO_CLK
Replies: 13
Views: 3196

Changing CLK frequency on pin GPIO_CLK

Hi All, Now I am using wiringPi library gpioClockSet() function to set frequency on CLK pin. I need a smooth frequency from 5k to 100KHz. When CLK pin operating, I keep calling same function gpioClockSet() and increasing the frequency. I feel that output frequency not stable during frequency change,...
by raspiCAM
Mon Nov 09, 2015 10:04 am
Forum: Device Tree
Topic: Need some advise on device tree over lay
Replies: 2
Views: 1552

Re: Need some advise on device tree over lay

That line enables a one-wire (w1) bus bit-bashed (i.e. the CPU does all of the protocol handling - no hardware accelation) over a GPIO pin. The gpiopin parameter tells it to use GPIO 4. This configuration line should never be part of a standard Raspberry Pi release because, as you've found, not eve...
by raspiCAM
Mon Nov 09, 2015 7:25 am
Forum: Device Tree
Topic: Need some advise on device tree over lay
Replies: 2
Views: 1552

Need some advise on device tree over lay

Hi All, dtoverlay=w1-gpio-pullup,gpiopin=4,extpullup=1 I saw this line under config.txt. This line causing my GPIO pin 4 always set as input and pull high. I have tried to do "gpio mode 4 out" and "gpio write 4 0", then "gpio readall" output looks ok for few seconds and it return back to input pull ...
by raspiCAM
Thu Oct 29, 2015 1:41 am
Forum: Device Tree
Topic: Changing dt-blob file to swith CAM 0 & 1
Replies: 13
Views: 3543

Re: Changing dt-blob file to swith CAM 0 & 1

Hi Mod & 6by9,

Good morning.

No idea why today it's working.... :lol:

Thanks for all your help. Appreciated it.
by raspiCAM
Wed Oct 28, 2015 5:47 pm
Forum: Device Tree
Topic: Changing dt-blob file to swith CAM 0 & 1
Replies: 13
Views: 3543

Re: Changing dt-blob file to swith CAM 0 & 1

So I suggested some things you could do to see if the blob was valid and being used. Try them. Hi mod, Now it's midnight in Singapore, so tomorrow only I can test it. If I test and proved dt blob not being used. Any step I can try to make it valid? I have enabled device tree in raspi-config. When I...
by raspiCAM
Wed Oct 28, 2015 5:38 pm
Forum: Device Tree
Topic: Changing dt-blob file to swith CAM 0 & 1
Replies: 13
Views: 3543

Re: Changing dt-blob file to swith CAM 0 & 1

So a single camera is connected to CAM1 and appears as CAMERA_0, while a second camera should be connected to CAM0 and appears as CAMERA_1 - not at all confusing. Anyway, with that resolved there is nothing obviously wrong with your configuration. And from what I can see there are no hard-coded val...
by raspiCAM
Wed Oct 28, 2015 5:34 pm
Forum: Device Tree
Topic: Changing dt-blob file to swith CAM 0 & 1
Replies: 13
Views: 3543

Re: Changing dt-blob file to swith CAM 0 & 1

It's not swapped the connectors that the cameras will connect to, only the I2C and shutdown pins. So the link cables need to change but nothing else. To change the connector for each camera would require changes to CAMERA_x_UNICAM_PORT, as those are hard wired through from the camera connectors to ...
by raspiCAM
Wed Oct 28, 2015 9:50 am
Forum: Device Tree
Topic: Changing dt-blob file to swith CAM 0 & 1
Replies: 13
Views: 3543

Re: Changing dt-blob file to swith CAM 0 & 1

But after reboot it still using pin 28&29 for CAM0 instead of pin 0&1. pin_define@CAMERA_0_SDA_PIN { type = "internal"; number = <28>; }; pin_define@CAMERA_0_SCL_PIN { type = "internal"; number = <29>; }; ... pin_define@CAMERA_1_SDA_PIN { type = "internal"; number = <0>; }; pin_define@CAMERA_1_SCL_...
by raspiCAM
Wed Oct 28, 2015 9:44 am
Forum: Device Tree
Topic: Changing dt-blob file to swith CAM 0 & 1
Replies: 13
Views: 3543

Re: Changing dt-blob file to swith CAM 0 & 1

But after reboot it still using pin 28&29 for CAM0 instead of pin 0&1. pin_define@CAMERA_0_SDA_PIN { type = "internal"; number = <28>; }; pin_define@CAMERA_0_SCL_PIN { type = "internal"; number = <29>; }; ... pin_define@CAMERA_1_SDA_PIN { type = "internal"; number = <0>; }; pin_define@CAMERA_1_SCL_...
by raspiCAM
Wed Oct 28, 2015 5:12 am
Forum: Device Tree
Topic: Changing dt-blob file to swith CAM 0 & 1
Replies: 13
Views: 3543

Changing dt-blob file to swith CAM 0 & 1

Hi All, I was trying to switch pin 0&1 for CAM 0 in dt-blob but no effect. By default CAM 1 assigned pin 0 & 1. And CAM0 assigned pin 28&29. I have changed my dt-blob file as below and recompiled to bin file in boot folder. But after reboot it still using pin 28&29 for CAM0 instead of pin 0&1. Do I ...
by raspiCAM
Wed Oct 28, 2015 5:06 am
Forum: Compute Module
Topic: Problem with Compute Modul
Replies: 1
Views: 562

Re: Problem with Compute Modul

you need to run rpiboot.exe application.
you can find it under driver installation
by raspiCAM
Tue Dec 23, 2014 1:16 am
Forum: Compute Module
Topic: Compute Module GPIO Not Working
Replies: 7
Views: 1701

Re: Compute Module GPIO Not Working

Check the position of the VG0 and VG1 select jumpers, these set the GPIO voltage reference levels, if they are missing it could explain your problem Gordon Hi Gordon, VG0 and VG1 jumpers always there. Please read my question again. I have 2 compute module that swap on same IO board. If 1 CM can wor...
by raspiCAM
Mon Dec 22, 2014 10:12 am
Forum: Compute Module
Topic: Compute Module GPIO Not Working
Replies: 7
Views: 1701

Re: Compute Module GPIO Not Working

That does sound wrong. I don't have a compute module so am not sure if this is feasible. For my own interest could you try to run the gpio test from http://abyz.co.uk/rpi/pigpio/examples.html#Shell_code (needs the pigpio daemon to be running). If you have wiringPi installed you could try its pin te...
by raspiCAM
Mon Dec 22, 2014 9:36 am
Forum: Compute Module
Topic: Compute Module GPIO Not Working
Replies: 7
Views: 1701

Re: Compute Module GPIO Not Working

joan wrote:What tests are you doing?

Please don't make us guess.
Just a simple C file that take trigger from button switch and display some text on GTK GUI when GPIO 0,1,2,triggered.

1 CM can work when button pressed. Another board has no respond when button pressed.

What else information you need?
by raspiCAM
Mon Dec 22, 2014 8:01 am
Forum: Compute Module
Topic: Compute Module GPIO Not Working
Replies: 7
Views: 1701

Compute Module GPIO Not Working

Hi All, I have bought 2 CM for raspberry PI. Both card I have flashed with same OS. But 1 CM can operate properly for GPIO trigger. Another board not working. Please advise me if 1 of my board got problem or some setup not doing correctly? I have tried to re-flash many times, always same board worki...
by raspiCAM
Tue Dec 16, 2014 12:00 pm
Forum: Compute Module
Topic: OpenCV Build In 4GB compute Module
Replies: 31
Views: 8471

Re: OpenCV Build In 4GB compute Module

gsh wrote:I'd suggest using buildroot, google "raspberry pi buildroot" for instructions but basically

Code: Select all

git clone git://git.buildroot.net/buildroot
ARCH=arm PROJECT=RPi make
then copy the files from the target directory to create the sdcard image...

Gordon
Thanks gordon~
I will give it a try~

Go to advanced search