Go to advanced search

by balanga
Tue Mar 26, 2019 9:00 am
Forum: Media centres
Topic: Text mode audio player using UPnP
Replies: 0
Views: 315

Text mode audio player using UPnP

I would like tike to use my RPi B as a music player using something like mpg123 to play music via UPnP from a Minidlna server. Is this possible? I know mpg123 can take input from a URL, but can I specify a minidlna server using upnp:// ? I've seen Kodi use some long undecipherable string after upnp:...
by balanga
Fri Mar 22, 2019 9:52 pm
Forum: General discussion
Topic: MicroSD slot broken
Replies: 1
Views: 128

MicroSD slot broken

I have an RPi 2 which does not retain a microSD card, ie it does fix in place when inserted. When a card is fully inserted I see the rainbow flash and that's all, except when one particular installation in which a screenful of text flashes by before rebooting.

Is there any way to fix it?
by balanga
Fri Feb 15, 2019 11:01 pm
Forum: HATs and other add-ons
Topic: Please explain some code
Replies: 0
Views: 511

Please explain some code

I pinched some code from somewhere for monitoring a PIR and don't really know how it works.... # Alarm program by Francesco Balsamo # # Using a PIR sensor with inverted logic # from time import sleep import pifacedigitalio as pfio # import piface.pfio as pfio pfio.init() while(True): for pin_number ...
by balanga
Mon Dec 10, 2018 5:07 pm
Forum: Networking and servers
Topic: Help with Wi-Fi
Replies: 11
Views: 520

Re: Help with Wi-Fi

One problem I have noticed with Wi-Fi is the IP address assigned is sometimes 169.254.116.184. This depends on where I use my RPi... That's a link-local / APIPA address. If you don't get an address from a DHCP server (and no address manually configured) you will get this. Why don't I get an IP addr...
by balanga
Mon Dec 10, 2018 12:59 pm
Forum: Networking and servers
Topic: Help with Wi-Fi
Replies: 11
Views: 520

Re: Help with Wi-Fi

One problem I have noticed with Wi-Fi is the IP address assigned is sometimes 169.254.116.184. This depends on where I use my RPi...

Does it depend on the distance from the router?

Would running iwlist wlan0 scan reveal anything?
by balanga
Mon Dec 10, 2018 12:52 pm
Forum: Networking and servers
Topic: Help with Wi-Fi
Replies: 11
Views: 520

Re: Help with Wi-Fi

DirkS wrote:
Mon Dec 10, 2018 11:03 am
balanga wrote:
Mon Dec 10, 2018 10:38 am
I could comment it out and Wi-Fi continued to work,
Does it survive a reboot?
Yes
by balanga
Mon Dec 10, 2018 10:38 am
Forum: Networking and servers
Topic: Help with Wi-Fi
Replies: 11
Views: 520

Re: Help with Wi-Fi

You do need to have a country code for your WiFi. Thanks for that! I used raspi-config to set up Wi-Fi and now it works, although I'm not sure how.... After setting country code I saw that COUNTRY=XX was added to /etc/wpa_supplicant/wpa_supplicant.conf but I found I could comment it out and Wi-Fi c...
by balanga
Sun Dec 09, 2018 4:57 pm
Forum: Networking and servers
Topic: Help with Wi-Fi
Replies: 11
Views: 520

Re: Help with Wi-Fi

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1


network={
    ssid="2.4G-Tulipan"
    psk="password"
#    proto=WPA
#    key_mgmt=WPA-PSK
}
The commented lines are things I tried to get it working...
by balanga
Sun Dec 09, 2018 1:52 pm
Forum: Networking and servers
Topic: Help with Wi-Fi
Replies: 11
Views: 520

Help with Wi-Fi

I have followed the guide (https://www.raspberrypi.org/documentation/configuration/wireless/README.md) for setting up wireless networking but don't get an IP address assigned. If I run iwlist wlan0 scan I do see the SSID I have in my /etc/wpa_supplicant/wpa_supplicant.conf. Can I tell if it is a sec...
by balanga
Mon Nov 19, 2018 9:11 pm
Forum: Networking and servers
Topic: Network configuration
Replies: 1
Views: 936

Network configuration

Where is network configuration setup? Various sources such as https://stackoverflow.com/questions/20251320/default-settings-raspberry-pi-etc-network-interfaces point to /etc/network/interfaces but mine only mentions:- source-directory /etc/network/interfaces.d How do I tell which interfaces are pres...
by balanga
Mon Nov 19, 2018 10:31 am
Forum: HATs and other add-ons
Topic: Connecting a PIR to PiFace Digital 2
Replies: 3
Views: 1976

Re: Connecting a PIR to PiFace Digital 2

PhatFil wrote:
Fri Nov 16, 2018 9:08 pm

it might be an idea to start with an led blink project to get you familiar with addressing different pins first.
I can make an LED blink without any problems using the PiFace Digital2. What I can't figure out is where to hook up the three wires from the PIR.
by balanga
Fri Nov 16, 2018 7:11 pm
Forum: HATs and other add-ons
Topic: Connecting a PIR to PiFace Digital 2
Replies: 3
Views: 1976

Connecting a PIR to PiFace Digital 2

I'm trying to get a PIR https://projects.raspberrypi.org/en/projects/physical-computing/13 working with a PiFace Digital2 http://www.piface.org.uk/static/img/piface_digital_2/pifacedigital2_diagram.png.... It seems simple enough - there are three pins/wires Vcc, Gnd, and Out. Where do I connect Out?...
by balanga
Thu Nov 08, 2018 3:05 pm
Forum: Automation, sensing and robotics
Topic: pifacedigitalio stopped working on PI 2 after last upgrade.
Replies: 13
Views: 8548

Re: pifacedigitalio stopped working on PI 2 after last upgrade.

Managed to get it working finally after much trial and error, although I would like to see some simplified instructions for getting it installed from scratch on a new installation. Write up the instructions and publish on a blog somewhere. Re-write the instructions and do a pull request (PR) agains...
by balanga
Tue Nov 06, 2018 9:27 pm
Forum: Automation, sensing and robotics
Topic: spi.py
Replies: 4
Views: 396

Re: spi.py

After some rummaging around it appears that setting SPI on consists of uncommenting

#dtparam=spi=on

in

/boot/config.txt

Can anyone confirm?

Presumably a reboot is required to make it effective...
by balanga
Tue Nov 06, 2018 1:27 pm
Forum: Automation, sensing and robotics
Topic: spi.py
Replies: 4
Views: 396

Re: spi.py

To enable SPI I have to run raspi-config then select 5 - Interface Options -> P4 SPI.

What does this actually do? ie which files are actually affected?
by balanga
Mon Nov 05, 2018 2:34 pm
Forum: HATs and other add-ons
Topic: No PiFace Digital board detected
Replies: 10
Views: 1092

Re: No PiFace Digital board detected

It seems the problem was due to SPI.PY not being updated to the latest version.

Have things working properly now.
by balanga
Mon Nov 05, 2018 2:32 pm
Forum: Automation, sensing and robotics
Topic: pifacedigitalio stopped working on PI 2 after last upgrade.
Replies: 13
Views: 8548

Re: pifacedigitalio stopped working on PI 2 after last upgrade.

Managed to get it working finally after much trial and error, although I would like to see some simplified instructions for getting it installed from scratch on a new installation.
by balanga
Fri Nov 02, 2018 2:28 pm
Forum: HATs and other add-ons
Topic: TV Hat - HD
Replies: 14
Views: 1119

Re: TV Hat - HD

I've only just come across the TV Hat and wondered if anyone knew if there was a satellite version in the pipeline - ie DVB-S2....
by balanga
Fri Nov 02, 2018 2:24 pm
Forum: HATs and other add-ons
Topic: No PiFace Digital board detected
Replies: 10
Views: 1092

Re: No PiFace Digital board detected

Many thanks.
by balanga
Fri Nov 02, 2018 2:17 pm
Forum: Automation, sensing and robotics
Topic: spi.py
Replies: 4
Views: 396

spi.py

I have two files called spi.py:-

/usr/local/lib/python3.5/dist-packages/pifacecommon/spi.py
/usr/lib/python3/dist-packages/pifacecommon/spi.py

How do I tell which is being used when I enable the SPI kernel module using raspi-config? and how would I go about enabling the other one?
by balanga
Fri Nov 02, 2018 12:33 pm
Forum: Automation, sensing and robotics
Topic: pifacedigitalio stopped working on PI 2 after last upgrade.
Replies: 13
Views: 8548

Re: pifacedigitalio stopped working on PI 2 after last upgrade.

I've just hit this 'No PiFace Digital board detected ' problem, and am not exactly sure how to fix it. Can anyone summarise what steps I need to take to fix it? uname -a shows Linux raspberrypi 4.14.71-v7+ #1145 SMP Fri Sep 21 15:38:35 BST 2018 armv7l GNU/Linux This is on a Raspberry Pi 2 with a PiF...
by balanga
Fri Nov 02, 2018 12:26 pm
Forum: HATs and other add-ons
Topic: No PiFace Digital board detected
Replies: 10
Views: 1092

Re: No PiFace Digital board detected

It seems as though someone who had the same problem managed to fix it:-

https://github.com/piface/pifacedigitalio/issues/36

Not sure that I can follow the fix.....
by balanga
Fri Nov 02, 2018 12:00 pm
Forum: HATs and other add-ons
Topic: No PiFace Digital board detected
Replies: 10
Views: 1092

Re: No PiFace Digital board detected

Is there any way to test a PiFace Digital2 physically? ie not using software.... I do notice a reading of 5V on my multimeter when connecting GND on the green inputs to 5V on the brown outputs on the diagram below: http://www.piface.org.uk/products/piface_digital_2/ Is there any Linux cmd I can run ...
by balanga
Thu Nov 01, 2018 8:16 pm
Forum: HATs and other add-ons
Topic: No PiFace Digital board detected
Replies: 10
Views: 1092

Re: No PiFace Digital board detected

Not sure how to add repos or even how to tell if I'm using Jessie or Stretch....

Code: Select all

uname -a
shows:
Linux raspberrypi 4.14.71-v7+ #1145 SMP Fri Sep 21 15:38:35 BST 2018 armv7l GNU/Linux
Should I run?

Code: Select all

git clone https://github.com/piface
by balanga
Thu Nov 01, 2018 10:24 am
Forum: HATs and other add-ons
Topic: No PiFace Digital board detected
Replies: 10
Views: 1092

Re: No PiFace Digital board detected

Looking at the web page http://www.piface.org.uk/products/piface_digital_2/ , a three things stand out: c) GUTHUB hosts an emulator https://github.com/piface/pifacedigital-emulator - it maybe worth trying that to see if the software has installed correctly... sudo apt-get install python3-pifacedigi...

Go to advanced search