Go to advanced search

by Paul Jurczak
Wed Dec 05, 2012 4:08 pm
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

Hmm. I probably do not understand this correctly, but the only angle I see is from the Omnivision pdf file: lens chief ray angle: 24° I hope I got that wrong as this is pretty narrow in my opinion. I would prefer something like 120 degrees: http://www.alibaba.com/product-gs/516275812/120_degree_wid...
by Paul Jurczak
Tue Dec 04, 2012 1:13 am
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

....... We are using mmal for this (an alternative to openmax, that's a little easier to use). Have a look here for the mmal API: https://github.com/raspberrypi/userland/tree/next/interface/mmal Is Multi-Media Abstraction Layer (MMAL) just Broadcom's API or is it a vendor neutral standard in making?
by Paul Jurczak
Sun Dec 02, 2012 9:20 pm
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

...... Of course, I have assumed that this sensor uses the GPU ISP, and doesn't have its own internal ISP and therefore bypasses the GPU stages - I haven't checked, but I think that its the former! If OV5647 is the sensor you are using, then it does have its own ISP, which can perform auto exposure...
by Paul Jurczak
Sun Dec 02, 2012 10:27 am
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

I think that bus is only accessible from the GPU, but could be wrong - but if you can write it the problem is you now have the GPU and the Arm writing sensor registers which will either confuse the sensor or confuse the GPU, as the sensor is now not doing what it expects. Note the GPU needs to comm...
by Paul Jurczak
Sun Dec 02, 2012 12:05 am
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

Point. Would it be easier (or even possible) to have anyone who wants more control fiddle with lens compensation and the like directly (by hooking the camera module up via I2C and flipping bits in the register) without any modifications to the driver? Can you even do that via I2C? I2C is already av...
by Paul Jurczak
Wed Sep 26, 2012 8:10 am
Forum: Beginners
Topic: Class 10 SDHC OK?
Replies: 20
Views: 42755

Re: Class 10 SDHC OK?

Mushkin SDHC class 10 32GB model MKNSDHCU1 works fine.
by Paul Jurczak
Wed Sep 26, 2012 4:19 am
Forum: C/C++
Topic: eclipse-cdt installation fails on 2012-09-18-wheezy-raspbian
Replies: 9
Views: 2436

Re: eclipse-cdt installation fails on 2012-09-18-wheezy-rasp

plugwash: I didn't remember because I didn't know about it :-) I did apt-get update and eclipse-cdt installed successfully, thank you! Unfortunately it is unbearably slow. I'm glad my initial attempts got derailed and I ended up with Code::Blocks. It looks very similar to Visual Studio, which I have...
by Paul Jurczak
Tue Sep 25, 2012 10:37 am
Forum: C/C++
Topic: eclipse-cdt installation fails on 2012-09-18-wheezy-raspbian
Replies: 9
Views: 2436

Re: eclipse-cdt installation fails on 2012-09-18-wheezy-rasp

I gave up on Eclipse for near future and installed Code::Blocks instead. Installation was smooth, "Hello World" example builds and runs fine. Much less bloat: only 68MB RAM used with project opened.
by Paul Jurczak
Tue Sep 25, 2012 7:52 am
Forum: C/C++
Topic: eclipse-cdt installation fails on 2012-09-18-wheezy-raspbian
Replies: 9
Views: 2436

Re: eclipse-cdt installation fails on 2012-09-18-wheezy-rasp

jackokring, is your image 2012-09-18-wheezy-raspbian? Have you made any changes to repositories list? I added more repositories, but it created problems with other packages missing.
by Paul Jurczak
Mon Sep 24, 2012 10:34 pm
Forum: C/C++
Topic: eclipse-cdt installation fails on 2012-09-18-wheezy-raspbian
Replies: 9
Views: 2436

Re: eclipse-cdt installation fails on 2012-09-18-wheezy-rasp

I tried installing Eclipse only:

Code: Select all

apt-get install eclipse
and the same file is missing. Same thing when installing: ecj-gcj or default-jdk.
by Paul Jurczak
Mon Sep 24, 2012 10:00 pm
Forum: C/C++
Topic: eclipse-cdt installation fails on 2012-09-18-wheezy-raspbian
Replies: 9
Views: 2436

eclipse-cdt installation fails on 2012-09-18-wheezy-raspbian

Hi, I'm trying to install eclipse-cdt on 2012-09-18-wheezy-raspbian (apt-get install eclipse-cdt) and it fails with this message: "Failed to fetch .../libnspr4_4.9.1-1_armhf.deb". Is there any simple workaround?
by Paul Jurczak
Mon Sep 24, 2012 3:04 pm
Forum: Beginners
Topic: Very long resize of 2012-09-18-wheezy-raspbian on 32GB card
Replies: 4
Views: 888

Re: Very long resize of 2012-09-18-wheezy-raspbian on 32GB c

OK, I rebooted with webcam unplugged, extra power plugged, my KVM switch left untouched and it completed resizing in a few minutes. So it was either a power issue or KVM switching (I was working on another PC sharing the monitor, keyboard and mouse).
by Paul Jurczak
Mon Sep 24, 2012 1:48 pm
Forum: Beginners
Topic: Very long resize of 2012-09-18-wheezy-raspbian on 32GB card
Replies: 4
Views: 888

Re: Very long resize of 2012-09-18-wheezy-raspbian on 32GB c

Yes, it shows executing in-line resize and SD access LED is flashing.
by Paul Jurczak
Mon Sep 24, 2012 11:20 am
Forum: Beginners
Topic: Very long resize of 2012-09-18-wheezy-raspbian on 32GB card
Replies: 4
Views: 888

Very long resize of 2012-09-18-wheezy-raspbian on 32GB card

Automatic on-line resize of 2012-09-18-wheezy-raspbian on my 32GB SDHC card (Mushkin) is still going on after more than 3 hours. Is that normal? Similar operation on 2GB card took a very short time.
by Paul Jurczak
Mon Sep 24, 2012 9:17 am
Forum: Beginners
Topic: attempting to solve power issues by switching from 5V to 6V
Replies: 33
Views: 6112

Re: Power issues semi-solved by switching from 5V to 6V

It looks like you have a linear power supply. You need a switching power supply for reliable operation.
by Paul Jurczak
Sun Sep 23, 2012 10:21 am
Forum: Raspbian
Topic: 2012-09-18-weezy-raspbian boot fails with display_rotate
Replies: 9
Views: 3924

Re: 2012-09-18-weezy-raspbian boot fails with display_rotate

192 memory split solves the problem, thank you!
by Paul Jurczak
Sun Sep 23, 2012 7:05 am
Forum: Raspbian
Topic: 2012-09-18-weezy-raspbian boot fails with display_rotate
Replies: 9
Views: 3924

Re: 2012-09-18-weezy-raspbian boot fails with display_rotate

The same problem here: after setting "display_rotate=1" RPi fails to boot (worked fine before). I'm getting only a color test screen and then it goes dark - no discernible error messages.
by Paul Jurczak
Thu Sep 20, 2012 9:04 am
Forum: Troubleshooting
Topic: Unable to burn image to SD Card.
Replies: 22
Views: 8978

Re: Unable to burn image to SD Card.

Adding to my last post: when using Roadkil's Disk Image I select "Physical Disc n" not "Drive x" - otherwise RPi will not boot (see also "SD card doesn't show up in installer Device dropdown" topic).
by Paul Jurczak
Thu Sep 20, 2012 8:22 am
Forum: Troubleshooting
Topic: Unable to burn image to SD Card.
Replies: 22
Views: 8978

Re: Unable to burn image to SD Card.

I tried Win32 Disk Imager 0.5 on Windows 7 and it fails to detect some SD cards, if they don't have small unallocated space (4MB) before the first partition. The cards are visible in File Explorer. I used GParted on Linux to look at and change partition layout. Roadkil's Disk Image 1.6 detects much ...
by Paul Jurczak
Mon Sep 17, 2012 12:44 am
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

Hi Pei,

the camera interface connector (CSI) is marked S5 on my board, see: http://elinux.org/File:Raspi-Model-AB-M ... 9x1024.png

Paul
by Paul Jurczak
Tue Jul 17, 2012 6:22 pm
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

I have two more suggestions (wishful thinking): 1. If lens assembly is removable (can be destructive), it would be useful to have mounting holes for microlens (M12x0.5) holder. Here are two sources: http://www.m12lenses.com/M12-Lens-Holders-s/61.htm http://www.optics-online.com/cmt.asp 2. If there i...
by Paul Jurczak
Sun May 20, 2012 11:06 pm
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

I had hoped to use one of the OV5650 (5 MP) CSI-2 camera modules you can find extremely cheap on ebay (5 EUR). They are usually sold as "iphone 4 rear camera". That hope probably won't be fulfilled. I second this request: $4 on eBay with free shipping - can't beat that! It makes sense to support an...
by Paul Jurczak
Sat May 19, 2012 7:45 pm
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

Can we have four mounting holes in camera PCB, one in each corner?
by Paul Jurczak
Sat May 19, 2012 6:10 pm
Forum: Camera board
Topic: Camera module! (And a picture of JamesH)
Replies: 431
Views: 147836

Re: Camera module! (And a picture of JamesH)

Image scaling down would be very useful since 14Mp is a lot of image processing for relatively slow CPU. I assume IPP can scale down, but is there any support for pixel binning on image sensor itself?

Go to advanced search