Go to advanced search

by AndyPi
Tue Feb 27, 2018 11:36 am
Forum: General discussion
Topic: MPEG2 Patent expires this month
Replies: 19
Views: 8313

Re: MPEG2 Patent expires this month

Seems last patents expired 2 weeks ago! https://www.theregister.co.uk/2018/02/1 ... g2_patent/
by AndyPi
Fri Jul 07, 2017 3:34 pm
Forum: Advanced users
Topic: Pi Zero 1.3, Full Disk Encryption and g_ether?
Replies: 12
Views: 2747

Re: Pi Zero 1.3, Full Disk Encryption and g_ether?

Is it possible that you need to add the g_ether modules into the initramfs and load the modules on kernel cmdline
maybe something like

Code: Select all

MODULES="dwc2 g_ether usb_f_ecm"
in the initramfs config file
by AndyPi
Tue Feb 21, 2017 1:31 pm
Forum: Camera board
Topic: Combining (captured) images with mmal?
Replies: 7
Views: 1253

Re: Combining (captured) images with mmal?

Its possible I think to convert images in to GL textures which can then be processed with shaders. egl_image = eglCreateImageKHR(eglFS->display, EGL_NO_CONTEXT, EGL_IMAGE_BRCM_MULTIMEDIA_Y, (EGLClientBuffer)buf->data, NULL); if (egl_image == EGL_NO_IMAGE_KHR) Error("No egl image created",0); glEGLIm...
by AndyPi
Tue Jan 24, 2017 2:20 pm
Forum: Compute Module
Topic: CM3 and rpiboot
Replies: 25
Views: 8048

Re: CM3 and rpiboot

Hi, I am trying with zero too and get a long wait. Did your revised bootcode fix ? [email protected]:~$ sudo ./usbboot/rpiboot -d zero/boot -v Waiting for BCM2835/6/7 Found device 1 idVendor=0x0a5c idProduct=0x2763 Device located successfully Initialised device correctly Found serial number 0 Se...
by AndyPi
Thu Dec 29, 2016 3:48 pm
Forum: General discussion
Topic: Possible to capture mouse input on the CLI?
Replies: 8
Views: 1939

Re: Possible to capture mouse input on the CLI?

ncurses supports mouse operations seehttp://www.tldp.org/HOWTO/NCURSES-Progr ... mouse.html. Alternatively you can read the mouse device /dev/input/mice
by AndyPi
Thu Aug 25, 2016 10:46 am
Forum: General programming discussion
Topic: Error building crosstol-ng for RaspberryPi
Replies: 3
Views: 1118

Re: Error building crosstol-ng for RaspberryPi

Have you looked in the build.log ?
also ct-ng list-samples lists some custom rpi samples configs
take a look at http://www.bootc.net/archives/2012/05/2 ... pberry-pi/ and http://crosstool-ng.org/#download_and_usage

regards
by AndyPi
Thu Jun 09, 2016 12:15 pm
Forum: Arch
Topic: Arch linux:set regulatory domain- SOLVED
Replies: 1
Views: 1930

Re: Arch linux:set regulatory domain SOLVED

Found this https://kernel.googlesource.com/pub/scm/linux/kernel/git/jberg/iw/+/94af668bdd6511b9d0a372542eb994ea67e8057d and iw: fix "iw reg get" double output Axel reports that running "iw reg get" results in the (global) output being printed twice. The reason for this is that we try to use the dump...
by AndyPi
Thu Jun 09, 2016 10:48 am
Forum: Arch
Topic: Arch linux:set regulatory domain- SOLVED
Replies: 1
Views: 1930

Arch linux:set regulatory domain- SOLVED

I am mildly irritated by all the cfg80211 messages at boot and set about seeing if I could reduce them. I have a Pi3 and have uncommented the GB entry in /etc/conf.d/wireless-regdom. I find that when I do iw reg get global country GB: DFS-ETSI (2402 - 2482 @ 40), (N/A, 20), (N/A) (5170 - 5250 @ 80),...
by AndyPi
Tue May 31, 2016 10:37 am
Forum: General discussion
Topic: Current Status USB boot Rpi3?
Replies: 2
Views: 914

Re: Current Status USB boot Rpi3?

Take a look at https://github.com/raspberrypi/tools/tr ... er/usbboot and https://github.com/raspberrypi/tools/issues.

Upshot is (I think) that it needs some attention and will get some eventually
by AndyPi
Thu Mar 10, 2016 1:56 pm
Forum: Arch
Topic: Pi3
Replies: 6
Views: 4481

Re: Pi3

All good in Arch 4.1.19-3

PS add
ExecUpPost='iw dev wlan0 set power_save off'
to netctl profile to disable the bothersome power management
by AndyPi
Thu Mar 03, 2016 5:33 pm
Forum: Troubleshooting
Topic: pi3 hdmi no signal
Replies: 0
Views: 617

pi3 hdmi no signal

Got a Pi3. Install latest raspian. switch on, it boots OK. Get wireless working as well...so far so good. Switched HDMI cable to another Pi (B2) when I switched back I get no signal. Switch cable back to Pi2 and signal returns. I am able to SSH into Pi3 when there is no signal so definitely booted b...
by AndyPi
Thu Mar 03, 2016 1:26 pm
Forum: Arch
Topic: Pi3
Replies: 6
Views: 4481

Re: Pi3 Arch

For completeness: Pi2 dmesg fragments CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d [ 0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache [ 0.000000] Machine model: Raspberry Pi 2 Model B Rev 1.1 and Kernel command line: dma.dmachans=0x7f35 bcm2708_fb...
by AndyPi
Thu Mar 03, 2016 12:33 pm
Forum: Arch
Topic: Pi3
Replies: 6
Views: 4481

Re: Pi3

On my updated Pi2 image it also has
bcm2710-rpi-3-b.dtb
in /boot so at least it knows about it. I seem to recall that the boot messages properly identified the Pi3.
by AndyPi
Wed Mar 02, 2016 1:01 pm
Forum: Arch
Topic: Pi3
Replies: 6
Views: 4481

Pi3

Arch Arm site indicates that for now Pi3 is to use Pi2 software https://archlinuxarm.org/platforms/armv8/broadcom/raspberry-pi-3 I assume that taking a fully updated Pi2 card and plugging into Pi3 is equivalent to doing a fresh install (?). However although Pi3 + Pi2 card boots OK it seems to boot a...
by AndyPi
Mon Feb 15, 2016 11:59 am
Forum: General discussion
Topic: HTML 5 clientless browser based remote desktop for pi
Replies: 38
Views: 11369

Re: HTML 5 clientless browser based remote desktop for pi ze

Hi I did the adafruit tutorial on gadget mode. When it comes to internet sharing they do it on a macOS. To manage it on Ubuntu as host I did the following (BTW I don't really understand what I'm doing but it seems to work. Need to use ip forwarding which is controlled via a sysctl value. To view sys...
by AndyPi
Sat Feb 06, 2016 1:59 pm
Forum: Advanced users
Topic: HOWTO: Enable USB device mode on Pi Zero
Replies: 68
Views: 42888

Re: HOWTO: Enable USB device mode on Pi Zero

Connect to my PiB2, Logik 2A 4 port hub, with power and usb ports dmesg usb 1-1.4.1: new full-speed USB device number 12 using dwc_otg usb 1-1.4.1: New USB device found, idVendor=0a5c, idProduct=2763 usb 1-1.4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 usb 1-1.4.1: Product: BCM2708 ...
by AndyPi
Sat Feb 06, 2016 1:29 pm
Forum: Advanced users
Topic: HOWTO: Enable USB device mode on Pi Zero
Replies: 68
Views: 42888

Re: HOWTO: Enable USB device mode on Pi Zero

Tried three cables. A short one (250mm) from Chromecast kit (I think), one from TomTom kit, one from newish Motorola smart phone. All give same results.
by AndyPi
Sat Feb 06, 2016 1:13 pm
Forum: Advanced users
Topic: HOWTO: Enable USB device mode on Pi Zero
Replies: 68
Views: 42888

Re: HOWTO: Enable USB device mode on Pi Zero

I have a couple of cables with male micro A / male USB-A. Not sure where they came from, do I need something extra special. As I said the Pi0 seems to enumerate when connected using this cable and am able to send usbbootcode.bin OK and read response, just doesn't want to re-enumerate after the bootc...
by AndyPi
Sat Feb 06, 2016 12:48 pm
Forum: Advanced users
Topic: HOWTO: Enable USB device mode on Pi Zero
Replies: 68
Views: 42888

Re: HOWTO: Enable USB device mode on Pi Zero

I must be doing something wrong! Got my Pi zero and want to experiment with the usb device mode. I am having trouble with the simple use of rpiboot. I have compiled and installed the rpiboot program on Ubuntu 14.10 PC. Got a pi zero with empty sd slot, usb micro to USB A cable connected to USB slot....
by AndyPi
Sat Jan 16, 2016 4:58 pm
Forum: Troubleshooting
Topic: Edimax EW-7811UTC Raspbian
Replies: 116
Views: 43730

Re: Edimax EW-7811UTC Raspbian

I have RPI2 and been using Edimax AC600 ( ID 7392:a812 Edimax Technology Co., Ltd )for some time without much difficulty. I am using Arch currently at 4.1.15. I do compile it myself from source here https://github.com/abperiasamy/rtl8812AU_8821AU_linux . It takes a couple of minutes to compile. It w...
by AndyPi
Mon Jan 11, 2016 12:23 pm
Forum: Beginners
Topic: Accidently plugged TTl into wrong pins
Replies: 5
Views: 796

Re: Accidently plugged TTl into wrong pins

Bit unsure about your pin numbering but see https://learn.adafruit.com/adafruits-ra ... t-the-lead
by AndyPi
Mon Jan 11, 2016 12:08 pm
Forum: Advanced users
Topic: Windows command-line program on RPI
Replies: 9
Views: 1862

Re: Windows command-line program on RPI

Try using mkvmerge -o outfile.mkv ch3_14.00.00-14.20.00.dav. Might have to install mkvtool-nix. Took 34 seconds. [[email protected] videos]# mkvmerge -o out.mkv ch3_14.00.00-14.20.00.dav mkvmerge v8.7.0 ('All of the above') 32bit 'ch3_14.00.00-14.20.00.dav': Using the demultiplexer for the format 'AVC/h.26...
by AndyPi
Wed Dec 16, 2015 9:38 pm
Forum: Advanced users
Topic: Linux kernel is now 4.1
Replies: 31
Views: 19254

Re: Linux kernel is now 4.1

Also see https://github.com/raspberrypi/linux/bl ... com/vcio.c lines 25 and 26
#define VCIO_IOC_MAGIC 100
#define IOCTL_MBOX_PROPERTY _IOWR(VCIO_IOC_MAGIC, 0, char *)

Go to advanced search