Go to advanced search

by TheFreeman04
Tue Jul 09, 2013 2:48 pm
Forum: Troubleshooting
Topic: Python GPIO, TpyeError
Replies: 5
Views: 1434

Re: Python GPIO, TpyeError

That pretty much seems to have sorted it! feel a little silly now :oops:

Thanks!
by TheFreeman04
Tue Jul 09, 2013 2:27 pm
Forum: Troubleshooting
Topic: Python GPIO, TpyeError
Replies: 5
Views: 1434

Re: Python GPIO, TpyeError

Thanks for the reply! But that didn't work, i get a different error now; Traceback (most recent call last): File "/home/pi/GPIO.py", line 4, in <module> GPIO.setup(17, GPIO.INPUT) AttributeError: 'module' object has no attribute 'INPUT' Every guide I've been following, it's been lowercase :? I lied,...
by TheFreeman04
Tue Jul 09, 2013 2:01 pm
Forum: Troubleshooting
Topic: Python GPIO, TpyeError
Replies: 5
Views: 1434

Python GPIO, TpyeError

I've only just got started with python and GPIO, and python in general, and i'm getting an annoying TypeError that i don't understand; Traceback (most recent call last): File "/home/pi/GPIO.py", line 4, in <module> GPIO.setup(17, GPIO.input) TypeError: an integer is required I understand that it wan...
by TheFreeman04
Sun Jun 03, 2012 9:54 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

Hmmm, again, no image or "no display" message. Guess I'm stuck with 720p :|
by TheFreeman04
Sun Jun 03, 2012 9:47 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

Is there any way to add resolutions to the RPi, maybe adding 1280x800?
by TheFreeman04
Sun Jun 03, 2012 9:28 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

Gave me an interesting result; monitor shows neither the RPi's image or a "no signal message".
Cheers for the help :D
by TheFreeman04
Sun Jun 03, 2012 6:25 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

Yes, Is that by any chance the problem? :|
by TheFreeman04
Sun Jun 03, 2012 5:44 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

I couldn't open the file; so i pasted from my raspberry.
by TheFreeman04
Sun Jun 03, 2012 5:43 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

HDMI:EDID version 1.3, 1 extensions, screen size 88x50 cm HDMI:EDID features - videodef 0xa0 !standby !suspend active off; colour encoding:RGB444|YCbCr422; sRGB is not default colourspace; preferred format is native; does not support GTF HDMI:EDID ignored unknown descriptor tag 0x0 HDMI:EDID found m...
by TheFreeman04
Sun Jun 03, 2012 4:13 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

Sorry! /opt/vc/bin/edidparser edid.dat reports:
failed to open edid.dat
edid_parser exited with code -1
I've tried:
hdmi_group=2
hdmi_mode=35
No picture! 1280x1024 would be perfect!
by TheFreeman04
Sun Jun 03, 2012 3:54 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

My monitor isn't even capable of 1080p/i its a 17" lg flatron maximum resolution of 1280x1024 :|
by TheFreeman04
Sun Jun 03, 2012 3:53 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

cat /boot/config.txt hdmi_group=1 hdmi_mode=4 disable_overscan=1 /opt/vc/bin/tvservice -s state: hpd high | HDMI mode | HDCP off | composite off (0x12002a), 1280x720 @ 60Hz progressive /opt/vc/bin/tvservice -m DMT Group DMT has 0 modes: /opt/vc/bin/tvservice -m CEA Group CEA has 9 modes: mode 1: 64...
by TheFreeman04
Sun Jun 03, 2012 3:26 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

After disabling overscan, i am able to get the resolutions i expect; but i'm still not getting the resolutions that 'fit' my monitor (1152x865 or 1280x1024) both of which are in DMT which after the update has "0 modes"...
by TheFreeman04
Sun Jun 03, 2012 2:27 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

And i'm still getting weird resolutions, even after messing with framebuffer :(
by TheFreeman04
Sun Jun 03, 2012 2:23 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

OK, I've got the update to work (finally after a fresh image, thanks :D ) and now I've lost all modes in DMT :evil: is there anything else I can do, or do i just have to deal with it?
by TheFreeman04
Sun Jun 03, 2012 1:16 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

md5sum /usr/bin/rpi-update:
#1a0e4e39f2497116ffd9e5fb4bcddd0e /usr/bin/rpi-update
ls -l /usr/bin/rpi-update:
-rwxr-xr-x 1 root root 5574 jun 3 1353 /usr/bin/rpi-update
rpi-update:
fatal: Not a git repository: '//root/.rpi-firmware/.git'
by TheFreeman04
Sun Jun 03, 2012 12:50 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

Damn. I ran it twice yesterday, first time i got a kernel panic. Just done it again, and now it says "fatal: Not a git repository: '//root/.rpi-firmware/.git'"
I am so sorry for this taking so long too sort out, I have never had this many problems at once :|
Thanks again for any help!
by TheFreeman04
Sun Jun 03, 2012 12:35 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

Apr 18 2012 15:04:56
Copyright (c) Broadcom
version 310376 (release)
by TheFreeman04
Sat Jun 02, 2012 6:59 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

/opt/vc/bin/tvservice -s shows "state 0x120001, 1024x768 @ 60hz progressive" My config file looks like this: hdmi_group=2 hdmi_mode=16 overscan_left=15 overscan_right=15 framebuffer_width=68 framebuffer_height=1024 I would like to have: hdmi_group=2 hdmi_mode=36 But it doesn't work. The current outp...
by TheFreeman04
Sat Jun 02, 2012 6:29 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

After having a lot of trouble updating; having to re-format my sd card 3 times because it stopped working somehow... I got to update, updated my config file and nothing changed. I checked my compatible modes using "/opt/vc/bin/tvservice -m CEA" and "/opt/vc/bin/tvservice -m DMT" Nothing has changed....
by TheFreeman04
Sat Jun 02, 2012 3:05 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

I'm getting no where the hexxeh updater doesn't work all i get is /usr/bin/rpi-update persmision denied, even if i run as root. when i do "sudo su rpi-update" all i get is "Unknown id: rpi-update"
This sucks :( any more help would be greatly appreciated!
by TheFreeman04
Fri Jun 01, 2012 9:40 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Re: Resolution help... again.

It didn't make any difference :| I'm still getting 930x704. Anything else i can do?
by TheFreeman04
Fri Jun 01, 2012 6:24 pm
Forum: Troubleshooting
Topic: Resolution help... again.
Replies: 39
Views: 5457

Resolution help... again.

I posted here yesterday asking about some help with the resolution on my pi; I changed the config file; it now looks like this: hdmi_group=2 hdmi_mode=16 overscan_left=15 overscan_right=15 So the resolution is supposed to be 1024x768 but it comes out as 930x704 I'd like to have it as 1280x1024 but i...
by TheFreeman04
Wed May 30, 2012 6:18 pm
Forum: Troubleshooting
Topic: Not so simple problem.
Replies: 2
Views: 1161

Re: Not so simple problem.

Thank you so much! It's got me a whole lot closer to what i need to do! :D
by TheFreeman04
Wed May 30, 2012 5:17 pm
Forum: Troubleshooting
Topic: Not so simple problem.
Replies: 2
Views: 1161

Not so simple problem.

I have a problem, and it's putting me at my whits end. I've brought a hdmi to vga converter and i get a picture through fine, but it comes through with a ridiculous resolution of something like 1860*964 (My monitor's native is 1280*1024 or 1152*864) I have tried all the "xrandr --newmode..." and whe...

Go to advanced search