Go to advanced search

by MrBool
Wed Oct 28, 2020 6:25 am
Forum: C/C++
Topic: printf on the HDMI console
Replies: 3
Views: 135

printf on the HDMI console

I'm using Raspbian Lite. My default console is serial port now and I want to use printf also on HDMI console.

How I can use printf to work also on the HDMI console?
by MrBool
Thu Oct 22, 2020 9:13 am
Forum: General discussion
Topic: Serial port console debug level during boot
Replies: 0
Views: 58

Serial port console debug level during boot

How I can change the debug level on the serial port console to see more information during boot? I noticed that on the LCD connected to HMDI I see more information during boot that on the serial port console. I will probably need to change /boot/cmdline.txt but I can't find any info about such an op...
by MrBool
Mon Jul 20, 2020 6:23 pm
Forum: Compute Module
Topic: CM4 serial ports RS485 mode
Replies: 9
Views: 821

Re: CM4 serial ports RS485 mode

I know that I need external hardware - Rs485 transceiver. I asked because some procesors have UART with RS485 mode options. I used it a few years ago on my SBC with ARM9. RS485 transceiver needs flow control signal, not only RXD and TXD like in Rs232. Usually signal RTS is used for it if UART has mo...
by MrBool
Sun Jul 19, 2020 4:25 pm
Forum: Compute Module
Topic: CM4 serial ports RS485 mode
Replies: 9
Views: 821

Re: CM4 serial ports RS485 mode

What part of "confidential until announced" are you struggling with? The RPF (after the official screen debacle) discovered that keeping their designs confidential until a product is available (from the usual suppliers) makes for an easier life, gets better product reviews and less speculation by t...
by MrBool
Sun Jul 19, 2020 2:04 pm
Forum: Compute Module
Topic: CM4 serial ports RS485 mode
Replies: 9
Views: 821

CM4 serial ports RS485 mode

I know that CM4 is not yet available but wants to be prepared for his arrival ;)

The processor of RPi4 has 4 serial ports. There are four new overlays for serial ports - uart2 to uart5.
Do any of them support RS485 mode?
by MrBool
Thu May 14, 2020 2:29 pm
Forum: Compute Module
Topic: CM3 boots fine but no a new device
Replies: 0
Views: 170

CM3 boots fine but no a new device

I use hundreds of CM3. Recently, after a year of normal operation, two CM3s stopped working. I tried to program them. Both boots find but there is no /dev/sd* device.
by MrBool
Wed Mar 11, 2020 4:06 pm
Forum: Compute Module
Topic: dt-blob file Compute Module 3+
Replies: 1
Views: 339

dt-blob file Compute Module 3+

I don't see a section for CM3+ in dt-blob.dts file
https://github.com/raspberrypi/firmware ... t-blob.dts

I noticed that my old dt-blob file for CM3 works also for CM3+.

Can anyone confirm this?
by MrBool
Sat Mar 07, 2020 2:24 pm
Forum: General discussion
Topic: Raspberry Pi Imager custom image file
Replies: 3
Views: 360

Raspberry Pi Imager custom image file

Does Raspberry Pi Imager have support for a custom image file?
by MrBool
Sat Sep 21, 2019 9:46 am
Forum: Device Tree
Topic: dtoverlay disable from command line
Replies: 5
Views: 2487

dtoverlay disable from command line

I use in my config.txt file
dtoverlay=mcp23017
Is possible to disable that dtoverlay from the command line?
I know that I can remove this line from config.txt but I need to disable it from the command line during test procedure and keep original config.txt
by MrBool
Wed May 29, 2019 1:33 pm
Forum: Compute Module
Topic: Two LAN9514, one crystal oscillator
Replies: 2
Views: 1054

Two LAN9514, one crystal oscillator

I would like to use two LAN9514 with CM3. Is possible to clock them both with one crystal oscillator? For the first one I will use crystal oscillator, not signal from CM3.
I noticed that LAN9514 has 24MHz reference clock output but it is not useful for the second LAN9514 because it needs 25 MHz.
by MrBool
Wed Sep 12, 2018 6:31 am
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 2869

Re: scriptexecutor problem

My mistake. I have pullup on schematic but I use version without HDMI and this pullup is not assembled. After adding hdmi_ignore_edid=1 to config.txt console log looks like below Raspberry Pi Bootcode USB device booting Read File: config.txt, 48 (bytes) Raspberry Pi Bootcode Read File: config.txt, 4...
by MrBool
Tue Sep 11, 2018 10:34 am
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 2869

Re: scriptexecutor problem

I don't have a CMIO3 board.
by MrBool
Tue Sep 11, 2018 10:28 am
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 2869

Re: scriptexecutor problem

Yes, I have the pullup 100k to 1v8 on HDMI_HPD_N_1V8.
by MrBool
Mon Sep 10, 2018 4:38 pm
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 2869

Re: scriptexecutor problem

OK. I use the latest firmware. Here is the console log: Raspberry Pi Bootcode USB device booting Read File: config.txt, 28 (bytes) Raspberry Pi Bootcode Read File: config.txt, 28 Read File: start.elf, 2846756 (bytes) Read File: fixup.dat, 6659 (bytes) MESS:00:00:15.758794:0: brfs: File read: /mfs/sd...
by MrBool
Mon Sep 10, 2018 10:03 am
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 2869

Re: scriptexecutor problem

This works on /boot/bootcode.bin on the eMMC but we are talking about scriptexecutor. It has their own bootcode.bin file (on the output directory) and this file loaded by USB. It looks like scriptexecutor uses old firmware during the build.
by MrBool
Mon Sep 10, 2018 8:38 am
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 2869

Re: scriptexecutor problem

Commands:

strings bootcode.bin | grep BOOT_UART=0
strings bootcode.bin | grep UART_BOOT=0
strings bootcode.bin | grep UART

do not return anything.
by MrBool
Sat Sep 08, 2018 12:50 pm
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 2869

Re: scriptexecutor problem

Any update about that issue?
I tried lastest usbboot and the result is the same.
Scriptexecutor is completely useless.
by MrBool
Thu Apr 05, 2018 9:17 am
Forum: Compute Module
Topic: scriptexecutor problem
Replies: 15
Views: 2869

scriptexecutor problem

I'm trying to use scriptexecutor to flash CM3. I have a problem with buildroot push over USB. I followed by build instructions: https://github.com/raspberrypi/scriptexecutor/wiki/Building-and-customizing and build was done fine. When I run command sudo ./rpiboot -d /home/dawid/scriptexecutor/output ...
by MrBool
Sat Mar 24, 2018 12:53 pm
Forum: General discussion
Topic: Boot delay
Replies: 5
Views: 1412

Re: Boot delay

I'm sorry, here is my cmdline.txt

dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=7009e660-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
by MrBool
Sat Mar 24, 2018 12:26 pm
Forum: General discussion
Topic: Boot delay
Replies: 5
Views: 1412

Re: Boot delay

In config.txt I have only:

ignore_lcd=1
force_eeprom_read=0
hdmi_ignore_edid=0xa5000080
by MrBool
Fri Mar 23, 2018 3:45 pm
Forum: General discussion
Topic: Boot delay
Replies: 5
Views: 1412

Boot delay

I use the latest image of Raspbian on the Compute Module. I noticed that after power on the first message on UART "Booting Linux on physical CPU 0x0" is after 5-6 seconds. Is possible make this delay shorter? I don't need HDMI and in the previous images I used in config: ignore_lcd=1 force_eeprom_re...
by MrBool
Fri Mar 23, 2018 2:33 pm
Forum: Compute Module
Topic: Two different config files
Replies: 0
Views: 435

Two different config files

Is possible to define two different config files? I want to create one image for two different devices based on CM. Depending on the device I want to use suitable config.
by MrBool
Thu Mar 15, 2018 7:43 am
Forum: Advanced users
Topic: Particular subversion of kernel
Replies: 0
Views: 593

Particular subversion of kernel

How can I download particular subversion of the kernel? For example: git clone --depth=1 -b rpi-4.9.y https://github.com/raspberrypi/linux.git cd linux head Makefile -n 3 give me 4.9.80 version. I want to apply RT preempt patch and there are no patches for 4.9.80: https://mirrors.edge.kernel.org/pub...
by MrBool
Tue Nov 07, 2017 5:55 pm
Forum: Compute Module
Topic: Flashing the Compute Module issue
Replies: 1
Views: 647

Flashing the Compute Module issue

During flashing the 250 pieces of Compute Modules I noticed that in two cases CM does not pop up under Windows as a disk. Rpiboot messages are the same as for others CMs (without any errors). Do you have any advice?
by MrBool
Sun Oct 22, 2017 4:33 pm
Forum: General discussion
Topic: Expand Filesystem - command line
Replies: 4
Views: 39394

Re: Expand Filesystem - command line

I have found solution:

Code: Select all

raspi-config --expand-rootfs

Go to advanced search