Go to advanced search

by ErinaceousJones
Fri Jun 20, 2014 3:57 pm
Forum: OpenMAX
Topic: video_scheduler / clock components -- playing video too fast
Replies: 12
Views: 10930

Re: video_scheduler / clock components -- playing video too

Ah, that may be why it's playing catchup. Without setting STARTTIME at the beginning of every new video, it never actually plays the next videos, if I flush the buffer before playing them. The program continues running (I continue getting debug output), but no new video is rendered to the screen. Po...
by ErinaceousJones
Fri Jun 20, 2014 2:06 am
Forum: OpenMAX
Topic: video_scheduler / clock components -- playing video too fast
Replies: 12
Views: 10930

Re: video_scheduler / clock components -- playing video too

Thanks for the tip :) unfortunately zeroing out nTimeStamp also had no effect. [bangs head against wall] I've tried reinitializing the clock component now as well -- still no joy. Maybe one of the components has some internal counter which I need to reset? e.g. something in the video_scheduler? The ...
by ErinaceousJones
Thu Jun 19, 2014 2:47 pm
Forum: OpenMAX
Topic: video_scheduler / clock components -- playing video too fast
Replies: 12
Views: 10930

video_scheduler / clock components -- playing video too fast

I'm writing a program based on hello_video which is intended to seamlessly load .h264 video files on the fly -- one will be playing on a loop, and with a command sent through a FIFO, the program opens a new video file and fills the video_decode buffer with data straight away. That's working -- it sw...

Go to advanced search