Go to advanced search

by sharix
Mon Mar 06, 2017 12:33 pm
Forum: Camera board
Topic: Disabling ISP processing blocks
Replies: 35
Views: 8143

Re: Disabling ISP processing blocks

Thank you, I compiled it on a Pi B and it works. Here is an album of a comparison of the default raspistill and one with disabled lens shading corrections, both with and without a stats pass. Camera is the official PiCam v1 with an additional fisheye lens attached in front of the factory lens. Commo...
by sharix
Tue Jun 07, 2016 7:44 am
Forum: Camera board
Topic: Pi Zero 1.3 Camera "Failed to create camera component"
Replies: 16
Views: 10802

Re: Pi Zero 1.3 Camera "Failed to create camera component"

This is the output of the debugging log after running raspistill -v: sudo vcdbg log assert 001179.053: assert( source ) failed; ../../../../../middleware/confzilla/cp_front_fdt.c::cp_front_fdt_load_builtin line 115 001657.549: assert( card not initialised ) failed; ../../../../../filesystem/media/sd...
by sharix
Tue Jun 07, 2016 7:29 am
Forum: Camera board
Topic: Pi Zero 1.3 Camera "Failed to create camera component"
Replies: 16
Views: 10802

Re: Pi Zero 1.3 Camera "Failed to create camera component"

I added this scritpt to a @reboot cronjob and left it running overnight. Over 120 reboots later, it still does not detect the camera. #!/bin/bash attFile="/home/pi/getcamAttempts.txt" sleep 60 att=$(cat "$attFile") cam=$(vcgencmd get_camera|awk -F= '{print $3}') echo $(($att + 1)) > "$attFile" if [ ...
by sharix
Tue Jun 07, 2016 12:51 am
Forum: Camera board
Topic: Pi Zero 1.3 Camera "Failed to create camera component"
Replies: 16
Views: 10802

Re: Pi Zero 1.3 Camera "Failed to create camera component"

I have the same problem. Camera led works with the python script; vcgencmd get_camera returns supported=1 detected=0.
The camera was working yesterday, now it doesn't.
by sharix
Wed Jun 01, 2016 9:04 am
Forum: Camera board
Topic: Strange blue artifacts in dark portions of an image
Replies: 1
Views: 578

Strange blue artifacts in dark portions of an image

I have noticed that sometimes, if the light is just weak enough, the camera will produce a strange blue tint over darker parts of the scene. Please check the images in album to see what I mean: http://imgur.com/a/kTvyE The first image, taken at 7 pm, shows no visible artifacts. The second image, tak...
by sharix
Mon May 30, 2016 9:30 am
Forum: Camera board
Topic: Blue tint on edges
Replies: 5
Views: 1091

Re: Blue tint on edges

This can be fixed by adding "ov5647_acls=1" in /boot/config.txt and restarting your Pi. Source: viewtopic.php?f=43&t=73998&p=971956
by sharix
Tue May 17, 2016 8:56 am
Forum: Camera board
Topic: -awb auto in raspistill does not work ideally
Replies: 3
Views: 795

Re: -awb auto in raspistill does not work ideally

It looks like you have some cyan vignetting. This can be fixed by adding "ov5647_acls=1" in /boot/config.txt and restarting your Pi. Source viewtopic.php?f=43&t=73998&p=971956
by sharix
Wed May 11, 2016 9:32 am
Forum: Camera board
Topic: Cyan vignetting after rpi-update
Replies: 42
Views: 12169

Re: Cyan vignetting after rpi-update

Thanks for this!
The auto white balance does produce images that are a bit too red, at least when the weather is cloudy.
by sharix
Mon Feb 08, 2016 8:46 am
Forum: Camera board
Topic: RaspberryPi Camera for Astrophotography
Replies: 345
Views: 100389

Re: RaspberryPi Camera for Astrophotography

gordon77, Is your source code on GitHub? Sorry no. I haven't used github (yet), looks too complicated for me! Gordon77 It's actually very simple, you create a repository and then push your code updates to the repo. Here is a very good and detailed guide on how to set up a repository: http://stackov...
by sharix
Wed Dec 16, 2015 9:57 am
Forum: Camera board
Topic: RAW output information
Replies: 236
Views: 89064

Re: RAW output information

I wrote a function to import raw images in Mathematica with proper 10-bit decoding. It's pretty fast, creating the bayer pixel array in less than 0.4 seconds. Converting the array to image takes 0.01 seconds, and demosaicing takes additional 5 seconds. c = Compile[{{cbl, _Integer, 1}, {coffset, _Int...
by sharix
Fri Dec 11, 2015 1:20 pm
Forum: Camera board
Topic: RAW output information
Replies: 236
Views: 89064

Re: RAW output information

I get the same histogram in Mathematica (rpi2dng raw file):

Image
by sharix
Mon Aug 03, 2015 11:47 pm
Forum: Camera board
Topic: Long exposure dark after rpi-update to 4.x
Replies: 8
Views: 1413

Re: Long exposure dark after rpi-update to 4.x

Sorry for a very late reply, I had forgotten about this thread. I shoot the photos with raspistill -vf -hf -ss 6000000 -ISO 800 -o $newpic EXIF confirms the exposure is 6 seconds in both pictures. The brightness variations at night are mostly due to low clouds, fog or haze, which cause more light sc...
by sharix
Thu Jul 23, 2015 12:28 pm
Forum: Camera board
Topic: Long exposure dark after rpi-update to 4.x
Replies: 8
Views: 1413

Re: Long exposure dark after rpi-update to 4.x

Here is a comparison from my weather station:

before 4.0.x:
http://i.imgur.com/RnMQl6m.jpg

after:
http://i.imgur.com/7bxkDDh.jpg

Would you consider the second significantly darker?
by sharix
Tue May 26, 2015 1:03 pm
Forum: Camera board
Topic: Image quality comparison with alternate lens (wow!)
Replies: 11
Views: 3391

Re: Image quality comparison with alternate lens (wow!)

I ordered one of these wide angle cameras from the ebay link provided. Unfortunately, I could not get it to work (tested with a RPi 2): mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM) mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (...
by sharix
Sun May 03, 2015 3:21 pm
Forum: Troubleshooting
Topic: How to install gstreamer1.0
Replies: 8
Views: 7705

Re: How to install gstreamer1.0

Yeah, I finished up with installing listed dependencies for epiphany-browser: libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-libav gstreamer1.0-omx I don't know why that user on stackexchange suggests to inst...
by sharix
Sun May 03, 2015 12:36 pm
Forum: Troubleshooting
Topic: How to install gstreamer1.0
Replies: 8
Views: 7705

Re: How to install gstreamer1.0

Interesting, there doesn't appear to be a gstreamer1.0 deb package here: http://archive.raspberrypi.org/debian/p ... reamer1.0/
by sharix
Sun May 03, 2015 11:47 am
Forum: Troubleshooting
Topic: How to install gstreamer1.0
Replies: 8
Views: 7705

Re: How to install gstreamer1.0

Well apparently I don't have a full raspbian. Where does gstreamer1.0 come from when it's installed by default and why can't we install it afterwards?
Will it be installed as a dependancy if I install epiphany or webkit3?
by sharix
Sun May 03, 2015 9:23 am
Forum: Troubleshooting
Topic: How to install gstreamer1.0
Replies: 8
Views: 7705

Re: How to install gstreamer1.0

yes
by sharix
Sun May 03, 2015 9:00 am
Forum: Troubleshooting
Topic: How to install gstreamer1.0
Replies: 8
Views: 7705

How to install gstreamer1.0

gstreamer1.0 is apparently now included in the raspbian repository: http://raspberrypi.stackexchange.com/a/29549/12720 However, when I wanted to install it, I get: sudo aptitude install gstreamer1.0 Couldn't find package "gstreamer1.0". However, the following packages contain "gstreamer1.0" in their...
by sharix
Tue Apr 14, 2015 12:56 pm
Forum: Camera board
Topic: picamera - Issue with white balance or damaged
Replies: 5
Views: 1186

Re: picamera - Issue with white balance or damaged

As 6by9 said, this can be fixed with -st option, but it doesn't always produce a better image, because -st overrides awb settings: viewtopic.php?f=43&t=92293
by sharix
Sat Feb 28, 2015 7:25 pm
Forum: Camera board
Topic: "--stats" option causes raspistill to ignore "-awbg" setting
Replies: 10
Views: 2364

Re: "--stats" option causes raspistill to ignore "-awbg" set

I'm just looking for a way to achieve a good color balance without the red color in the middle of the picture. This combination of arguments seemed the only way to do it.
by sharix
Sat Feb 28, 2015 7:07 pm
Forum: Camera board
Topic: "--stats" option causes raspistill to ignore "-awbg" setting
Replies: 10
Views: 2364

Re: "--stats" option causes raspistill to ignore "-awbg" set

OK no need for that attitude, in your previous post in this thread you said, quote,
you can't currently have manual AWB gains and a stats pass.
currently implies that it could be fixed eventually.
by sharix
Sun Nov 23, 2014 2:09 pm
Forum: Camera board
Topic: "--stats" option causes raspistill to ignore "-awbg" setting
Replies: 10
Views: 2364

Re: "--stats" option causes raspistill to ignore "-awbg" set

Alright, thanks for the info.
by sharix
Sun Nov 23, 2014 10:22 am
Forum: Camera board
Topic: "--stats" option causes raspistill to ignore "-awbg" setting
Replies: 10
Views: 2364

"--stats" option causes raspistill to ignore "-awbg" setting

It seems that if the "--stats" ("-st") option is enabled, raspistill ignores auto white balance settings: raspistill -st -set -awb off -awbg 1.0,4.0 -o test_st.jpg mmal: Exposure now 10000, analog gain 256/256, digital gain 256/256 mmal: AWB R=256/256, B=1024/256 mmal: Exposure now 9977, analog gain...

Go to advanced search