Go to advanced search

by FirstTenor
Fri Jun 06, 2014 10:13 pm
Forum: Beginners
Topic: Raspberry pi FTP server no permissions
Replies: 2
Views: 1065

Re: Raspberry pi FTP server no permissions

I have proftpd loaded on my setup. It won't work with the 'pi' account ... Just as well as that users files are on the SD card. I created a new account with its 'home folder' on an external disk. This has 754 permission (user can do anything, group read & execute, others read). I can login using Fil...
by FirstTenor
Fri Jun 06, 2014 10:04 pm
Forum: Beginners
Topic: Bug with my USB HDD
Replies: 7
Views: 953

Re: Bug with my USB HDD

I am guessing here - but IF your HDD does not need power when plugged into your PC .... Then the power supply for that external HDD box may not be connected or your psu not working. A PC would easily drive an external disk .... But a RPi on a 1A psu won't. I have my external HDD plugged into a power...
by FirstTenor
Fri Jun 06, 2014 9:53 pm
Forum: Troubleshooting
Topic: Can't delete two files from a directory.
Replies: 6
Views: 1901

Re: Can't delete two files from a directory.

Looking at your screenshot - there could be spaces (more than one) in the name any you would need to completely match in linux.

Did you try chmod 666 * Within the folder

Or maybe use lxde (startx). And open the file manager

Good luck
by FirstTenor
Sun Jun 01, 2014 5:10 pm
Forum: General programming discussion
Topic: Shell Script Backup
Replies: 5
Views: 1620

Re: Shell Script Backup

rsync is a standard linux function.

Try man rsync to read up about it.
by FirstTenor
Fri May 30, 2014 1:49 pm
Forum: Troubleshooting
Topic: Accidentally changed permissions and now can't log in
Replies: 14
Views: 2671

Re: Accidentally changed permissions and now can't log in

Too bad you didn't assign a password to the root account. You could have logged in as root and fixed your problem ... not a good idea to do this - Root account is too powerful to be accessible from single login - but too bad that you didn't add a second user that you could have logged in as instead.
by FirstTenor
Fri May 30, 2014 1:40 pm
Forum: Troubleshooting
Topic: Raspberry Pi and External Hard Drives
Replies: 13
Views: 10248

Re: Raspberry Pi and External Hard Drives

I have a Seagate 500Gb usb drive plugged into a powered USB hub. It has one of those power split cables so I am using that to supply enough power from 2 USB ports off the hub to spin up the disk. I found that it never spun up otherwise. I also tried using a 800Gb WD drive - that seemed fine for a wh...
by FirstTenor
Fri May 30, 2014 7:22 am
Forum: Beginners
Topic: Anti virus software
Replies: 6
Views: 2339

Re: Anti virus software

There is Anti Virus software available for the RPi (or more precisely - Linux in general) ... clamav. This is really an admin tool though and there is lots to read through to understand how to set it up. It is really intended to be an automated virus scan on a mail or ftp service - so the documentat...
by FirstTenor
Fri May 30, 2014 6:58 am
Forum: Networking and servers
Topic: Best Webmin os
Replies: 3
Views: 2306

Re: Best Webmin os

I have this setup. I used the current NOOBS install from this site and boot to Raspbian (just follow all the prompts after startup - and pick a good secure password). Make sure that you update after initial boot: sudo apt-get update sudo apt-get upgrade ... it will take a while You ask which options...
by FirstTenor
Fri May 30, 2014 6:40 am
Forum: Networking and servers
Topic: Help setting up NAS/Samba
Replies: 3
Views: 1243

Re: Help setting up NAS/Samba

There are several projects in the project section of this site that describe in detail how to create a NAS server (or 'home server'). You might also like to look for projects on the 'instructables' website. Watch out that some of them may be fairly old now and quote older versions of the necessary p...
by FirstTenor
Fri May 23, 2014 10:44 am
Forum: Networking and servers
Topic: Problem understanding Apache2 setup
Replies: 4
Views: 2267

Re: Problem understanding Apache2 setup

Thanks for that information. I could not find the description about the Alias command anywhere - but can now understand how it gets applied. I think I have moved this a bit further forward - but not far... I modified the Alias command to 'Alias /media /var/www/media' as you suggested. I copied the s...
by FirstTenor
Wed May 21, 2014 6:34 pm
Forum: Networking and servers
Topic: Problem understanding Apache2 setup
Replies: 4
Views: 2267

Problem understanding Apache2 setup

I am trying to use Apache2 as the web host for Seafile - as a file sharing server. This is all running on RPi & Raspbian - booted off a NOOBS Distro that has now had several extra installations added to it (too many to type here). I have Seafile installed and it claims to start :-) I already had Apa...
by FirstTenor
Wed May 07, 2014 12:43 pm
Forum: Troubleshooting
Topic: Attempt to install Kerberos says no krb5-config
Replies: 0
Views: 1181

Attempt to install Kerberos says no krb5-config

Running on RPi with current Raspbian. I have the python developer tools, OpenSSL, etc all loaded & running. I have installed a number of other programs including Webmin. I am trying to install GateOne to provide a secure shell service from outside my firewall. It says that I need Kerberos to provide...
by FirstTenor
Wed May 07, 2014 7:11 am
Forum: Troubleshooting
Topic: Having trouble installing GateOne
Replies: 2
Views: 646

Re: Having trouble installing GateOne

Think that I found the problem - the Python developer functions were not installed with the standard raspberian - so no 'pip' amongst other things.

Just not used to compiling / installing this kind of code so could not understand the error messages.
by FirstTenor
Wed May 07, 2014 7:05 am
Forum: Troubleshooting
Topic: Forums not working properly
Replies: 21
Views: 2707

Re: Forums not working properly

If it's of any help - I have been getting this too - but only the first time logging in from a different system: IE on windows PC / Midori on RPi / Safari on iPad. Also had the problem again after an upgrade / forced reboot of the windows PC (new version of IE).
by FirstTenor
Mon May 05, 2014 9:31 am
Forum: Beginners
Topic: Need basic advice on installing packages
Replies: 1
Views: 350

Need basic advice on installing packages

I am very new to programming. I am trying to follow instructions for one of the projects - but they are a bit old and most of the packages listed have changed ... So I am having to find and download source to compile and install. Some sites have very simple 'installer.sh' scripts that pull down a ta...
by FirstTenor
Sun May 04, 2014 9:06 pm
Forum: Troubleshooting
Topic: Having trouble installing GateOne
Replies: 2
Views: 646

Re: Having trouble installing GateOne

The actual error portion .... Ign http://repository.wolfram.com stable/non-free Translation-en_GB Ign http://repository.wolfram.com stable/non-free Translation-en Reading package lists... Done + DEBIAN_FRONTEND=noninteractive + apt-get -y $'\302\240\302\240\302\240\302\240\302\240\302\240\302\240\30...
by FirstTenor
Sun May 04, 2014 8:56 pm
Forum: Troubleshooting
Topic: Having trouble installing GateOne
Replies: 2
Views: 646

Having trouble installing GateOne

I am trying to install a secure terminal server on the RPi. There seem to be several suggestions out there - but the clear favourites seem to be GateOne by Liftoff or 'Shell in a box'.... With GateOne having more features & less footprint. ... By the way, I am new to RPi - used unix years ago (1980'...
by FirstTenor
Fri May 02, 2014 5:53 pm
Forum: Staffroom, classroom and projects
Topic: Why use a RPi at school?
Replies: 32
Views: 7924

Re: Why use a RPi at school?

I am not a teacher - but an IT consultant. I was asked this same question recently by a group of teachers ... My answer was 'To get the kids interested in more than 'consuming' programs that someone else has sold them'... Show them how they can solve real problems - like: You have a Mars rover and y...

Go to advanced search