Go to advanced search

by W9RAN
Sat Oct 29, 2016 2:57 pm
Forum: Troubleshooting
Topic: Bluetooth drops and locks up
Replies: 7
Views: 1449

Re: Bluetooth drops and locks up

Subsequently I disabled the bluetooth timeout function by commenting out the 2nd line below:

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle


This still does not fix the bluetooth timeout problem. I'm filing a bug report.
by W9RAN
Sat Oct 29, 2016 2:22 am
Forum: Troubleshooting
Topic: Bluetooth drops and locks up
Replies: 7
Views: 1449

Re: Bluetooth drops and locks up

I decided to try removing the blueman applet. Did that, purged, updated, etc. Bluetooth now seems to be a little better behaved but a new problem has come up - the Pi totally locks up after a while, not sure it's related. Python app freezes, USB devices unresponsive, remote ssh session disconnects. ...
by W9RAN
Thu Oct 27, 2016 7:21 pm
Forum: Troubleshooting
Topic: Bluetooth drops and locks up
Replies: 7
Views: 1449

Re: Bluetooth drops and locks up

Thanks, very similar to what I see. BT will play all day unless the audio source is muted or stopped, then it will time out and nothing short of a reboot will restore BT function. Can't get any response to pairing or connect commands. Something must be killing the driver and hopefully will be addres...
by W9RAN
Wed Oct 26, 2016 3:20 pm
Forum: Troubleshooting
Topic: Bluetooth drops and locks up
Replies: 7
Views: 1449

Bluetooth drops and locks up

Bluetooth audio seems to work OK as long as the audio source is running, but muting or stopping the app results in Bluetooth disconnect - never to return. Blueman applet will not respond ("Timeout reached") for connect, disconnnect, or any other function. Rebooting and re-pairing is necessary. Anyon...
by W9RAN
Sun Oct 23, 2016 6:48 pm
Forum: Troubleshooting
Topic: Bluetooth device not showing up in Pulseaudio
Replies: 7
Views: 2890

Re: Bluetooth device not showing up in Pulseaudio

Thanks. I did manage to get the headphones connected although I'm not sure I did exactly what you said. I have two Bluetooth icons as a result of installing stuff recommended in other threads and that could be part of the problem. But to be clear, when you say "little speaker" do you mean the one in...
by W9RAN
Sun Oct 23, 2016 4:00 pm
Forum: Troubleshooting
Topic: Bluetooth device not showing up in Pulseaudio
Replies: 7
Views: 2890

Re: Bluetooth device not showing up in Pulseaudio

Thanks for that link, maybe I've got competing Bluetooth software after reading and installing things from previous threads. I may go ahead and remove some stuff and update. I'm running the newest kernel and OS with Pixel btw. As stated, I do have Pulseaudio installed. It seems to not be starting au...
by W9RAN
Sun Oct 23, 2016 4:33 am
Forum: Troubleshooting
Topic: Bluetooth device not showing up in Pulseaudio
Replies: 7
Views: 2890

Bluetooth device not showing up in Pulseaudio

I have Blueman and "Manage Bluetooth devices" installed and can pair with an audio device but when I try to connect it says - "Connection failed - Use the audio menu to connect to this device," What the hell is the "audio menu"? There is no "Audio Menu"! So I installed Pulseaudio, which doesn't seem...
by W9RAN
Sat Oct 22, 2016 5:33 pm
Forum: Troubleshooting
Topic: Terrible WiFi performance
Replies: 0
Views: 273

Terrible WiFi performance

I've just put together a Pi3 with the official R-Pi Touchscreen, and while WiFi works, the performance is extremely poor, with speed tests from sites like testmy.net yielding results around 1mbps vs. 24 mbps when using hardwired ethernet. Internet access is noticably sluggish and more importantly to...
by W9RAN
Mon Jul 27, 2015 2:24 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23366

Re: RPI RTL-SDR server: Segmentation fault.

Slaven, After a bit more experimenting I got audio to run, using VLC to play the audio stream at port :1234. However, I can only get it to work with Steam BWbit set to 8000, which works with either Ogg Vobis or FLAC codecs. But with 16000 or higher settings, both MNM and VLC seem to be working norma...
by W9RAN
Mon Jul 27, 2015 1:45 am
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23366

Re: RPI RTL-SDR server: Segmentation fault.

Slaven, That was exactly the right suggestion! I wiped everything clean and followed those steps and now have things running well. The only remaining issue is I don't have audio, even though the stream is connecting and the spectrum analyzer function works. So I'll dig into that now that I've overco...
by W9RAN
Fri Jul 24, 2015 4:35 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23366

Re: RPI RTL-SDR server: Segmentation fault.

Slaven, Thanks but I'm still getting nowhere. I've installed what seems to be the latest version of .NET Framework (4.5.2) just to be sure and Windows Update says everything is up to date. So I don't know what to do about the .NET exceptions I continue to get. After reading the discussion you refere...
by W9RAN
Wed Jul 22, 2015 4:11 am
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23366

Re: RPI RTL-SDR server: Segmentation fault.

Staven, Thanks for the detailed assistance. The db info command says my version is MSSQLLocalDB so that's what I edited into the xml file, but when I try to run it now I get a .NET error. I don't recall you mentioning which version of .NET is required. (I can send you the debug info if you like, jus...
by W9RAN
Sun Jul 19, 2015 8:05 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23366

Re: RPI RTL-SDR server: Segmentation fault.

Hi, I'm interested in trying it but having trouble with the installation. Installation fails due to not having Microsoft SQL Express installed so I tried doing that first on an old XP machine, which it said was not a supported OS. Assuming this was due to EOL support issues, I switched to a new i7 m...
by W9RAN
Fri Apr 17, 2015 3:09 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23366

Re: RPI RTL-SDR server: Segmentation fault.

This did not do anything to fix the problem. It only allowed me to confirm that the version of WinUSB being fetched by apt-get is 11-1 not 19-1, and attempts to install 19-1 directly failed due to not having required dependencies. Attempts to install listed dependencies also failed. Key word: Failed...
by W9RAN
Tue Apr 07, 2015 2:56 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23366

Re: RPI RTL-SDR server: Segmentation fault.

I've had this problem for months too, so was happy to try the suggestions here related to the version of libusb-1.0 that is installed. Unfortunately the procedure described that is supposed to force aptitude to get the updated version from the "jesse" repository does not work for me. I've triple-che...
by W9RAN
Mon May 19, 2014 8:46 pm
Forum: Troubleshooting
Topic: Buffer Underruns with rtl_fm and aplay
Replies: 24
Views: 12121

Re: Buffer Underruns with rtl_fm and aplay

To close out this thread - the Rasbian developers have fixed the problem. After updating the kernel to 3.12.18+ #679, I am no longer experiencing buffer underruns. Presumably this change will be incorporated into the aptget package soon. Thanks to the team for the prompt and efficient response! 73, ...
by W9RAN
Mon Apr 07, 2014 11:53 pm
Forum: Troubleshooting
Topic: Buffer Underruns with rtl_fm and aplay
Replies: 24
Views: 12121

Re: Buffer Underruns with rtl_fm and aplay

This sounded promising, so I first did the usual apt-get update and upgrade, but the kernel version after rebooting remained 3.10.25 with #662 Preempt Friday Jan 3 2014 - the same as it was before. So evidently that is the latest official version. So I then used rpi-update to update the kernel, whic...
by W9RAN
Wed Apr 02, 2014 11:01 pm
Forum: Raspbian
Topic: ALSA recording broken by 3.10.25+ kernel
Replies: 6
Views: 3081

Re: ALSA recording broken by 3.10.25+ kernel

Richard - Thanks! I started the referenced thread above and yours is the most helpful comment received. For a newbie who has thus far only done update-upgrade, am I correct in thinking that to revert to the kernel that you referenced, I'll need to start from scratch with a new image on SD card? In o...
by W9RAN
Tue Apr 01, 2014 10:45 pm
Forum: Advanced users
Topic: What about reverting the kernel?
Replies: 5
Views: 1302

What about reverting the kernel?

Since a recent upgrade, my ALSA audio has been screwed-up, and no one seems to know why, even though others have experienced the same problem of intermittent choppy audio. The only oddball "cure" seem to be keeping the CPU busy doing something - anything that burns cycles - which makes the problem g...
by W9RAN
Sat Mar 29, 2014 1:37 am
Forum: Troubleshooting
Topic: Buffer Underruns with rtl_fm and aplay
Replies: 24
Views: 12121

Re: Buffer Underruns with rtl_fm and aplay

SDR# will decode the basic RDS data and display it on the spectrum display. I think someone did an enhanced version as a plug-in that could pull out other RDS data also. SDR# runs on a PC however, not on a Pi. Thanks for the workaround suggestions, I'll be giving it a try tomorrow. 73, Bob W9RAN
by W9RAN
Mon Mar 24, 2014 4:38 pm
Forum: Advanced users
Topic: rtl_fm not working RTL2832 + Raspberry Wideband Reciever
Replies: 12
Views: 10400

Re: rtl_fm not working RTL2832 + Raspberry Wideband Reciever

Mike, I've experienced the same thing since a update-upgrade about 2 weeks ago. I started a thread on this problem on the Troubleshooting forum and also the Osmocom mail reflector. Thus far, others have reported the same problem but no one has found a real solution, although I will share below what ...
by W9RAN
Sat Mar 22, 2014 5:01 pm
Forum: Troubleshooting
Topic: Buffer Underruns with rtl_fm and aplay
Replies: 24
Views: 12121

Re: Buffer Underruns with rtl_fm and aplay

Thanks to Alexandru Csete for verifying that the audio underruns disappear whenever the CPU is kept busy. To prove this, he created the following command line loop in another terminal: "while true; do find / -name pi; done" As long as this task is keeping the CPU plenty busy, the interruptions disap...
by W9RAN
Fri Mar 21, 2014 11:48 pm
Forum: Troubleshooting
Topic: Buffer Underruns with rtl_fm and aplay
Replies: 24
Views: 12121

Re: Buffer Underruns with rtl_fm and aplay

No resolution yet. I have tried direct and powered hub USB connections but it makes no difference. I've examined the dpkg logs and can't see any updates were made to ALSA, and I've verified that the same version of rtl_fm works flawlessly on an Xubuntu system using the same command line, so that ten...
by W9RAN
Wed Mar 19, 2014 5:04 pm
Forum: Troubleshooting
Topic: Buffer Underruns with rtl_fm and aplay
Replies: 24
Views: 12121

Buffer Underruns with rtl_fm and aplay

Before I ask for help with a problem, I try to identify the cause, but in this case I can't seem to even do that! rtl_fm is a simple FM radio app for DVB-T USB sticks and I've used it successfully for over a year, piping the audio output from it to aplay and the analog audio jack on the R-Pi. Audio ...
by W9RAN
Thu Mar 28, 2013 4:43 pm
Forum: Other projects
Topic: Bike Simulator - Cool Project
Replies: 4
Views: 3246

Re: Bike Simulator - Cool Project

Matthew - Back in 2011, someone did nearly what you describe using a Python program and and Arduino, along with some sensors. This is an app that is MEANT for the Raspberry Pi, but there's a problem. Back then there was no Linux broswer plug-in for Google Earth, and since then Google Maps has put al...

Go to advanced search