Go to advanced search

by MrEngman
Thu Jun 14, 2018 9:25 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 990572

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Wow -- your driver and hostapd works on 8188eu without a hitch. I am on Raspian 4.14.48+ on a Raspberry Pi Zero. Just from the modinfo 8818eu I see there is a lot more supported in this driver module. iw/iwconfig commands also seem to be working. Is there a GPL or BSD license for the source code fo...
by MrEngman
Thu Jun 14, 2018 9:20 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 990572

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Hi corrobor, It would appear the issue is to do with Raspbian Stretch and the mt7610u driver. When I checked the driver and it was OK when rebooting or using shutdown or halt it appears the kernel I was using was Raspbian Jessie although it was updated to kernel 4.14.44-v7+. I made a new SD card wi...
by MrEngman
Mon Jun 11, 2018 7:22 am
Forum: Troubleshooting
Topic: Can't get WiFi working with Pi Zero Ralink 7601
Replies: 1
Views: 57

Re: Can't get WiFi working with Pi Zero Ralink 7601

Just connected a mt7601 wifi to a Pi running Stretch and it connected to my wifi network straight away with name wlan, not ra. My wifi configuration is - /etc/network/interfaces # interfaces(5) file used by ifup(8) and ifdown(8) # Please note that this file is written to be used with dhcpcd # For st...
by MrEngman
Fri Jun 08, 2018 6:39 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 990572

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Hi corrobor, It would appear the issue is to do with Raspbian Stretch and the mt7610u driver. When I checked the driver and it was OK when rebooting or using shutdown or halt it appears the kernel I was using was Raspbian Jessie although it was updated to kernel 4.14.44-v7+. I made a new SD card wit...
by MrEngman
Thu Jun 07, 2018 10:37 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 990572

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Hi corrobor, Been running one of my Pi 2B with kernel 4.14.44-v7 with the T1U wifi for a few hours and tried rebooting several times and I've not had any problems. After issuing command sudo reboot the LED on the T1U flashes a couple of times and then turns off, then after a short time the LED on th...
by MrEngman
Tue Jun 05, 2018 3:16 pm
Forum: Troubleshooting
Topic: Broke off part on Raspi 3 ==> WIFI gone
Replies: 11
Views: 400

Re: Broke off part on Raspi 3 ==> WIFI gone

So why does my Pi 3B have one there?
by MrEngman
Sun Jun 03, 2018 9:24 pm
Forum: Troubleshooting
Topic: No SSH acess after Wifi Dongle install
Replies: 8
Views: 211

Re: No SSH acess after Wifi Dongle install

With Raspbian Stretch do not edit file /etc/network/interfaces to configure your network connection. Put I back to the default. Then you should set up the wifi by editing file /etc/wpa_supplicant/wpa_supplicant.conf like :- ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 coun...
by MrEngman
Tue May 29, 2018 9:01 am
Forum: General discussion
Topic: Two LEDs both "on" but nothing more...
Replies: 13
Views: 454

Re: Two LEDs both "on" but nothing more...

Maybe you have a problem with the SD card socket on the Pi so it cannot read the SD card.
by MrEngman
Sat May 26, 2018 9:07 pm
Forum: Beginners
Topic: Crontab doesn't run my .sh script (but script works standalone)
Replies: 5
Views: 118

Re: Crontab doesn't run my .sh script (but script works standalone)

In crontab you probably need to include the directory where your script is. e.g. * * * * * /home/pi/myscript.sh or whatever it actually is.

Read item 2 in the link you posted.
by MrEngman
Tue May 22, 2018 9:26 am
Forum: Python
Topic: iwlist scan maximal refresh rate
Replies: 6
Views: 218

Re: iwlist scan maximal refresh rate

Hi ProjZ, I think you will find 1 second is about the fastest the scan will run at. The time taken also appears to be dependent on how many APs the scan finds, or what wifi module you do the scan with. I have a Pi 3B+ which has an extra wifi module, an 8188eu module, connected to it. Scanning with t...
by MrEngman
Fri May 18, 2018 8:46 am
Forum: Python
Topic: iwlist scan maximal refresh rate
Replies: 6
Views: 218

Re: iwlist scan maximal refresh rate

Ok I guess there is nothing I can do in Python to speed it up. I'm still wondering what is the underlying reason of this slowdown. Anyway thank you very much for your answer Paul Hutch! (Sorry for the long delay by the way) I believe the scan results are saved somewhere when the Pi boots and connec...
by MrEngman
Thu May 17, 2018 3:54 pm
Forum: Troubleshooting
Topic: Unable to make D-Link DWA-131E1 driver working
Replies: 1
Views: 79

Re: Unable to make D-Link DWA-131E1 driver working

I am trying to get my D-Link WiFi adapter working in my Raspberry Pi 3.( Kernel 4.14.39) .I tried following instructions in many of the previous posts, I understood that I need to install 8192eu driver. I downloaded the zip file from http://downloads.fars-robotics.net/wifi-drivers/8192eu-drivers/81...
by MrEngman
Mon May 14, 2018 1:39 pm
Forum: Troubleshooting
Topic: "sudo ifup wlan0" shows "unknown interface wlan0"
Replies: 4
Views: 344

Re: "sudo ifup wlan0" shows "unknown interface wlan0"

Try these

Code: Select all

sudo ip link set wlan0 down
sudo ip link set wlan0 up
by MrEngman
Mon Apr 30, 2018 12:03 pm
Forum: Troubleshooting
Topic: RPI as an acces point with USB wifi dongle PROBLEM
Replies: 10
Views: 263

Re: RPI as an acces point with USB wifi dongle PROBLEM

Hello, I just followed this tutorial on how to make your rpi as an access point. (https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md) After going through all the steps the pi won't show up on my computer under networks. I followed al the steps but the problem is I am u...
by MrEngman
Fri Apr 27, 2018 10:31 pm
Forum: Raspbian
Topic: Nano Line Numbers
Replies: 3
Views: 259

Re: Nano Line Numbers

I accidentally enabled line numbers in Nano and I can't replicate it. It seems like I hit <shift>3 or <alt>3, or something close to that keying. It just doesn't work for me when I try to do it deliberately! How do I get nano to show the line numbers? In nano take a look at "Get Help" - cntl-G - on ...
by MrEngman
Fri Apr 27, 2018 10:05 am
Forum: Troubleshooting
Topic: Cannot set wifi up using ssh: Failed to connect to non-global ctrl_ifname: wlan0
Replies: 4
Views: 230

Re: Cannot set wifi up using ssh: Failed to connect to non-global ctrl_ifname: wlan0

PS: my whole wpa_supplicant.conf content is: ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 network={ ssid = "601" psk = "********" } You need to remove the spaces around the equal signs in the network={..} section to get it to work like ctrl_interface=DIR=/var/run/wpa_supp...
by MrEngman
Tue Apr 24, 2018 9:45 am
Forum: Troubleshooting
Topic: Edimax EW-7811UTC WIFIAC NOT WORKING
Replies: 102
Views: 16032

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

OS is Xbian which is also based on debian. Wouldn't that work? I don't know if it will. I compile the drivers using the source provided by RPF and the last kernel source for raspbian is 4.9.80 so I cannot compile the driver for 4.9.95 anyway. I had a look on the Xbian forum and found a post that su...
by MrEngman
Tue Apr 24, 2018 8:20 am
Forum: Troubleshooting
Topic: Edimax EW-7811UTC WIFIAC NOT WORKING
Replies: 102
Views: 16032

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

OS is Xbian which is also based on debian. Wouldn't that work? I don't know if it will. I compile the drivers using the source provided by RPF and the last kernel source for raspbian is 4.9.80 so I cannot compile the driver for 4.9.95 anyway. I had a look on the Xbian forum and found a post that su...
by MrEngman
Mon Apr 23, 2018 10:39 pm
Forum: Troubleshooting
Topic: Edimax EW-7811UTC WIFIAC NOT WORKING
Replies: 102
Views: 16032

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

@MrEngman Are you planning to create driver files for the RTL8812AU on kernel 4.9.95? That would be very much appreciated!! Wifi install script now tells me: *** Raspberry Pi wifi driver installer by MrEngman. Your current kernel revision = 4.9.95+ Your current kernel build = #1 I compile drivers f...
by MrEngman
Mon Apr 23, 2018 10:24 am
Forum: Troubleshooting
Topic: [SOLVED] wlan1 (5GHz) does not come up
Replies: 9
Views: 327

Re: [SOLVED] wlan1 (5GHz) does not come up

As you are running the latest kernel version, especially if you are using kernel Stretch, I'm wondering why you have edited file /etc/network/interfaces . Don't I have to declare the usual "auto lo // iface lo inet loopback..." under stretch? I just used my old interfaces-file from the former versi...
by MrEngman
Mon Apr 23, 2018 10:23 am
Forum: Troubleshooting
Topic: D.Link DWA 131 WLAN/USB Adapter not working
Replies: 211
Views: 60456

Re: D.Link DWA 131 WLAN/USB Adapter not working

pascale wrote:
Mon Apr 23, 2018 10:07 am
Hi MrEngman
I have now read all the script and it now works
:oops: :oops: :oops: :oops: :oops: :oops: :oops:
Thanks again
Paul
No problem, good to hear you've got it working.
by MrEngman
Mon Apr 23, 2018 10:02 am
Forum: Troubleshooting
Topic: D.Link DWA 131 WLAN/USB Adapter not working
Replies: 211
Views: 60456

Re: D.Link DWA 131 WLAN/USB Adapter not working

Hi again MrEngman I updated my kernal and rebooted and lost internet, my dongle does not work any more, I have stuck the sd card into a zero w and have tried the following script sudo wget http://www.fars-robotics.net/install-wifi -O /usr/bin/install-wifi sudo chmod +x /usr/bin/install-wifi sudo in...
by MrEngman
Mon Apr 23, 2018 9:23 am
Forum: Troubleshooting
Topic: [SOLVED] wlan1 (5GHz) does not come up
Replies: 9
Views: 327

Re: [SOLVED] wlan1 (5GHz) does not come up

MrEngman has on his webpage an sh-file that I ran. This file did everything, installing the driver as well as activating it. Unfortunately, I just realized that it is only with 2.4GHz, not 5GHz. I am sure that this is not a software issue. Hi andies, I am using the driver you are installing for you...
by MrEngman
Fri Apr 20, 2018 5:51 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 990572

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Hello, I've just upgrade to Linux raspberrypi 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux the compiled driver doesn't seems to be available for this kernel yet, right ? wget http://fars-robotics.net/8192eu-4.14.34-v7-1110.tar.gz Regards, Louis The web site has changed. http:...
by MrEngman
Fri Apr 13, 2018 7:30 pm
Forum: Beginners
Topic: Problems with TP-Link WiFi Adapter
Replies: 18
Views: 446

Re: Problems with TP-Link WiFi Adapter

Unfortunately, after both re-installing the script and running sudo install-wifi and trying direct download of the .tar.gz from downloads.fars-robotics.net, wireless still fails to work. The install script from the directly-downloaded tar.gz file still says to reboot, but my WiFi module is still no...

Go to advanced search