Unable to "apt-get install vim" cause of broken dependencies


4 posts
by Zinahe » Sun Jun 17, 2012 11:34 pm
apt-get install vim throws the following error.

vim : Depends: vim-runtime (= 2:7.3.429-2) but 2:7.3.547-1 is to be installed.

Obviously it looks like the installer is dealing with a newer version of vim-runtime; where as vim expects an older one.

Any advice ?
Posts: 16
Joined: Sun Jan 29, 2012 11:56 pm
by jecxjo » Sun Jun 17, 2012 11:43 pm
First I'd try updating your cache of the repo
Code: Select all
sudo apt-get update
sudo apt-get install vim-runtime
sudo apt-get install vim


I've run into this type of problem when the repo isn't completely up to date yet.
IRC (w/ SSL Support): jecxjo.mdns.org
Blog: http://jecxjo.motd.org/code
ProjectEuler Friend: 79556084281370_44d12dd95e92b1d9453aba2bdc94101b
User avatar
Posts: 157
Joined: Sat May 19, 2012 5:22 pm
Location: Ames, IA (USA)
by plugwash » Sun Jun 17, 2012 11:46 pm
This is an artefact of how raspbian works, the source and arch all packages are imported first and then the architecture specific packages are built. Therefore there is a time window when the arch all packages have been updated but the arch specific packages have not.

It should clear up soon.
Forum Moderator
Forum Moderator
Posts: 2344
Joined: Wed Dec 28, 2011 11:45 pm
by Zinahe » Mon Jun 18, 2012 1:00 am
You're right.

It worked when I retried after like 2 hours:

Setting up libgpm2:armhf (1.20.4-4) ...
Setting up vim-common (2:7.3.547-1) ...
Setting up vim-runtime (2:7.3.547-1) ...
Processing /usr/share/vim/addons/doc
Setting up vim (2:7.3.547-1) ...


Thanks
Posts: 16
Joined: Sun Jan 29, 2012 11:56 pm