No HDMI output on LG TV


29 posts   Page 1 of 2   1, 2
by Tommie » Tue Jun 12, 2012 12:25 pm
Hello,
I connected my Raspberry to my LG TV via HDMI and loaded the Debian 6 image onto the SD card, but altough I tried tinkering with config.txt and updated my firmware as well, I am still unable to get any video signal on my tv set ("No signal"). At least I am able to use SSH.

This is what read-edid says about the output of /opt/vc/bin/tvservice -d:
Code: Select all
pi@raspberrypi:~$ parse-edid edid.dat
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

   # EDID version 1 revision 3
Section "Monitor"
   # Block type: 2:0 3:fc
   Identifier "LG TV"
   VendorName "GSM"
   ModelName "LG TV"
   # Block type: 2:0 3:fc
   # Block type: 2:0 3:fd
   HorizSync 28-67
   VertRefresh 50-75
   # Max dot clock (video bandwidth) 150 MHz
   # DPMS capabilities: Active off:yes  Suspend:yes  Standby:yes

   Mode    "1360x768"   # vfreq 59.799Hz, hfreq 47.720kHz
      DotClock   84.750000
      HTimings   1360 1432 1568 1776
      VTimings   768 771 776 798
      Flags   "+HSync" "-VSync"
   EndMode
   Mode    "1280x768"   # vfreq 60.352Hz, hfreq 48.161kHz
      DotClock   80.140000
      HTimings   1280 1344 1472 1664
      VTimings   768 771 778 798
      Flags   "-HSync" "-VSync"
   EndMode
   # Block type: 2:0 3:fc
   # Block type: 2:0 3:fd
EndSection


I tried setting various options in /boot/config.txt, but with no actual success.

Code: Select all
pi@raspberrypi:~$ /opt/vc/bin/tvservice -s
state: HPD low|HDMI off|NTSC mode|composite CP off (0x140001), 720x480 @ 60Hz, interlaced
pi@raspberrypi:~$ /opt/vc/bin/tvservice -p
Powering on HDMI with preferred settings
[E] Failed to power on HDMI with preferred settings


Any advice?
Posts: 2
Joined: Tue Jun 12, 2012 12:18 pm
by dom » Tue Jun 12, 2012 12:33 pm
"state: HPD low" is the problem. Make sure monitor is powered on and on right input setting before booting pi.

If no luck, try hdmi_force_hotplug=1
(see here: http://elinux.org/R-Pi_Troubleshooting# ... put_at_all)
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4034
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by extravagoose » Tue Jun 12, 2012 12:35 pm
I had this issue with Arch - I first tried simply renaming or move the config.txt file to another directory... or just wipe its contents. This seemed to work for me. Of course this may bare no relevance to Debian or indeed you setup.

But as said by dom,
try using hdmi_force_hotplug=1
RPi 1: Hostname: Gimli, 500Gb USB HDD, ArchLinux | ARM.
Main Use: Bit of everything - but mainly web server, Network Storage and C programming.

RPi 2: Hostname tba, awaiting delivery.
User avatar
Posts: 59
Joined: Tue May 29, 2012 2:51 pm
Location: UK
by Tommie » Sun Jun 17, 2012 12:12 am
Using this config.txt, I still do not get a picture on my TV:

Code: Select all
root@raspberrypi:/home/pi# cat /boot/config.txt
sdtv_mode=2
hdmi_force_hotplug=1
config_hdmi_boost=5
hdmi_drive=2


Code: Select all
root@raspberrypi:/home/pi# /opt/vc/bin/tvservice -s
state: HPD high|HDMI mode|HDCP off|composite off (0x12001a), 1280x768 @ 60Hz, progressive
root@raspberrypi:/home/pi# /opt/vc/bin/tvservice -m CEA
Group CEA has 16 modes:
           mode 1: 640x480 @ 60Hz, progressive
           mode 2: 720x480 @ 60Hz, progressive
           mode 3: 720x480 @ 60Hz, progressive
           mode 4: 1280x720 @ 60Hz, progressive
  (native) mode 5: 1920x1080 @ 60Hz, interlaced
           mode 7: 720x480 @ 60Hz, interlaced
           mode 16: 1920x1080 @ 60Hz, progressive
           mode 17: 720x576 @ 50Hz, progressive
           mode 18: 720x576 @ 50Hz, progressive
           mode 19: 1280x720 @ 50Hz, progressive
           mode 20: 1920x1080 @ 50Hz, interlaced
           mode 22: 720x576 @ 50Hz, interlaced
           mode 31: 1920x1080 @ 50Hz, progressive
           mode 32: 1920x1080 @ 24Hz, progressive
           mode 33: 1920x1080 @ 25Hz, progressive
           mode 34: 1920x1080 @ 30Hz, progressive
root@raspberrypi:/home/pi# /opt/vc/bin/tvservice -m DMT
Group DMT has 4 modes:
           mode 4: 640x480 @ 60Hz, progressive
           mode 9: 800x600 @ 60Hz, progressive
           mode 16: 1024x768 @ 60Hz, progressive
           mode 23: 1280x768 @ 60Hz, progressive
root@raspberrypi:/home/pi#


How ever, no picture and TV indicating "NO SIGNAL".
Posts: 2
Joined: Tue Jun 12, 2012 12:18 pm
by steveastrouk » Sun Aug 05, 2012 5:58 pm
Tommie,
I have exactly the same problem - I've even updated my telly's firmware, but no joy.
Did you EVER get the thing working ?
Thanks

Steve
Posts: 6
Joined: Sun Aug 05, 2012 5:57 pm
by proyecto » Sun Aug 19, 2012 1:55 pm
Exactly the same problem. Not working yet.
http://www.twitter.com/proyecto
http://www.enigmatres.es
User avatar
Posts: 6
Joined: Sun Aug 19, 2012 1:54 pm
Location: Sevilla (Spain)
by steveastrouk » Sun Aug 19, 2012 3:27 pm
proyecto wrote:Exactly the same problem. Not working yet.


Balls. Me neither, but it MIGHT be worth unplugging the TV and trying again when it restarts.
Steve
Posts: 6
Joined: Sun Aug 05, 2012 5:57 pm
by dom » Sun Aug 19, 2012 3:41 pm
Make your you've got recent firmware (official wheezy/raspbian shoud be okay) and try
hdmi_safe=1
In config.txt.
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4034
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by steveastrouk » Sun Aug 19, 2012 4:00 pm
I've tried several HDMI hacks in the config file, and they didn't work. Will try the latest distribution though.

Steve
Posts: 6
Joined: Sun Aug 05, 2012 5:57 pm
by proyecto » Sun Aug 19, 2012 4:30 pm
I have also tested all the config hacks I have seen on the web, updated firmware with the latest Raspbian version, and nothing.
The same Raspi works perfectly in a samsung tv.
http://www.twitter.com/proyecto
http://www.enigmatres.es
User avatar
Posts: 6
Joined: Sun Aug 19, 2012 1:54 pm
Location: Sevilla (Spain)
by steveastrouk » Sun Aug 19, 2012 4:53 pm
proyecto wrote:I have also tested all the config hacks I have seen on the web, updated firmware with the latest Raspbian version, and nothing.
The same Raspi works perfectly in a samsung tv.


Trying the new firmware any minute. I'll concur shortly....
What the heck is it with LG and PI ?

Which TV have you got proyecto ?

Steve
Posts: 6
Joined: Sun Aug 05, 2012 5:57 pm
by steveastrouk » Sun Aug 19, 2012 5:24 pm
OK, Latest Raspbian,STILL no luck,
Hotplug set to 1
Safe mode set to 1
Posts: 6
Joined: Sun Aug 05, 2012 5:57 pm
by proyecto » Sun Aug 19, 2012 7:22 pm
Latest Raspbian, latest firmware updated via Hexxeh tool. Not working even with the config.txt hacks commented above.

My tv: http://www.lg.com/es/monitores/lg-M2780D-PZ-monitor

Code: Select all
/opt/vc/bin/tvservice -s
state: HPD high|HDMI mode|HDCP off|composite off (0x12001a), 640x480 @ 60Hz, progressive


Code: Select all
/opt/vc/bin/tvservice -m CEA
Group CEA has 1 modes:
           mode 1: 640x480 @ 60Hz, progressive
http://www.twitter.com/proyecto
http://www.enigmatres.es
User avatar
Posts: 6
Joined: Sun Aug 19, 2012 1:54 pm
Location: Sevilla (Spain)
by dom » Mon Aug 20, 2012 10:56 am
@steveastrouk @proyecto
Can you dump your edids and attach them to response (you will need to zip them)
/opt/vc/bin/tvservice -d edid.dat

@steveastrouk what is the exact model?
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4034
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by steveastrouk » Mon Aug 20, 2012 11:43 am
37LG6000
Posts: 6
Joined: Sun Aug 05, 2012 5:57 pm
by proyecto » Wed Sep 26, 2012 8:48 pm
Back again, not able to make it work yet. Attached edid.dat zipped.
Attachments
edid.dat.zip
(815 Bytes) Downloaded 104 times
http://www.twitter.com/proyecto
http://www.enigmatres.es
User avatar
Posts: 6
Joined: Sun Aug 19, 2012 1:54 pm
Location: Sevilla (Spain)
by deimusmeister » Wed Nov 28, 2012 11:42 pm
Is there any update on this ? seems rapsberry has a problem to connect to LG TVs
Posts: 4
Joined: Wed Nov 28, 2012 11:40 pm
by dom » Thu Nov 29, 2012 2:37 pm
proyecto wrote:Back again, not able to make it work yet. Attached edid.dat zipped.


Nothing surprising in edid.dat. With hdmi_safe=1 we are outputting a manditory HDMI mode, and we are hdmi compliant.

Possibilities are:
a hardware fault on Pi. If you can drive other monitors, then that seems unlikely.
a hardware fault on TV or with HDMI cable. Can you definitely drive this monitor from another source, using the same HDMI cable and HDMI input port on TV?

Other settings to randomly try: (remove hdmi_safe and other settings first)

Always add:
hdmi_force_hotplug=1
config_hdmi_boost=7

Try combintation of:
hdmi_drive=1
or
hdmi_drive=2

hdmi_group=1
or
hdmi_group=2

hdmi_mode=<mode>
with modes listed here:
http://elinux.org/RPi_config.txt
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4034
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by zwg_zero » Fri Nov 30, 2012 6:33 am
try add this line in config.txt (ignore reading TV's edid message)

hdmi_ignore_edid=0xa5000080
Posts: 3
Joined: Fri Nov 30, 2012 6:28 am
by deimusmeister » Thu Dec 06, 2012 8:04 pm
what address is that 0xa5000080 ?
In my case it might be another
Posts: 4
Joined: Wed Nov 28, 2012 11:40 pm
by deimusmeister » Thu Dec 06, 2012 8:08 pm
@dom can you please review my edid as well ?
Attachments
edid.dat.txt.zip
(1.34 KiB) Downloaded 80 times
Posts: 4
Joined: Wed Nov 28, 2012 11:40 pm
by proyecto » Thu Dec 06, 2012 8:36 pm
zwg_zero wrote:try add this line in config.txt (ignore reading TV's edid message)

hdmi_ignore_edid=0xa5000080


I will try it next week. Thanks!
http://www.twitter.com/proyecto
http://www.enigmatres.es
User avatar
Posts: 6
Joined: Sun Aug 19, 2012 1:54 pm
Location: Sevilla (Spain)
by deimusmeister » Thu Dec 06, 2012 9:13 pm
I'm just surfing, seems there is a widespread issues for LG HDMI inputs, anyway I don't have another HDMI device to test the tv :(
Posts: 4
Joined: Wed Nov 28, 2012 11:40 pm
by zwg_zero » Fri Dec 07, 2012 9:38 am
Posts: 3
Joined: Fri Nov 30, 2012 6:28 am
by aaa801 » Fri Dec 07, 2012 11:56 am
works fine on my lg tv
Posts: 427
Joined: Mon Jun 04, 2012 9:06 pm
Location: Berkshire