Installer SAMBA


10 posts
by mic78000 » Thu Dec 26, 2013 3:07 pm
Bonjour

J'essaie d'installer samba pour pouvoir voir les fichiers de la carte et d'un disque USB connecté sur la framboise.
J'ai donc suivi ce tuto : http://elinux.org/R-Pi_NAS#Configure_a_Samba_server_on_Debian_RPi
Tout se passe bien jusqu'à cette ligne :
Restart samba to use the new configuration file.

sudo /etc/init.d/samba restart

Là, j'obtiens
sudo: /etc/init.d/samba : command not found

A tout hasard : j'ai été voir, en faisant un cd pour aller dans /etc/init.d puis en faisant un ls, je ne vois pas de fichier samba (il est caché et ls n'affiche pas les fichiers cachés ?)
Par acquis de conscience, j'ai refait un sudo apt-get install samba samba-common-bin et il m'a bien dit qu'une version aussi récente était installée et du coup, j'ai dit non à cette réinstallation.
Posts: 38
Joined: Tue Dec 24, 2013 8:07 am
by totoharibo » Thu Dec 26, 2013 3:46 pm
étonnant non ?

que donne la commande :
dpkg -l samba*
tu devrais avoir un "ii" devant les packages chargés.
Posts: 769
Joined: Thu Jan 24, 2013 8:43 am
by mic78000 » Thu Dec 26, 2013 4:03 pm
Merci pour la réponse !
Voilà ce que j"obtiens : (d'ailleurs, au oassage, si tu sais comment dans putty, obtenir le bon affichage des caractères accentués...

pi@raspberrypi /dev $ dpkg -l samba*
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| Ãtat=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (Ãtat,Err: majuscule=mauvais)
||/ Nom Version Architecture Description
+++-====================-===============-===============-=============================================
un samba <aucun> (aucune description n'est disponible)
un samba-client <aucun> (aucune description n'est disponible)
ii samba-common 2:3.6.6-6 all common files used by both the Samba server an
ii samba-common-bin 2:3.6.6-6+deb7u armhf common files used by both the Samba server an
un samba-tools <aucun> (aucune description n'est disponible)
un samba4-clients <aucun> (aucune description n'est disponible)
un samba4-common <aucun> (aucune description n'est disponible)
pi@raspberrypi /dev $
Posts: 38
Joined: Tue Dec 24, 2013 8:07 am
by phil95 » Thu Dec 26, 2013 4:07 pm
Essayer sudo service samba start
Posts: 105
Joined: Wed Sep 12, 2012 8:10 am
Location: Paris
by mic78000 » Thu Dec 26, 2013 4:21 pm
à la commande

pi@raspberrypi ~ $ sudo service samba start
il me répond ceci :

samba: unrecognized service
Posts: 38
Joined: Tue Dec 24, 2013 8:07 am
by totoharibo » Thu Dec 26, 2013 8:47 pm
le service samba est dans le package samba (tout court)

le charger.
Ça devrait changer les choses.
Posts: 769
Joined: Thu Jan 24, 2013 8:43 am
by mic78000 » Fri Dec 27, 2013 8:47 am
Bonjour,
Effectivement,ça a chargé des choses puisque j'ai eu : :

pi@raspberrypi ~ $ sudo apt-get install samba
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
libwbclient0 samba-common smbclient tdb-tools
Paquets suggérés :
openbsd-inetd inet-superserver smbldap-tools ldb-tools ctdb
Les NOUVEAUX paquets suivants seront installés :
samba tdb-tools
Les paquets suivants seront mis à jour :
libwbclient0 samba-common smbclient
3 mis à jour, 2 nouvellement installés, 0 à enlever et 71 non mis à jour.
Il est nécessaire de prendre 8 226 ko dans les archives.
Après cette opération, 19,8 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?

Et ça marche (enfin pour cette étape) :
pi@raspberrypi ~ $ sudo /etc/init.d/samba restart
[ ok ] Stopping Samba daemons: nmbd smbd.
[ ok ] Starting Samba daemons: nmbd smbd.

Merci !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :D
Posts: 38
Joined: Tue Dec 24, 2013 8:07 am
by mic78000 » Fri Dec 27, 2013 6:20 pm
Et j'ajoute même que maintenant, j'ai été au bout et ça marche, j'ai accès à un dossier via samba depuis un micro windoz.
Posts: 38
Joined: Tue Dec 24, 2013 8:07 am
by totoharibo » Fri Dec 27, 2013 9:43 pm
en profiter maintenant pour faire un
apt-get update
apt-get upgrade
apt-get clean
Posts: 769
Joined: Thu Jan 24, 2013 8:43 am
by mic78000 » Sun Dec 29, 2013 6:16 am
C'est maintenant fait.
Merci !
Posts: 38
Joined: Tue Dec 24, 2013 8:07 am