Get black screen trying to use VNC to remot into my Pi


7 posts
by LucidEye » Mon Aug 12, 2013 9:04 am
OK... so I am running Pidora on the Pi with TigerVNC as the vnc server.
I am trying to remote into the Pi from my Ubuntu 12.10 laptop using Remmina Remote Desktop client.
I get a connection, but the client screen just shows up black with the 'X' shaped mouse cursor.
I have disabled IPv6 on both the laptop and the Pi.
I have disabled the firewall on both the laptop and the Pi.
I have heard this is an incompatibility with the XFCE desktop and I need to install the GNOME DE on the Pi.
Can anyone please tell me how to get this all working and if I really need to change my desktop environment on the Pi... I really like XFCE... can I make the vnc client work with XFCE rather than GNOME? It seems silly to me that they would use a desktop for Pidora that wasn't compatible with most vnc clients since many people connect to their Pi's remotely.
I really need to get the vnc remote working as I am using the Pi in "headless mode" as a remote WiFi camera and I need to be able to see what it's shooting via the vnc client window.

UPDATE: Also, I need to know how to set the firewall in Pidora to accept VNC connections or how to prevent the firewall service from starting up at boot... AND I need to know what boot file I need to edit so that the "vncserver" service starts at boot up. Thanks.

Thanks
Last edited by LucidEye on Mon Aug 12, 2013 6:37 pm, edited 1 time in total.
Posts: 44
Joined: Sun Aug 04, 2013 2:20 pm
by malcolmh » Mon Aug 12, 2013 2:01 pm
On the Pi, edit your ~/.vnc/xstartup file thus:

#!/bin/sh

startxfce4 &
Posts: 20
Joined: Fri Jul 29, 2011 3:59 pm
by LucidEye » Mon Aug 12, 2013 3:55 pm
Thank you for the reply, but could you please clarify exactly what this does? I am still somewhat new to Linux and don't like entering CLI stuff or editing system files without knowing exactly what and why I am doing. Thanks :-)
Posts: 44
Joined: Sun Aug 04, 2013 2:20 pm
by LucidEye » Mon Aug 12, 2013 5:08 pm
OK malcomh...
so I added the line "startxfce4 &" to the beginning of my ~/.vnc/xstartup file and... it still doesn't work.

When I try to connect to the Pi from my laptop with the vnc client app all I get is a black screen and an error message that pops up saying "failed to start session 'gnome' ".

Any other ideas?
Posts: 44
Joined: Sun Aug 04, 2013 2:20 pm
by malcolmh » Mon Aug 12, 2013 8:06 pm
The xstartup file should contain only those two lines - delete everything else.
Posts: 20
Joined: Fri Jul 29, 2011 3:59 pm
by LucidEye » Mon Aug 12, 2013 9:33 pm
Nope, that still didn't work... still only getting the black screen and mouse cursor in the vnc client app. I've wasted 2 days on this issue and this is getting really frustrating... this is really simple stuff that should work "out of the box" without all these problems but this is now the one thing keeping me from completing this project I'm working on. Will this work in Pidora, or should I go back to using Raspbian? I like Pidora better... more apps and features than Raspbian, and I couldn't get my camera to recognize under gphoto2 in Raspbian, but it seems to work fine in Pidora which is why I want to get the VNC working for this distro.
Hope someone can help me find a fix for this soon :-(
Posts: 44
Joined: Sun Aug 04, 2013 2:20 pm
by malcolmh » Tue Aug 13, 2013 7:01 am
Ah sorry, but there another step that I had forgot about. List the contents of file /lib/systemd/system/vncserver@.service and follow the instructions.

BTW, I found all this information by searching the web. This is a must when trying to solve these problems, rather than hoping that someone will bring the answer to you. There are usually others that have solved the problem and posted their findings somewhere.
Posts: 20
Joined: Fri Jul 29, 2011 3:59 pm