Picamera's problems


8 posts
by Assurpanibal » Wed Jun 26, 2013 1:08 pm
Hi guyz

I've got some problem with my Picamera: when i input the command raspistill -o for take a photo, my picamera doesn't respond, and it seems it is in "stand by", because i have to abort the process to continue typing in the terminal-

What kind of problem has my PiCamera? How can i deal with it?

It could be that other process (like bluetooth) interference with the PiCamera? I have to remove it with rmmod ?

please help a poor student in period of stage ;)
Posts: 14
Joined: Wed Jun 19, 2013 6:59 am
by RaTTuS » Wed Jun 26, 2013 1:19 pm
it's probably down to speeling ;)
1) make sure both ends of teh cables are properly inserted
2) make sure the sunney connector is properly seated
3) make sure you have good power
4) make sure it's all upto date [sudo apt-get update && sudo apt-get upgrade -y ]
1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX - Prosliver FTW
"That's not right, the badgers have moved the goalposts."
User avatar
Posts: 4159
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
by Assurpanibal » Wed Jun 26, 2013 2:20 pm
It doesn't seems an hardware problem, but a software issue.... As i see everything is ok, but it still doesnt' work
Posts: 14
Joined: Wed Jun 19, 2013 6:59 am
by RaTTuS » Wed Jun 26, 2013 4:22 pm
what does
vcgencmd get_camera
report
and one thread please
1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX - Prosliver FTW
"That's not right, the badgers have moved the goalposts."
User avatar
Posts: 4159
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
by jamesh » Wed Jun 26, 2013 4:49 pm
Assurpanibal wrote:Hi guyz

I've got some problem with my Picamera: when i input the command raspistill -o for take a photo, my picamera doesn't respond, and it seems it is in "stand by", because i have to abort the process to continue typing in the terminal-

What kind of problem has my PiCamera? How can i deal with it?

It could be that other process (like bluetooth) interference with the PiCamera? I have to remove it with rmmod ?

please help a poor student in period of stage ;)


What is the exact command you are typing on the command line - the command above won't work very well as it's written.
Moderator
Moderator
Posts: 10528
Joined: Sat Jul 30, 2011 7:41 pm
by tenochtitlanuk » Wed Jun 26, 2013 8:30 pm
If raspistill -o ./home/pi/ashurpanibal.jpg does not turn camera ( red LED) on & take a picture at the location spelled out for the output then you've either a bad camera or connection- or haven't updated software.
raspistill if typed alone in a terminal will give all the options.
Posts: 89
Joined: Fri Jul 06, 2012 8:51 pm
Location: Taunton, Somerset, UK
by Assurpanibal » Thu Jun 27, 2013 7:02 am
if i type vcgencmd get_camera resoult the same problem: the picamera's led turns on but i don't have any response form it or in the terminal, and i have to abort the command for continue typing in the terminal!
Posts: 14
Joined: Wed Jun 19, 2013 6:59 am
by RaTTuS » Thu Jun 27, 2013 7:19 am
Assurpanibal wrote:if i type vcgencmd get_camera resoult the same problem: the picamera's led turns on but i don't have any response form it or in the terminal, and i have to abort the command for continue typing in the terminal!

posting.php?mode=quote&f=63&p=377436#pr376960
the cables -....

and has it ever worked
1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX - Prosliver FTW
"That's not right, the badgers have moved the goalposts."
User avatar
Posts: 4159
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK