Networking With Android Devices


5 posts
by Matt » Wed Jun 26, 2013 11:26 am
I currently have 2 raspberry pis, both running xbian, on my network, connected via a wireless bridge. My pcs can all see the raspberry pi's with no issues whatsoever, but neither of my mobile android devices, phone or tablet, are able to see or communicate with the pis. I get a destination host unreachable when attempting to ping them. Any ideas why this might be happening and/or suggestions on how to fix it would be greatly appreciated.
Posts: 3
Joined: Wed Jun 26, 2013 11:19 am
by klricks » Wed Jun 26, 2013 5:15 pm
Make sure you are connecting to your local network via WIIFI.
If you are attempting to connect your mobile devices using the cell network then that is the same as trying to connect from an external internet connection.
In order to do that you would have to set up port forwarding on your router and use the IP from your ISP, not the local 192.168... one.
Go here for my RPi writeup. Basic config, Serial Port add-on etc:
http://home.budget.net/~klricks/Comp/RPi/Rpi.html
Posts: 1329
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
by Matt » Thu Jun 27, 2013 7:01 am
Thanks for the response. I am currently connecting via wifi, I can see my pcs on the same network via the android devices (tablet only has wifi) and I can see the pis from my pcs, so not sure why the android devices can't see the pis
Posts: 3
Joined: Wed Jun 26, 2013 11:19 am
by SirLagz » Thu Jun 27, 2013 7:33 am
What sort of wireless bridge ?
My Blog - http://www.sirlagz.net
Visit my blog for Tips, Tricks, Guides and More !
WiFi Issues ? Have a look at this post ! http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=44044
Posts: 1704
Joined: Mon Feb 20, 2012 8:53 am
Location: Perth, Australia
by Matt » Thu Jun 27, 2013 7:39 am
I'm using an old TP-Link 3g router that I flashed with gargoyle.This is bridging to a d-link dsl-2750u router.
Posts: 3
Joined: Wed Jun 26, 2013 11:19 am