Simple GUIDE: *Fully Automated* TV/Movie Following via XBMC


 
579 posts   Page 18 of 24   1 ... 15, 16, 17, 18, 19, 20, 21 ... 24
by DougieLawson » Fri Jan 10, 2014 9:07 pm
Your image doesn't have enough resolution to see the messages.

Try posting a full size image on http://imageshack.us and a link in [img][/img] tags to it here.
Hacker on ZX80, Microtan65, Raspberry Pis and Arduinos
Unemployed mainframe database troubleshooter
RPi owner since 2012.
Twitter: @DougieLawson

Gaffer tape is "The Force", it has a dark side and a light side and it holds the Universe together.
User avatar
Posts: 7118
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
by wheninromebro » Fri Jan 10, 2014 9:22 pm
To above.. thats udev trying to identify a device I think?

Remove any connected USB devices or disks and reboot.
Posts: 8
Joined: Wed Jun 05, 2013 4:08 am
by lilone21804 » Fri Jan 10, 2014 9:41 pm
DougieLawson wrote:Your image doesn't have enough resolution to see the messages.

Try posting a full size image on http://imageshack.us and a link in [img][/img] tags to it here.



If you click on the image, it takes you to a full size image which you can read the messages. Let me know if that doesn't work and I'll post a new image.
Posts: 125
Joined: Thu Aug 01, 2013 11:57 am
by DougieLawson » Fri Jan 10, 2014 10:43 pm
lilone21804 wrote:
DougieLawson wrote:Your image doesn't have enough resolution to see the messages.

Try posting a full size image on http://imageshack.us and a link in [img][/img] tags to it here.



If you click on the image, it takes you to a full size image which you can read the messages. Let me know if that doesn't work and I'll post a new image.


Your SDCard is 100% borked. It can't even read the partition table.
Hacker on ZX80, Microtan65, Raspberry Pis and Arduinos
Unemployed mainframe database troubleshooter
RPi owner since 2012.
Twitter: @DougieLawson

Gaffer tape is "The Force", it has a dark side and a light side and it holds the Universe together.
User avatar
Posts: 7118
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
by lilone21804 » Sat Jan 11, 2014 1:06 pm
DougieLawson wrote:
lilone21804 wrote:
DougieLawson wrote:Your image doesn't have enough resolution to see the messages.

Try posting a full size image on http://imageshack.us and a link in [img][/img] tags to it here.



If you click on the image, it takes you to a full size image which you can read the messages. Let me know if that doesn't work and I'll post a new image.


Your SDCard is 100% borked. It can't even read the partition table.




Well I have Raspbmc running off my USB flash drive. Is there anyway I can just rewrite the image back to another SD drive and still use my flash drive so that I don't lose all my data?
Posts: 125
Joined: Thu Aug 01, 2013 11:57 am
by supercazzola » Sat Jan 11, 2014 1:29 pm
I followed the instructions and incredible help in this thread. Set it up to watch for one tv show. flexget grabbed the right info and transmission was queuing two episodes. I went to bed. All seemed to be working well. When I woke up this morning, the transmission didn't seem to respond on port 9091. I double checked the config and that is the port it is listening on. i restarted the service, didn't fix it. I rebooted raspberry didn't fix it.
Seems to be listening on that port, but no web browsers I use are prompting me for username / password.
both files I saw downloading last evening are sitting in the incomplete directory, so I assume they didn't finish. Checking back after a few hours, their file size didn't change, so I assume transmission is not running, yet this is what netstat returns:

Code: Select all
xbian@xbian /etc/transmission $ netstat -an|grep 9091
tcp        0      0 0.0.0.0:9091            0.0.0.0:*               LISTEN     
tcp        1      0 192.168.1.145:9091      192.168.1.123:52356     CLOSE_WAIT
tcp      419      0 192.168.1.145:9091      192.168.1.123:52355     CLOSE_WAIT
tcp        1      0 192.168.1.145:9091      192.168.1.123:52363     CLOSE_WAIT
tcp      419      0 192.168.1.145:9091      192.168.1.123:52362     CLOSE_WAIT


Any ideas where to try and troubleshoot?

even after removing and reinstalling the transmission package, re-doing the config files, the web gui stops the moment the flexget inserts the torrents into the queue.
Posts: 1
Joined: Sat Jan 11, 2014 1:22 pm
by gonzocox » Sat Jan 11, 2014 7:53 pm
I went through the whole guide and I had flexget working fine with the config file. I then upgraded flexget to 1.2.30 and now when I run flexget -c /media/usb0/Downloads/flexget/config.yml --test execute

I get this error:

Traceback (most recent call last):
File "/usr/local/bin/flexget", line 9, in <module>
load_entry_point('FlexGet==1.2', 'console_scripts', 'flexget')()
File "/usr/local/lib/python2.7/dist-packages/flexget/__init__.py", line 25, in main
manager = Manager(options)
File "/usr/local/lib/python2.7/dist-packages/flexget/manager.py", line 105, in __init__
self.initialize()
File "/usr/local/lib/python2.7/dist-packages/flexget/manager.py", line 133, in initialize
self.init_sqlalchemy()
File "/usr/local/lib/python2.7/dist-packages/flexget/manager.py", line 565, in init_sqlalchemy
shutil.copy(self.db_filename, db_test_filename)
File "/usr/lib/python2.7/shutil.py", line 120, in copy
copymode(src, dst)
File "/usr/lib/python2.7/shutil.py", line 91, in copymode
os.chmod(dst, mode)
OSError: [Errno 38] Function not implemented: '/media/usb0/Downloads/flexget/test-config.sqlite'


I believe it is a configuration file problem because when I run flexget check I get this output:

2014-01-11 19:47 CRITICAL manager Failed to find configtion file config.yml


Has anybody else had this problem and knows how to solve this? Thanks!
Posts: 2
Joined: Mon Dec 09, 2013 5:04 am
by DougieLawson » Sat Jan 11, 2014 10:01 pm
lilone21804 wrote:
DougieLawson wrote:
Your SDCard is 100% borked. It can't even read the partition table.




Well I have Raspbmc running off my USB flash drive. Is there anyway I can just rewrite the image back to another SD drive and still use my flash drive so that I don't lose all my data?


The SDCard and USB keys are completely separate filesystems? Create a new SDCard and you should be able to re-discover the data on your flash drive.
Hacker on ZX80, Microtan65, Raspberry Pis and Arduinos
Unemployed mainframe database troubleshooter
RPi owner since 2012.
Twitter: @DougieLawson

Gaffer tape is "The Force", it has a dark side and a light side and it holds the Universe together.
User avatar
Posts: 7118
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
by lilone21804 » Sun Jan 12, 2014 12:14 am
DougieLawson wrote:
lilone21804 wrote:
DougieLawson wrote:
Your SDCard is 100% borked. It can't even read the partition table.




Well I have Raspbmc running off my USB flash drive. Is there anyway I can just rewrite the image back to another SD drive and still use my flash drive so that I don't lose all my data?


The SDCard and USB keys are completely separate filesystems? Create a new SDCard and you should be able to re-discover the data on your flash drive.



Care to advise on creating a new USB? The first time I did it, I used the NOOB installer with an older version of Raspbmc. If I download Raspbmc, it will give me a newer version. Will that effect anything being that the USB was created with an older version?
Posts: 125
Joined: Thu Aug 01, 2013 11:57 am
by wheninromebro » Sun Jan 12, 2014 1:46 am
Anyone work out how to get all episodes of the current season to date not just the latest one?

Cheers,
Posts: 8
Joined: Wed Jun 05, 2013 4:08 am
by lilone21804 » Sun Jan 12, 2014 2:21 am
wheninromebro wrote:Anyone work out how to get all episodes of the current season to date not just the latest one?

Cheers,


You have to manually download them yourself. This is set up to only download current episodes of TV shows that are currently airing.
Posts: 125
Joined: Thu Aug 01, 2013 11:57 am
by wheninromebro » Sun Jan 12, 2014 2:37 am
Sooo close. I still have a syntax issue me thinks?

pi@raspbmc:/media/MONSTER/Downloads/Flexget$ /usr/local/bin/flexget -c /media/MONSTER/Downloads/Flexget/config_3.yml --test execute
2014-01-12 15:27 CRITICAL manager while parsing a block mapping in "<unicode string>", line 64, column 5: priority: 3 ^ expected <block end>, but found '<block mapping start>' in "<unicode string>", line 70, column 7: movies: watchlist ^

-------------------------------------------------------------------------------
Malformed configuration file (check messages above). Common reasons:
-------------------------------------------------------------------------------

o Indentation error
o Missing : from end of the line
o Non ASCII characters (use UTF8)
o If text contains any of :[]{}% characters it must be single-quoted (eg. value{1} should be 'value{1}')

Reason: expected <block end>, but found '<block mapping start>'

Check configuration near line 63, column 4
Check configuration near line 69, column 6

Fault is almost always in one of these lines or previous ones

Here is my config file. http://pastebin.com/BV0Szm8U

I can get TV shows ok just not the movies working.

Cheers, Help appreciated.
Posts: 8
Joined: Wed Jun 05, 2013 4:08 am
by ct54 » Sun Jan 12, 2014 10:36 am
wheninromebro wrote:Sooo close. I still have a syntax issue me thinks?

pi@raspbmc:/media/MONSTER/Downloads/Flexget$ /usr/local/bin/flexget -c /media/MONSTER/Downloads/Flexget/config_3.yml --test execute
2014-01-12 15:27 CRITICAL manager while parsing a block mapping in "<unicode string>", line 64, column 5: priority: 3 ^ expected <block end>, but found '<block mapping start>' in "<unicode string>", line 70, column 7: movies: watchlist ^

-------------------------------------------------------------------------------
Malformed configuration file (check messages above). Common reasons:
-------------------------------------------------------------------------------

o Indentation error
o Missing : from end of the line
o Non ASCII characters (use UTF8)
o If text contains any of :[]{}% characters it must be single-quoted (eg. value{1} should be 'value{1}')

Reason: expected <block end>, but found '<block mapping start>'

Check configuration near line 63, column 4
Check configuration near line 69, column 6

Fault is almost always in one of these lines or previous ones

Here is my config file. http://pastebin.com/BV0Szm8U

I can get TV shows ok just not the movies working.

Cheers, Help appreciated.


try interval: 1 days with the s maybe that works
and in line 79, you still use "preset" instead of "template"
greetz
CT54
Posts: 21
Joined: Fri Jan 03, 2014 7:10 pm
by gonzocox » Mon Jan 13, 2014 4:19 am
Nevermind, I just figured it out. For some odd reason I had other files in my flexget folder that I had to delete. I forget what they were but I believe it was test file and than a dt-database or something like that file. Everything is up and running now.
Posts: 2
Joined: Mon Dec 09, 2013 5:04 am
by ct54 » Wed Jan 15, 2014 7:16 am
hello,

Got a new error with the imdb_list plugin
I get this error:
2014-01-14 20:49 VERBOSE imdb_list Fill movie queue Retrieving list watchlist ...
2014-01-14 20:49 CRITICAL plugin Fill movie queue Unable to get imdb list: 404 Client Error: Not Found
2014-01-14 20:49 WARNING task Fill movie queue Aborting task (plugin: imdb_list)

Does anyone know what to do with this?
It's a public watchlist.

Greetz
Posts: 21
Joined: Fri Jan 03, 2014 7:10 pm
by GarryL » Fri Jan 17, 2014 12:58 pm
So just installed Flexget and all is working fine. The only problem I have though is that when it automatically downloads certain shows, the name of the show is different to what I have called it so it creates another folder.

For example, currently on my hard drive I keep a show under the folder:
/Media/USBHDD/shares/Television/The Tomorrow People.

When Flexget starts to download The Tomorrow People it will download it into a custom folder:
/Media/USBHDD/shares/Television/The Tomorrow People 2013

What would I have to add to my config.yml file so that the shows join my existing folders I have created?

Below is my config code. Many thanks :D
Code: Select all
tasks:
  task-a:
    rss: http://showrss.info/rss.php?user_id=158236&hd=null&proper=null
    all_series: yes
    transmission:
      host: localhost
      port: 9091
      username: *****
      password: *****
      path: /media/USBHDD/shares/Television/{{series_name}}/{{series_name}} Season {{series_season}}
      addpaused: no
Posts: 2
Joined: Sun Jan 12, 2014 3:24 pm
Location: London, England
by effemmeffe » Fri Jan 17, 2014 1:13 pm
It's easier to remove your old directory and use the new one created by flexget.
XBMC will recognize it without any problem and you'll see the show in the TV shows list as you are doing now.
Posts: 19
Joined: Thu Jan 10, 2013 1:25 pm
by kennyeni » Sun Jan 19, 2014 5:53 pm
Hi,

I noticed that flexget has updated and several other things have changed (showrss new URL, and usb0 directories), so here's my config.yaml in case it's useful for someone:

Code: Select all
templates:
  tvshows:
    exists_series:
      - /media/usb0/TV Shows/
      - /media/usb0/Downloads/
    regexp:
      reject:
        - FASTSUB
        - VOSTFR
        - Subtitulado
    content_filter:
      reject:
        - '*.rar'
        - '*.zip'
        - '*.avi' 
    transmission:
      host: localhost
      port: 9091
      username: USER
      password: PASS
      path: /media/usb0/TV Shows/{{series_name}}/S{{"%02d"|format(series_season)}} 
    inputs:
      - rss: http://showrss.info//rss.php?user_id=USER&hd=2&proper=1&namespaces=true&magnets=true
      - rss: http://kat.ph/tv/?rss=1
      - rss: http://ezrss.it/feed/
      - rss: http://rss.bt-chat.com/?group=3
      - rss: http://extratorrent.com/rss.xml?cid=8
  movies:
    transmission:
      host: localhost
      port: 9091
      username: USER
      password: PASS
      path: /media/usb0/Movies

tasks:
  Get tvshows 720p hdtv:
    priority: 1
    template: tvshows
    configure_series:
      from:
        trakt_list:
          username: USER
          password: PASS
          api_key: API
          custom: Following
      settings:
        quality: 720p
 
  Fill movie queue:
    priority: 3
    interval: 1 day
    trakt_list:
      username: USER
      api_key: API
      movies: watchlist
    seen: local                    # We don't want accepted movies on this feed to affect actual download feed
    queue_movies:
      quality: 720p+ bluray
    imdb_lookup: yes
    accept_all: yes
 
  Get movies:
    template: movies
    priority: 4
    content_size:
      max: 2200
      min: 780
    torrent_alive: yes
    discover:
      what:
        - emit_movie_queue: yes
      from:
        - piratebay: yes
        - search_rss:
            url: http://pirateproxy.net/feeds/207
            link: magneturi
        - search_rss:
            url:  http://katmirror.com/highres-movies/?rss=1
        - kat:
            verified: yes
        - torrentz: verified
    movie_queue: yes



Also, is there anyway to download the episodes I'm missing? Using trakt.tv progress watcher and all that, also schedule "finished" Shows, so I always have the next 2 episodes I need to see? (when I see one, it could be deleted and the next one queued)
Posts: 2
Joined: Sat Dec 28, 2013 5:27 am
by txt3rob » Mon Jan 20, 2014 11:14 am
i keep getting when checking flexget config

Code: Select all
xbian@xbian /media/usb0/Downloads/flexget $ sudo flexget -c /media/usb0/Downloads/flexget/config.yml check                       2014-01-20 11:14 CRITICAL manager                       [/] The key `presets` is not valid here.
2014-01-20 11:14 CRITICAL manager                       [/tasks/Get movies] The key `preset` is not valid here. Only known plugin names are valid keys.
2014-01-20 11:14 CRITICAL manager                       [/tasks/Get tvshows 720p hdtv] The keys `import_series`, `preset` are not valid here. Only known plugin names are valid keys.
2014-01-20 11:14 CRITICAL manager                       [/tasks/Get tvshows hdtv <720p] The keys `import_series`, `preset` are not valid here. Only known plugin names are valid keys.
2014-01-20 11:14 CRITICAL manager                       [/tasks/Fill movie queue/queue_movies] The key `force` is not valid here.
xbian@xbian /media/usb0/Downloads/flexget $
The Raspberry Pi Hell Guy - Random Ramblings to assist me and others.
http://raspberrypihell.blogspot.com
My Github - http:/www.github.com/txt3rob/
www.smspi.co.uk - send free uk sms via your raspberry pi from here
Posts: 336
Joined: Sat Aug 11, 2012 3:45 pm
by txt3rob » Mon Jan 20, 2014 11:19 am
kennyeni wrote:Hi,

I noticed that flexget has updated and several other things have changed (showrss new URL, and usb0 directories), so here's my config.yaml in case it's useful for someone:

Code: Select all
templates:
  tvshows:
    exists_series:
      - /media/usb0/TV Shows/
      - /media/usb0/Downloads/
    regexp:
      reject:
        - FASTSUB
        - VOSTFR
        - Subtitulado
    content_filter:
      reject:
        - '*.rar'
        - '*.zip'
        - '*.avi' 
    transmission:
      host: localhost
      port: 9091
      username: USER
      password: PASS
      path: /media/usb0/TV Shows/{{series_name}}/S{{"%02d"|format(series_season)}} 
    inputs:
      - rss: http://showrss.info//rss.php?user_id=USER&hd=2&proper=1&namespaces=true&magnets=true
      - rss: http://kat.ph/tv/?rss=1
      - rss: http://ezrss.it/feed/
      - rss: http://rss.bt-chat.com/?group=3
      - rss: http://extratorrent.com/rss.xml?cid=8
  movies:
    transmission:
      host: localhost
      port: 9091
      username: USER
      password: PASS
      path: /media/usb0/Movies

tasks:
  Get tvshows 720p hdtv:
    priority: 1
    template: tvshows
    configure_series:
      from:
        trakt_list:
          username: USER
          password: PASS
          api_key: API
          custom: Following
      settings:
        quality: 720p
 
  Fill movie queue:
    priority: 3
    interval: 1 day
    trakt_list:
      username: USER
      api_key: API
      movies: watchlist
    seen: local                    # We don't want accepted movies on this feed to affect actual download feed
    queue_movies:
      quality: 720p+ bluray
    imdb_lookup: yes
    accept_all: yes
 
  Get movies:
    template: movies
    priority: 4
    content_size:
      max: 2200
      min: 780
    torrent_alive: yes
    discover:
      what:
        - emit_movie_queue: yes
      from:
        - piratebay: yes
        - search_rss:
            url: http://pirateproxy.net/feeds/207
            link: magneturi
        - search_rss:
            url:  http://katmirror.com/highres-movies/?rss=1
        - kat:
            verified: yes
        - torrentz: verified
    movie_queue: yes



Also, is there anyway to download the episodes I'm missing? Using trakt.tv progress watcher and all that, also schedule "finished" Shows, so I always have the next 2 episodes I need to see? (when I see one, it could be deleted and the next one queued)


thank you this has fixed my issue :D
The Raspberry Pi Hell Guy - Random Ramblings to assist me and others.
http://raspberrypihell.blogspot.com
My Github - http:/www.github.com/txt3rob/
www.smspi.co.uk - send free uk sms via your raspberry pi from here
Posts: 336
Joined: Sat Aug 11, 2012 3:45 pm
by haralder » Sun Jan 26, 2014 8:32 pm
It seems that the config is obsolete in the current flexget version. I made it work with the following changes:
presets -> templates
preset -> template
import_series -> configure_series

i keep getting when checking flexget config

Code: Select all
xbian@xbian /media/usb0/Downloads/flexget $ sudo flexget -c /media/usb0/Downloads/flexget/config.yml check 2014-01-20 11:14 CRITICAL manager [/] The key `presets` is not valid here.
2014-01-20 11:14 CRITICAL manager [/tasks/Get movies] The key `preset` is not valid here. Only known plugin names are valid keys.
2014-01-20 11:14 CRITICAL manager [/tasks/Get tvshows 720p hdtv] The keys `import_series`, `preset` are not valid here. Only known plugin names are valid keys.
2014-01-20 11:14 CRITICAL manager [/tasks/Get tvshows hdtv <720p] The keys `import_series`, `preset` are not valid here. Only known plugin names are valid keys.
2014-01-20 11:14 CRITICAL manager [/tasks/Fill movie queue/queue_movies] The key `force` is not valid here.
xbian@xbian /media/usb0/Downloads/flexget $
Posts: 1
Joined: Sun Jan 26, 2014 8:29 pm
by fredo55 » Mon Jan 27, 2014 9:17 pm
I need help to fix this error when testing my config.yml with flexget:
2014-01-27 20:25 CRITICAL manager [/tasks/movie_queue] Got `True`, expected: dict

Thanks.
Posts: 16
Joined: Fri Dec 27, 2013 5:57 pm
by fredo55 » Sat Feb 01, 2014 12:12 am
Any ideas?
Posts: 16
Joined: Fri Dec 27, 2013 5:57 pm
by ryantcarter » Sun Feb 02, 2014 9:36 am
Hi Guys,

managed to sort all of the errors in the config file by reading flexgets upgrade actions log - http://flexget.com/wiki/UpgradeActions

I'm only wanting to configure the movies section as I use showrss' filtering to do all of the legwork for my TV shows.

I'm a little confused as to how it works though, I've stripped down the config file so it only searches a kat proxy (I find it hard to find TPB feeds here in the UK) I've got it so it queues my movies up but when it starts searching it seems to search random torrents and tries to match them. This can't be right can it?

Can anyone see what's wrong here?
http://pastebin.com/FYxepqsk

Config - http://pastebin.com/nH6HpaUf
Posts: 6
Joined: Wed Oct 02, 2013 7:26 pm
by ct54 » Sun Feb 02, 2014 9:34 pm
ryantcarter wrote:Hi Guys,

managed to sort all of the errors in the config file by reading flexgets upgrade actions log - http://flexget.com/wiki/UpgradeActions

I'm only wanting to configure the movies section as I use showrss' filtering to do all of the legwork for my TV shows.

I'm a little confused as to how it works though, I've stripped down the config file so it only searches a kat proxy (I find it hard to find TPB feeds here in the UK) I've got it so it queues my movies up but when it starts searching it seems to search random torrents and tries to match them. This can't be right can it?

Can anyone see what's wrong here?
http://pastebin.com/FYxepqsk

Config - http://pastebin.com/nH6HpaUf


hello,
for your last part I had the same problem. I thought that it came because we use a rss feed for e.g. kickass torrents.
url: http://kickass.pw/highres-movies/?rss=1
and if you go to that url you only see and find the first 25 or so "random" movies. then flexget tries to connect them with your movie que.
now i only use the last one.
torrentz: verified
then it seems as it it really searches for that entry on the particular site.

I'm not an expert, only a little experice, so maybe somone has a better solution.

greetz
CT54
Posts: 21
Joined: Fri Jan 03, 2014 7:10 pm