my pi stopped working


5 posts
by BA5H » Sat May 04, 2013 9:01 pm
i tried to turn on a relay using gpio den i turned it off and wont turn back on
help me pls urgent
my power cable has a light but once i plug the pi in it turns off
i tried a diff power cable but still it doesent work
thks BA5H
User avatar
Posts: 6
Joined: Sat Feb 02, 2013 11:22 am
by mahjongg » Sat May 04, 2013 10:02 pm
you may have managed to damage the files on the SD-card, try re-flashing it.

Also, you can never directly drive a relay with a GPIO pin, for two reasons:
  • the relay needs much more energy than the GPIO pin can deliver
  • A relay is a coil, which when interrupting the current though it will generate dangerously high voltages, which may destroy whatever is blocking the current (in this case the GPIO), unless you mount a diode (backwards) across the coil, so that the voltage is shorted out.
so if you really did attempt to drive a relay directly with a GPIO pin, you may have damaged it.
If so, just pray that its only a damaged SD-card content.
User avatar
Forum Moderator
Forum Moderator
Posts: 5879
Joined: Sun Mar 11, 2012 12:19 am
by abishur » Sun May 05, 2013 1:08 am
What mahjongg said is 100% correct, though there are boards that had the built in protection to let you "control" the relay from the GPIO. The better of these boards use an opto-isolator to keep the 3v3 of the GPIO completely protected from even the slightly higher voltage used to drive the relay. The more basic of these models use a simple transistor as protection. If you were using one of these rather than a bare relay by itself, it's probable your SD card just got messed up somehow like Mahjongg said, it's a good place to start troubleshooting.
Dear forum: Play nice ;-)
User avatar
Forum Moderator
Forum Moderator
Posts: 4313
Joined: Thu Jul 28, 2011 4:10 am
Location: USA
by BA5H » Sun May 05, 2013 9:01 am
i reflashed my sd card and it still doesent work the plug has light on it when i plug the micro usb into the pi the light goes off
i tried diff plugs but it stil dont work
User avatar
Posts: 6
Joined: Sat Feb 02, 2013 11:22 am
by mahjongg » Sun May 05, 2013 11:39 am
Especially the fact that the indicator light on your power supply turns off indicates that your PI is somehow shorting/overloading the power.

two possibilities

Your power supply is broken

or

your PI is broken.

But if you tried other power supplies with the same result, I'm afraid your PI is definitely broken!
User avatar
Forum Moderator
Forum Moderator
Posts: 5879
Joined: Sun Mar 11, 2012 12:19 am