Ethernet Port is shuting down


7 posts
by kmh42 » Thu Apr 11, 2013 1:06 pm
Hello!

I used my raspberrypi as an ownclud server (reasbian) in my home network. It function well at home and I administrate it over SSH. Today I brought it into my work office and connect it to a Cisco Switch 3560CG on an 1Gbit PoE Port. Since then the Ethernet port is flapping. The link is going up and down and I can't see any MAC address coming from the raspberrypi. I have no Monitior to connect it with at work. What could have possible happened to it?
Posts: 7
Joined: Fri Mar 29, 2013 4:26 pm
by DeeJay » Thu Apr 11, 2013 4:08 pm
Is the Gigabit port on the cisco switch at work configured to auto-negotiate down to 10/100? (Pretty sure the Pi doesn't have 1Gb support.)

Do the network policies for your work network allow and support the connection of 'Bring Your Own Device'?
How To Ask Questions The Smart Way: http://www.catb.org/~esr/faqs/smart-questions.html
How to Report Bugs Effectively: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html
User avatar
Posts: 2033
Joined: Tue Jan 01, 2013 9:33 pm
Location: East Midlands, UK
by kmh42 » Thu Apr 11, 2013 4:44 pm
Yes my company support bring your own device. I am network technician and i configured the Switch to just use 10 /100. I also turn off PoE but still nothing works.
Now I am at home and the raspberrypi works fine on the LAN. I will try it again tomorrow.
Posts: 7
Joined: Fri Mar 29, 2013 4:26 pm
by DeeJay » Thu Apr 11, 2013 9:19 pm
For most enquiries like this I would say "talk to your network support people." But that doesn't work here, because you ARE the network support person. :)

After speed negotiation has been ruled out, what about crossover on the cable? I think the Pi has auto crossover detection. I've forgotten what the rules are about having auto mdix detection at both ends of the link - might they get confused? If you haven't already, perhaps try setting NO MDIX AUTO on the switch port to see if that helps them negotiate?
How To Ask Questions The Smart Way: http://www.catb.org/~esr/faqs/smart-questions.html
How to Report Bugs Effectively: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html
User avatar
Posts: 2033
Joined: Tue Jan 01, 2013 9:33 pm
Location: East Midlands, UK
by Jim JKla » Thu Apr 11, 2013 9:24 pm
The RPi has auto crossover detect.
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 2184
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by TheQuestor » Fri Apr 12, 2013 3:05 am
I was having major issues with the eth0 port stop working after about 1/2 an hour after bootup. I had a powered usb hub connected to it and my keyboard/mouse/camera and a 4 gig usb stick plugged in. I swapped out the hub for a different hub and my nic is rock solid stable now. Seems something is really touchy on the usb nic and the usb ports.
Posts: 69
Joined: Wed Nov 28, 2012 9:15 am
by kmh42 » Fri Apr 12, 2013 6:17 am
I found the solution. It has nothing to do with the network. The problem is the micro USB charger. I don't know why but apparently its too weak. It is a Samsung 5V 700mA charger.
At home I am using a Samsung 5V 1000mA charger and a HTC 5V 700mA and its working great. When I connect it to a micro usb cable on the PC it is working great. Very strange.
Posts: 7
Joined: Fri Mar 29, 2013 4:26 pm