Problema PiMAME y Chameleon, no arranca


22 posts
by vanraidex » Sat Mar 16, 2013 9:11 am
Hola,

Hace una semana me llegó mi Raspberry Pi, pero hasta hoy no había podido tocarla. Primero le he metido Raspbian y ha funcionado perfecto, he estado trasteando un poco, no mucho ya que no soy experto e iba perfecto. Después me he puesto a instalar Raspberry Pi Chameleon y al arracar la raspberry se queda la luz roja y ni se encienden las luces de red ni recibe señal el hdmi. He probado también con PiMAME y me pasa lo mismo. Le pongo otra vez Raspbian y funciona perfecto.

¿A alguién le ha pasado esto?

Saludos y gracias.

Edito: Por si sirve de algo, uso una tarjeta de 16 gb clase 10.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by AsCrNet » Thu Mar 21, 2013 1:53 pm
Siempre paso eso cuando te queda mal grabada la imagen de la aplicacion en la SD.

Saludos
Posts: 5
Joined: Fri Feb 08, 2013 2:43 pm
by vanraidex » Thu Mar 21, 2013 2:40 pm
AsCrNet wrote:Siempre paso eso cuando te queda mal grabada la imagen de la aplicacion en la SD.

Saludos


Ok, gracias por la respuesta, pues probaré de nuevo, pero es raro, lo he grabado 2 veces cada uno y las dos veces no funcionó ninguno de los dos, en cambio raspbian a la primera y retropie a la primera también.

Saludos.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by AsCrNet » Thu Mar 21, 2013 3:03 pm
No estaran malas las imagenes que bajaste de internet? :roll:

Saludos
Posts: 5
Joined: Fri Feb 08, 2013 2:43 pm
by vanraidex » Thu Mar 21, 2013 3:13 pm
AsCrNet wrote:No estaran malas las imagenes que bajaste de internet? :roll:

Saludos


Pues ya me haces dudar, pero si recuerdo que de PiMame me baje dos versiones y las dos no funcionaban. Todo me lo baje de los enlaces de la fuente original. De todas formas hasta el fin de semana no voy a poder probar nada, así que este fin de semana descargaré otra vez las imágenes y te cuento, a ver si era eso.

Saludos y gracias.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by ulysess » Sat Mar 23, 2013 3:19 am
Creo que si tu Raspberry Pi es nueva, sólo vas a poder utilizar una versión actualizada de Raspbian debido a la nueva memoria que traen, y que la hace incompatible con otras distribuciones hasta que se actualicen.
Mis apuntes de...Raspberry Pi: http://misapuntesde.com
Google Docs RPi: http://goo.gl/Iwhbq
Posts: 217
Joined: Thu Aug 02, 2012 6:35 am
Location: Spain
by vanraidex » Sat Mar 23, 2013 7:17 am
ulysess wrote:Creo que si tu Raspberry Pi es nueva, sólo vas a poder utilizar una versión actualizada de Raspbian debido a la nueva memoria que traen, y que la hace incompatible con otras distribuciones hasta que se actualicen.


Ok, si, es completamente nueva, apenas tiene 2 semanas. Esto ya me cuadra más, aunque es la primera vez que veo eso. De todas formas volveré a intentar instalar las otra versiones, no fuera que la imagen estuviera mal.

De momento solo conozco, pimame, chamaleon pi y retropie, me recomendáis algún otro?

Saludos y gracias.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by ulysess » Sat Mar 23, 2013 11:31 am
vanraidex wrote:
ulysess wrote:
De momento solo conozco, pimame, chamaleon pi y retropie, me recomendáis algún otro?

Saludos y gracias.


Uff, tienes muchos. En mi documento de google docs hay una sección de distribuciones. Tienes para aburrirte.

Para cualquier duda, me puedes consultar lo que quieras ;)
Mis apuntes de...Raspberry Pi: http://misapuntesde.com
Google Docs RPi: http://goo.gl/Iwhbq
Posts: 217
Joined: Thu Aug 02, 2012 6:35 am
Location: Spain
by vanraidex » Sat Mar 23, 2013 11:51 am
ulysess wrote:Uff, tienes muchos. En mi documento de google docs hay una sección de distribuciones. Tienes para aburrirte.

Para cualquier duda, me puedes consultar lo que quieras ;)


Ok, si, ese documento lo encontre buscando en google, lo que pasa que es gigante y no lo he visto todo todavía :D Buena recopilación.

He visto que te interesa mucho el tema de la Raspberry Pi y que eres programador, ¿tu sabrías modificar RetroArch para realizar tu propio emulador, al estilo de ChameleonPI, por ejemplo?

He estado leyendo por encima tú guía de RetroPie y me han surgido algunas dudas:

- Yo probé el Doom y no arrancaba, solo pantallazo negro y volvía al menú.¿A ti te funcionó a la primera?
- Sobre el mando, no pude hacerlo funcionar en los juegos, pero según veo me faltaba ejecutar un comando. Lo probaré, gracias.

Esta tarde la leo más detenidamente.

Un saludo y gracias.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by ulysess » Sat Mar 23, 2013 5:52 pm
vanraidex wrote:He visto que te interesa mucho el tema de la Raspberry Pi y que eres programador, ¿tu sabrías modificar RetroArch para realizar tu propio emulador, al estilo de ChameleonPI, por ejemplo?


Bueno, no hace falta tener muchos conocimientos para ello. Al fin y al cabo todos son front-ends para emuladores que ya están programados, aunque no estaría mal que en vez de usar la distro completa, usaran una más ligera sólo con lo necesario para ejecutar los emuladores y así agilizar los tiempos de arranque

vanraidex wrote:He estado leyendo por encima tú guía de RetroPie y me han surgido algunas dudas:

- Yo probé el Doom y no arrancaba, solo pantallazo negro y volvía al menú.¿A ti te funcionó a la primera?


:idea: El fichero .wad que viene en el directorio de Doom no funciona. Busca un doom.wad en internet, creo que también soporta doom2.wad, heretic.wad y Hexen
Mis apuntes de...Raspberry Pi: http://misapuntesde.com
Google Docs RPi: http://goo.gl/Iwhbq
Posts: 217
Joined: Thu Aug 02, 2012 6:35 am
Location: Spain
by vanraidex » Sat Mar 23, 2013 7:04 pm
ulysess wrote:Bueno, no hace falta tener muchos conocimientos para ello. Al fin y al cabo todos son front-ends para emuladores que ya están programados, aunque no estaría mal que en vez de usar la distro completa, usaran una más ligera sólo con lo necesario para ejecutar los emuladores y así agilizar los tiempos de arranque


Am, pensaba que llevaban algo más. Todo el tema de emuladores y de compatibilidad del pad va con RetroArch, entonces RtroPie, chamaleon pi, etc.. sólo son un conjunto de frontend?

Yo es que estoy haciendo un proyecto personal y me gustaría poder realizar mi propia versión, si no es muy difícil, claro. Aunque creo que se va de mis conocimientos, pero investigare un poco.

ulysess wrote: :idea: El fichero .wad que viene en el directorio de Doom no funciona. Busca un doom.wad en internet, creo que también soporta doom2.wad, heretic.wad y Hexen


Ya he probado el mando y funciona perfecto. Pues mañana busco un doom que funcione y también probare algún juego de psx a ver como corre.

Bueno, mañana te cuento, cuando pruebe el mítico doom. Gracias de nuevo por tu ayuda.

Saludos.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by vanraidex » Sat Mar 30, 2013 10:12 am
ulysess wrote: :idea: El fichero .wad que viene en el directorio de Doom no funciona. Busca un doom.wad en internet, creo que también soporta doom2.wad, heretic.wad y Hexen


Hola,

Por fin he podido volver a dedicarle tiempo a la rasp. He probado un montón de Doom y no he conseguido que funcione ninguno, ¿hay que hacerlo de alguna forma especial?

Con el emulador de PSX me ha pasado lo mismo, ¿hay alguna lista de juegos compatibles? A ver si estoy probando todos los que no funcionan.

Saludos.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by ulysess » Sat Mar 30, 2013 6:28 pm
vanraidex wrote:
He probado un montón de Doom y no he conseguido que funcione ninguno, ¿hay que hacerlo de alguna forma especial?

Con el emulador de PSX me ha pasado lo mismo, ¿hay alguna lista de juegos compatibles? A ver si estoy probando todos los que no funcionan.


Sobre el Doom, tal vez hayas borrado el fichero prboom.wad que venía, el cual es necesario para que funcionen los demás. A mi me van todos, menos Heretic y Hexen, aunque según la web del proyecto prboom deberían funcionar.

Sobre la psx, pasa de .img y .7z. Todos en .bin y mete en el fichero de configuración que te coja este formato (en mi guía tienes más ayuda) ;)

¡Suerte!
Mis apuntes de...Raspberry Pi: http://misapuntesde.com
Google Docs RPi: http://goo.gl/Iwhbq
Posts: 217
Joined: Thu Aug 02, 2012 6:35 am
Location: Spain
by vanraidex » Sun Mar 31, 2013 8:57 am
ulysess wrote:Sobre el Doom, tal vez hayas borrado el fichero prboom.wad que venía, el cual es necesario para que funcionen los demás. A mi me van todos, menos Heretic y Hexen, aunque según la web del proyecto prboom deberían funcionar.

Sobre la psx, pasa de .img y .7z. Todos en .bin y mete en el fichero de configuración que te coja este formato (en mi guía tienes más ayuda) ;)

¡Suerte!


Ok, pues sí, borre el prboom :D, lo volveré a meter y lo pruebo. Cada vez que leo tú guía descubro cosas nuevas, ¿o la vas a actualizando o yo no sé leer? XD

Lo probaré a ver que tal. Mil gracias de nuevo.

Saludos.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by ulysess » Thu Apr 04, 2013 11:24 am
vanraidex wrote:
Ok, pues sí, borre el prboom :D, lo volveré a meter y lo pruebo. Cada vez que leo tú guía descubro cosas nuevas, ¿o la vas a actualizando o yo no sé leer? XD

Lo probaré a ver que tal. Mil gracias de nuevo.

Saludos.


Pues he ido actualizando algunas cosas, pero ya está finiquitada. Ahora estoy con algo para la web que os va a gustar. Estad atentos...
Mis apuntes de...Raspberry Pi: http://misapuntesde.com
Google Docs RPi: http://goo.gl/Iwhbq
Posts: 217
Joined: Thu Aug 02, 2012 6:35 am
Location: Spain
by vanraidex » Thu Apr 04, 2013 1:18 pm
ulysess wrote:Pues he ido actualizando algunas cosas, pero ya está finiquitada. Ahora estoy con algo para la web que os va a gustar. Estad atentos...


Ok, a ver si puedo este finde que tengo el tiempo muy escaso. Estaré atento a la web a ver que sacas :D

Saludos.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by Nandove » Thu Apr 04, 2013 1:28 pm
Pues yo ando igual, he comprado un par de RPi hace menos de 15 dias, y si bien he podido instalar el XBMC de Openelec, no he podido arrancar ni el pimame ni el Chameleon, a pesar de haber grabado la imagen 3 veces en cada uno :(

¿hay algo que se pueda hacer?, ¿tal vez modificar algo en la imagen?, ¿las nuevas que están saliendo son incompatibles con las anteriores?

Gracias por adelantado.
Posts: 1
Joined: Thu Apr 04, 2013 12:20 pm
by vanraidex » Fri Apr 05, 2013 5:26 am
Nandove wrote:Pues yo ando igual, he comprado un par de RPi hace menos de 15 dias, y si bien he podido instalar el XBMC de Openelec, no he podido arrancar ni el pimame ni el Chameleon, a pesar de haber grabado la imagen 3 veces en cada uno :(

¿hay algo que se pueda hacer?, ¿tal vez modificar algo en la imagen?, ¿las nuevas que están saliendo son incompatibles con las anteriores?

Gracias por adelantado.


Yo he desistido de pimame y de chamaleon, no he conseguido arrancar ninguno de los dos. Instalate RetroPie que tienen una imagen ya creada y es muy fácil. Yo tengo configurado mi mando y todo. Mírate la guía del compañero ulysess que esta muy bien.

Hace unos días sacaron una nueva versión de chamaleon, pero no la he probado, quizás esa si funcione.

Saludos.
Posts: 10
Joined: Sat Mar 16, 2013 9:08 am
by radioelf » Sat Apr 06, 2013 5:55 pm
Hola, yo use la imagen de pimame 0.6 Beta3 http://blog.sheasilverman.com/pimame-raspberry-pi-os-download/ y sin problemas, además por si os interesa realicé un emulador usb para 12 teclas http://radioelf.blogspot.com.es/2013/04/emulador-teclado-usb-hid-para-mame.html
Posts: 49
Joined: Mon Sep 03, 2012 1:14 pm
Location: España
by ulysess » Mon Apr 08, 2013 6:35 pm
radioelf wrote:Hola, yo use la imagen de pimame 0.6 Beta3 http://blog.sheasilverman.com/pimame-raspberry-pi-os-download/ y sin problemas, además por si os interesa realicé un emulador usb para 12 teclas http://radioelf.blogspot.com.es/2013/04/emulador-teclado-usb-hid-para-mame.html


Gran trabajo, pero.. ¿Qué se supone que conectamos a esa placa? No lo entiendo, supongo que joysticks y botones, no?
Mis apuntes de...Raspberry Pi: http://misapuntesde.com
Google Docs RPi: http://goo.gl/Iwhbq
Posts: 217
Joined: Thu Aug 02, 2012 6:35 am
Location: Spain
by radioelf » Tue Apr 09, 2013 10:01 am
Hola, se conectan pulsadores, emula a un teclado, (solo 12 teclas).
Posts: 49
Joined: Mon Sep 03, 2012 1:14 pm
Location: España
by MiguelAR » Sun Apr 28, 2013 2:57 pm
Hola, a todos:

Me pillé recientemente la Raspberry y efectivamente, ninguna de las versiones de "Chameleon" arranca.

Después de unos cuantos intentos infructuosos con todas las versiones y con diferentes memorias, me decidí a investigar un poco por internet, llegando a este foro.

En él se insinúa que es un problema que aqueja solo a los modelos recientes de la PI, por lo que se me ocurrió que ya que que es un problema de arranque y que el debian W. funciona bien y que Chameleon deriva de esta, a lo mejor sustituyendo los ficheros de arranque de la instalación por los de la distro wheezy funcionaría y...

...En la 0.3.1 casi (se ve el logo e intenta seguir..)... pero no...
.. En la 0.3.0...tampoco ....
...Pero en la 0.2.1 Siiiii!!! Exito!!. Funciona bien.

Para quien quiera disfrutarlo y tenga una Pi nueva.

Salud.
Posts: 1
Joined: Sun Apr 28, 2013 2:40 pm