Task manager not showing %CPU utilisation


12 posts
by DevonPaul » Sun Feb 24, 2013 10:28 pm
I had noticed that the CPU Usage Monitor applet was showing 100% for some time. I wanted to see what was actively using the CPU so I fired up the Task Manager. Every process was showing -1%. I enabled viewing of all available tasks and sorted ascending and descending. All show -1%

I had recently done both #apt-get update as will as #apt-get upgrade.

Is there a fix for this?
User avatar
Posts: 26
Joined: Mon Jan 28, 2013 7:12 pm
by Cloudcentric » Sun Feb 24, 2013 10:47 pm
Presuming you are using Debian "wheezy" then drop down to command line and:

sudo su
apt-get update
apt-get dist-upgrade
sync
reboot
I know everything about nothing"
Posts: 982
Joined: Fri Sep 14, 2012 9:13 am
by DevonPaul » Sun Feb 24, 2013 11:29 pm
I ran each of those but it still shows -1% CPU for all.
User avatar
Posts: 26
Joined: Mon Jan 28, 2013 7:12 pm
by Sleep Mode zZ » Mon Feb 25, 2013 12:07 am
DevonPaul wrote:I had noticed that the CPU Usage Monitor applet was showing 100% for some time. I wanted to see what was actively using the CPU so I fired up the Task Manager. Every process was showing -1%. I enabled viewing of all available tasks and sorted ascending and descending. All show -1%

I had recently done both #apt-get update as will as #apt-get upgrade.

Is there a fix for this?


I don't know if it is relevant to your issue, but your CPU Usage Monitor applet might be showing IO Wait times. The cpu is not actually doing anything but there is processes reading from the SD card. On my desktop computer I would notice the hard drive activity but on the Pi there is no indication that the "100% CPU usage" is actually processes waiting to get something from the SD card. It would be better to have a CPU monitor applet that can make the distinction between real CPU usage and IO wait.

In short: Most of the time when the CPU usage monitor on on LXPanel is showing 100% usage, it's actually just showing that the SD card is busy!
Posts: 176
Joined: Sun Aug 19, 2012 5:56 am
Location: Finland
by DevonPaul » Mon Feb 25, 2013 12:07 pm
Sleep Mode zZ wrote:I don't know if it is relevant to your issue, but your CPU Usage Monitor applet might be showing IO Wait times. The cpu is not actually doing anything but there is processes reading from the SD card. On my desktop computer I would notice the hard drive activity but on the Pi there is no indication that the "100% CPU usage" is actually processes waiting to get something from the SD card. It would be better to have a CPU monitor applet that can make the distinction between real CPU usage and IO wait.

In short: Most of the time when the CPU usage monitor on on LXPanel is showing 100% usage, it's actually just showing that the SD card is busy!
That may be true but it does not explain the -1% for every process in the Task Manager.
User avatar
Posts: 26
Joined: Mon Jan 28, 2013 7:12 pm
by paul42 » Mon Feb 25, 2013 12:23 pm
I°m sure it's a bug. Open a terminal window & type "top" without the quotes.
Posts: 22
Joined: Mon Nov 26, 2012 5:38 pm
by DevonPaul » Mon Feb 25, 2013 12:50 pm
paul42 wrote:I°m sure it's a bug. Open a terminal window & type "top" without the quotes.
That shows expected output. Task Manager borked but can it be fixed?

I accept that top in a terminal is a working temporary solution but would like to have a working Task Manager as the columns can be sorted. Example - easily find maximum memory utilising process.
User avatar
Posts: 26
Joined: Mon Jan 28, 2013 7:12 pm
by Sleep Mode zZ » Mon Feb 25, 2013 1:36 pm
DevonPaul wrote:
paul42 wrote:I°m sure it's a bug. Open a terminal window & type "top" without the quotes.
That shows expected output. Task Manager borked but can it be fixed?

I accept that top in a terminal is a working temporary solution but would like to have a working Task Manager as the columns can be sorted. Example - easily find maximum memory utilising process.


You could try htop. It's nicer than top and allows sorting by column.
Posts: 176
Joined: Sun Aug 19, 2012 5:56 am
Location: Finland
by DevonPaul » Mon Feb 25, 2013 3:14 pm
Sleep Mode zZ wrote:You could try htop. It's nicer than top and allows sorting by column.
Code: Select all
root@raspberrypi:/home/pi# htop
bash: htop: command not found
root@raspberrypi:/home/pi# find / -name 'htop'
/usr/share/bash-completion/completions/htop
root@raspberrypi:/home/pi# cd /usr/share/bash-completion/completions
root@raspberrypi:/usr/share/bash-completion/completions# ./htop
bash: ./htop: Permission denied
root@raspberrypi:/usr/share/bash-completion/completions# chmod +x htop
root@raspberrypi:/usr/share/bash-completion/completions# ./htop
root@raspberrypi:/usr/share/bash-completion/completions#
root@raspberrypi:/usr/share/bash-completion/completions#
After all that, nothing?
User avatar
Posts: 26
Joined: Mon Jan 28, 2013 7:12 pm
by Sleep Mode zZ » Mon Feb 25, 2013 3:34 pm
DevonPaul wrote:
Sleep Mode zZ wrote:You could try htop. It's nicer than top and allows sorting by column.
Code: Select all
root@raspberrypi:/home/pi# htop
bash: htop: command not found
root@raspberrypi:/home/pi# find / -name 'htop'
/usr/share/bash-completion/completions/htop
root@raspberrypi:/home/pi# cd /usr/share/bash-completion/completions
root@raspberrypi:/usr/share/bash-completion/completions# ./htop
bash: ./htop: Permission denied
root@raspberrypi:/usr/share/bash-completion/completions# chmod +x htop
root@raspberrypi:/usr/share/bash-completion/completions# ./htop
root@raspberrypi:/usr/share/bash-completion/completions#
root@raspberrypi:/usr/share/bash-completion/completions#
After all that, nothing?

Install it first?
Code: Select all
sudo apt-get install htop
Posts: 176
Joined: Sun Aug 19, 2012 5:56 am
Location: Finland
by DevonPaul » Mon Feb 25, 2013 9:50 pm
Sleep Mode zZ wrote:Install it first?
JEEES! You mean that even though I eventualy found an htop file it was never installed?

Well it works. Nowhere near as easy on the eye as Task manager but better than nothing.

How can I add a short-cut to the System Tools menu so I can more easily use this? I am not too familiar with *nix type systems.

edit/ Tee Hee - should have checked first as the apt-get already did that /edit

Still would like to fix Task manager as it is nicer to look at. Any clues?
User avatar
Posts: 26
Joined: Mon Jan 28, 2013 7:12 pm
by Sleep Mode zZ » Mon Feb 25, 2013 10:50 pm
DevonPaul wrote:
Sleep Mode zZ wrote:Install it first?
JEEES! You mean that even though I eventualy found an htop file it was never installed?

Well it works. Nowhere near as easy on the eye as Task manager but better than nothing.

How can I add a short-cut to the System Tools menu so I can more easily use this? I am not too familiar with *nix type systems.

edit/ Tee Hee - should have checked first as the apt-get already did that /edit

Still would like to fix Task manager as it is nicer to look at. Any clues?


I confirmed that I also had the -1% -issue. No clues how to fix it. It seems to be a bug in LXTask.

LXTask is nicer to the eyes but htop is more configurable: It's possible to choose what information to display in the columns and in what order. There is even 5 extra color schemes to choose from. :D

One hint: Change the settings in LXTerminal so that it will not use the F10 key. If it does, you will be unable to to use the F10 key in htop and It is needed for saving the settings and quitting.
Posts: 176
Joined: Sun Aug 19, 2012 5:56 am
Location: Finland