No sound through USB speakers


6 posts
by Mcbeaver » Fri Feb 08, 2013 1:46 pm
Hi there.

I've run into a problem with my sound on the raspberry.
I picked up a pair of Edifier R600USB speakers today and thought i'd give them a go.

The problem though is that I can't seem to get any sound through these.

The speakers are powered from a powered usb hub so I think the power should be alright.

I believe i have messed up some settings which would make them work (most likely in /etc/asound.conf)

Here are 4 images of how it looks.
http://imgur.com/r4EDBAW,vQWhpaL,2rzJmYo,NUrajHI#0

It seems like the raspberry finds the speakers but are unable to process sound through them because of hwparams?

Any help would be appreciated.
Posts: 2
Joined: Fri Feb 08, 2013 1:35 pm
by redhawk » Fri Feb 08, 2013 2:50 pm
Does aplay -l show your device as listed??

You cannot simply plug in a USB audio device an expect it to play the music app needs to be configured to access it.

What program are you using for playing audio??

Richard S.
User avatar
Posts: 3328
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1
by Mcbeaver » Fri Feb 08, 2013 2:55 pm
Yes, as shown in one of the pictures, aplay -l listed the speakers correctly.

I managed to solve the problem myself though through some testing, apparently everything was set up correctly and it scared the hell out of me when sound came out when i tried "speaker-test -c2" (went through the list of -c0-> in desperation).
I had only tried the wrong outputs (which looked right i thought).

Got sound through squeezeslave when I selected the "sysdefault" option somewhere in the middle of options instead of "USB Audio Device: USB Audio" or default.
Posts: 2
Joined: Fri Feb 08, 2013 1:35 pm
by blacknoise » Wed Feb 20, 2013 10:38 am
Thanks for the great input! I'm trying to get the R600 working with mpd.
The speaker-test went just fine with the -c2 flag, but I don't know which settings to use in mpd.conf.
Aplay also doesn't work. Any ideas?
Posts: 2
Joined: Wed Feb 20, 2013 10:17 am
by ski522 » Wed Feb 20, 2013 12:32 pm
blacknoise wrote:Thanks for the great input! I'm trying to get the R600 working with mpd.
The speaker-test went just fine with the -c2 flag, but I don't know which settings to use in mpd.conf.
Aplay also doesn't work. Any ideas?


Have you configured MPD to work with alsa? "sudo nano /etc/mpd.conf" and make sure you have the following:
Code: Select all
audio_output {
        type            "alsa"
        name            "My ALSA Device"
        device          "hw:0,0"        # optional
        format          "44100:16:2"    # optional
        mixer_device    "default"       # optional
        mixer_control   "PCM"           # optional
        mixer_index     "0"             # optional
}
Posts: 394
Joined: Sun Sep 30, 2012 2:22 pm
by blacknoise » Thu Feb 21, 2013 10:20 am
Hi ski522,

thanks for the reply, my config looks just like that.
After another hour of trial and error I finally found the cause. Kind of awkward, but the mpd playlist was empty. :roll:
I had to add the files from the music folder first...

Initially the sound was very distorted, but after switching to USB 1.1 I'm happy with the result.

Greetings
blacknoise
Posts: 2
Joined: Wed Feb 20, 2013 10:17 am