wifi dongle and bluetooth


5 posts
by bluetape66 » Mon Feb 04, 2013 10:52 pm
I have just recently received my RPi and was trying to connect my wifi dongle (asus usb-n10) and USB Bluetooth (iogear GBU521) and my first problem is, when it boots it goes strait to the desktop. i also don't know have to install drivers etc i am at a very basic level and need all the help i can get. :D
Don't Cry because it's over, smile because it happend. :D
Posts: 41
Joined: Thu Jan 24, 2013 1:59 pm
Location: EARHT
by Cloudcentric » Mon Feb 04, 2013 11:18 pm
What Operating System have you installed Raspbian "Wheezy" ?

USB Peripherals are recommended to be plugged into a USB Mains Powered Hub

Linux does not use drivers par-se, and many peripherals are recognised out-of-the-box.
I know everything about nothing"
Posts: 982
Joined: Fri Sep 14, 2012 9:13 am
by bluetape66 » Mon Feb 04, 2013 11:43 pm
Cloudcentric wrote:What Operating System have you installed Raspbian "Wheezy" ?

USB Peripherals are recommended to be plugged into a USB Mains Powered Hub

Linux does not use drivers par-se, and many peripherals are recognised out-of-the-box.


I am using both Wheezy and a powered hub, but my questions were what next? I have no knowledge at all of Linux or Linux based os
Don't Cry because it's over, smile because it happend. :D
Posts: 41
Joined: Thu Jan 24, 2013 1:59 pm
Location: EARHT
by Mobius » Tue Feb 05, 2013 1:48 am
You should not be going directly to the Desktop unless you enabled that when you first booted the SD card and it ran the configuration setup. To get back to configuration and turn that off, exit the Desktop and do a "sudo raspi-config" at the command line. Not sure about setting up Bluetooth but the wifi can be set up from the Desktop using the wifi configuration program there. At least that is what everyone says. I have always set mine up manually by editing file /etc/network/interfaces (the editing command is "sudo nano xxx" where "xxx" is the path and filename).
Posts: 238
Joined: Thu Aug 30, 2012 1:07 am
Location: San Angelo, Texas USA
by Cloudcentric » Tue Feb 05, 2013 9:19 am
As above stated logout and run raspi-config but after that you may need to upgrade you Raspbian Wheezy, it is best to boot to command line and get used to working outside GUI to learn more....

http://www.raspberrypi.org/archives/2008

If you have changed the configuration to boot to command line after logging in type startx and press the enter key to launch the LXDE Desktop GUI


WiFi should have a WIF_Config desktop icon and Bluetooth needs the bluez-utilities installed.


You need to be at the command line to type the following, followed by pressing the Enter key and following prompts:

sudo su
apt-get update
apt-get dist-upgrade
sync
reboot

After rebooting after logging in and at the command line type the following, followed by pressing the Enter key and following prompts:

sudo su
apt-get install bluez
apt-get install bluez-utils
apt-get install blueman
login

Login will ask for the login / pass then can type startx

http://debianarmpi.blogspot.co.uk
I know everything about nothing"
Posts: 982
Joined: Fri Sep 14, 2012 9:13 am