SSH now working Raspberry Pi


7 posts
by GE0N0VA » Mon Feb 04, 2013 4:28 pm
I want to SSH into my raspberry pi from other computers that are now on my network before you say that i should use Port forwarding i already did that and i know that it is done properly i forwarded port 22 i know it's done properly because i have mumble server running on Pi and port for that is working fine my only question is is there anything else that could be wrong for example some setting in pi or something
Posts: 11
Joined: Wed Jan 16, 2013 2:16 pm
by RaTTuS » Mon Feb 04, 2013 4:54 pm
as long as you have changed the password for user pi you're fine
1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX - Prosliver FTW
"That's not right, the badgers have moved the goalposts."
User avatar
Posts: 5233
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
by GE0N0VA » Mon Feb 04, 2013 5:01 pm
RaTTuS wrote:as long as you have changed the password for user pi you're fine
i mistyped it is not working so what should i do
Posts: 11
Joined: Wed Jan 16, 2013 2:16 pm
by DBryant » Mon Feb 04, 2013 5:22 pm
Your network is an intranet i.e every is in a 192.168.xxx.yyy sub-net? You do say 'my network' to make me think this.

Port forwarding is not required, you'd only want that is your were coming form the internet through your router into your local network.

Have you every had ssh working? Pi side of things is configures by the file /etc/xinit.d/ssh - in there there is a line that states whether its enabled or not. Does it looks ok.

Undo the port changes and verify that ssh between your local boxes is functioning.

Run ssh with the -v flag to increase verbosity of connection process. You can -v -v -v to increase the level, it may help (or not).

Once you're happy, and you need the port forwarding then put it back in.
Posts: 279
Joined: Sat Feb 02, 2013 12:41 pm
Location: Berkshire, UK
by GE0N0VA » Mon Feb 04, 2013 5:58 pm
DBryant wrote:Your network is an intranet i.e every is in a 192.168.xxx.yyy sub-net? You do say 'my network' to make me think this.

Port forwarding is not required, you'd only want that is your were coming form the internet through your router into your local network.

Have you every had ssh working? Pi side of things is configures by the file /etc/xinit.d/ssh - in there there is a line that states whether its enabled or not. Does it looks ok.

Undo the port changes and verify that ssh between your local boxes is functioning.

Run ssh with the -v flag to increase verbosity of connection process. You can -v -v -v to increase the level, it may help (or not).

Once you're happy, and you need the port forwarding then put it back in.

Sorry for bad english but what i mean was that SSH is working in intranet but not from outside
Posts: 11
Joined: Wed Jan 16, 2013 2:16 pm
by GE0N0VA » Mon Feb 04, 2013 6:30 pm
Thanks i figured it out my isp is blocking port 22 so i opened port 12354 and it worked i also change that in /etc/ssh/sshd_config
Posts: 11
Joined: Wed Jan 16, 2013 2:16 pm
by tonyhughes » Mon Feb 04, 2013 7:13 pm
For others reading this thread, if you are port forwarding SSH from the internet, you should consider changing the port from 22 to something much higher.

Many scripts and automated attack systems will just focus on port 22 and other low numbers, because thats the 'low hanging fruit'.

There is anecdotal evidence (forum posts splattered around teh intarwebs) that sysadmins experience a 99% plus reduction in SSH attempts when changing the port up.

Also, you should set the disable root login setting.

Code: Select all
sudo nano /etc/ssh/sshd_config

then uncomment:
Code: Select all
PermitRootLogin no

To change the port, find this line and uncomment, and change to the port you want:
Code: Select all
#Port 22
Baked Linux Mod http://www.geek101.co.nz/bakedlinuxmod

Easy install of Drupal, Wordpress, RazorCMS, Chyrp, Apache, Nginx, Lighttpd, firewall, Webmin, VNC, RDP, FTP servers, mailservers, MySQL, SQLite, Transmission and more...

tall.co.nz/webcam.jpg
User avatar
Posts: 931
Joined: Wed Dec 26, 2012 3:46 am