Problemas com Raspberry pi


7 posts
by criostage » Mon Feb 04, 2013 12:55 pm
Bons dias a todos,

Gostaria de pedir um pouco de ajuda a solucionar um problema com o Raspberry Pi que tenho tido com o meu. O que acontece é, ligo o raspberry pi com o cabo de rede, cartão SDHC com Raspbian e a fonte de alimentação claro e apartir daqui ele arranca com o sistema operativo que está cartão, ora passados entre +- 30Min~13Horas (medi estes tempos com um programa uprecords-cgi, que gere e mostra quais os tempos mais altos de uptime) o Raspberry pi desliga-se ficando apenas com a luz de power sempre ligada. O raspberry pi volta ao normal após o desligar da corrente e voltar a ligar e aguenta-se por mais uns tempinhos assim.

Eu já tinha postado nos forums ingleses e eles disseram-me que poderia ser problemas com o adaptador de corrente. Seguindo esta pista comprei e devolvi uns quantos adaptadores de corrente ... mas infelizmente a minha situação mantem-se, Alguns adaptadores que usei ...
  • Alguns de linha branca de 5v e 1a~1.5a
  • Duracel Travel Charger 5v 1A
  • Carregador do meu telemovel Samsung Galaxy Nexus 5V 1A
  • Carregador do meu tablet ZTE V9C de 5V 1.5A

A minha pergunta é existe algum que voces utilizem e que sabem que funciona? ou esta situação pode ser derivada de outra situaçao? Agradeço alguem que me possa dar uma pequena ajuda ..

Já agora uma pequena nota, eu comprei o raspberry pi para ser o meu webserver la em casa para applicações PHP (desenvolvimento e uso), não tenho assim nada para verificar a voltagem dos carregadores ou do proprio raspberry pi quando ligado.
Posts: 7
Joined: Wed Jan 30, 2013 2:00 pm
by Montekuri » Mon Feb 04, 2013 2:27 pm
Tente usar outro cartão SD.
Aqui no Brasil eu uso um carregador de 5V e 1,5 A de marca nacional (COMTAC).
E uso cartões da marca DANE e SANDISK.
Uso o Raspberry Pi como media player e funciona durante horas sem parar.
User avatar
Posts: 420
Joined: Thu Sep 22, 2011 6:26 pm
by criostage » Mon Feb 04, 2013 2:54 pm
Montekuri wrote:Tente usar outro cartão SD.
Aqui no Brasil eu uso um carregador de 5V e 1,5 A de marca nacional (COMTAC).
E uso cartões da marca DANE e SANDISK.
Uso o Raspberry Pi como media player e funciona durante horas sem parar.


Olá Montekuri, obrigado pela sugestão mas infelizmente essa foi uma das primeiras coisas que testei porque quase todo o tipo de dispositivo (Smartphones, tablets, etc ...) usam cartões SDHC ou microSD o que torna facil trocar e ver se funciona ou não, para minha desgraça o resultado foi exactamente o mesmo.

A falha foi realmente minha porque como tenho lido muita coisa sobre problemas com a alimentação do raspberry pi, esquecime de adicionar ao post que já tinha realizado este teste. :?
Posts: 7
Joined: Wed Jan 30, 2013 2:00 pm
by pksato » Mon Feb 04, 2013 9:30 pm
Ola,
Faça um teste de memoria usando o memtester (não o memtest86 ou memtest86+).
Talvez tenha que instalar,
sudo aptitude install memtester
depois rodar especificando a quantidade de memoria a ser testada, pode colocar um valor maior, que o programa se ajusta
memtester 192M
Posts: 110
Joined: Fri Aug 03, 2012 5:25 pm
by tonyhughes » Mon Feb 04, 2013 9:35 pm
Are you overclocking your Pi? This can lead to SD card related problems. If so, turn your overclock off, and try again...
Baked Linux Mod http://www.geek101.co.nz/bakedlinuxmod

Easy install of Drupal, Wordpress, RazorCMS, Chyrp, Apache, Nginx, Lighttpd, firewall, Webmin, VNC, RDP, FTP servers, mailservers, MySQL, SQLite, Transmission and more...

tall.co.nz/webcam.jpg
User avatar
Posts: 931
Joined: Wed Dec 26, 2012 3:46 am
by criostage » Tue Feb 05, 2013 12:33 am
Olá pksato, eu tentei fazer o que me indicaste mas não sei porque o raspberry pi hoje não se aguenta 5min ligado (mesmo so com o cabo de power) com as mesmas fontes de alimentação que indiquei no primeiro post ... tou a axar isto cada vx mais estanho .... mas amanha vou tentar outra vez a ver se tenho mais sorte ... ando a procurar alguem que me possa emprestar um voltimetro.

Se não der em nada ligo para a RS Compoments a ver o que eles podem fazer..

Hey tonyhughes, no my raspberry pi isn't overclocked at the moment, i did tried on the day it arrived overclock it to 800Mhz to see if there was any big change in performance but ended up in reverting after it's first crash (it was in my hands no longer than 1 hour when i got it from the post office).
Posts: 7
Joined: Wed Jan 30, 2013 2:00 pm
by criostage » Tue Feb 05, 2013 4:24 pm
Olá a todos,

Levei o meu raspberry pi a uma pessoa (e que percebe mais de circuitos electricos que eu) na empresa onde trabalho, e após analize e comparação com a WiKi parece que o fusivel F3 (junto a entrada microUSB) está queimado, e explica os problemas que tenho vindo a ter de ele estar constantemente a ir a baixo por falta de corrente.

Levei os transformadores que use, e os 2 primeiros (o carregador do Samsung Galaxy Nexus dá 4.98v e o carregador do ZTE da 5.09v) davam mais que suficiente para o Raspberry pi funcionar normalmente. Sendo assim vou ter de entrar em contato com o pessoal da RS a ver se tenho alguma sorte .... Agradeço a todos que tentaram ajudar qualquer das maneiras
Posts: 7
Joined: Wed Jan 30, 2013 2:00 pm