HDMI/ TV out and framebuffer size. Text is not crystal clear


8 posts
by hanzelpeter » Tue Jan 22, 2013 6:46 pm
Hello.

I have a question about HDMI/TV resolution and default size of framebuffer width/height.
My setup HDMI LCD Monitor: tvservice -s = 1920x1080, fbset reports 1824x984
TV with NTSC: tvservice -s = 720x480 fbset reports 656x416.

My problem is that on HDMI LCD monitor the console text is not crystal clear.
If I use fbset -xres 1920 -yres 1080, then it get's better but still not crystal clear texts in console.

Should I play with disable_overscan and with overscan_left etc.
I did not changes the default config.txt so all this properties are commented.

How this explais the framebuffer width versus real size of display.

Thanks.
User avatar
Posts: 55
Joined: Mon Jul 09, 2012 11:56 am
by drgeoff » Tue Jan 22, 2013 8:17 pm
To get 'crystal clear' text you need to be running the display at the native resolution of the panel. So that is the first thing to ascertain.

Secondly, unlike some TVs, very few if any monitors have overscan. So ensure you have
Code: Select all
disable_overscan=1

in config.txt
Posts: 2731
Joined: Wed Jan 25, 2012 6:39 pm
by efflandt » Tue Jan 22, 2013 8:22 pm
Normally a 1080p HDTV connected with HDMI should show up like this:
Code: Select all
efflandt@raspberrypi ~ $ tvservice -s
state 0x12001a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60Hz, progressive

The only audio/video related settings I have in /boot/config.txt are disable_overscan=1, and after some rpi-update I had to uncomment hdmi_force_hotplug=1. That should fill the screen be sharp if your TV has some mode to do that, which my LG calls "Just Scan" or Samsung calls "Screen Fit".

My first Pi initially ran at a lower resolution with the Oct Raspbian image. But maybe that HDMI input was set to a different mode, because once I got it full screen, it has remained that way, whether I redid a fresh Oct Raspbian image or newer image or updates since then.

If the image on your HDTV is too small or too big, you may need to set disable_overscan=0 and play around with overscan settings. But first see if your TV has a setting to make it fit.
Posts: 359
Joined: Mon Dec 03, 2012 2:47 am
Location: Elgin, IL USA
by hanzelpeter » Wed Jan 23, 2013 5:50 pm
Hello.

I am stuck. On my LCD monitor the disable_overscan=1 makes my command line moved to left and bottom and I can't see login prompt.

Can disable_overscan=0 and overscan_left be combined?
But also with disable_overscan=1 the text console is not "crystal" clear.

Any ideas?
Thanks.
User avatar
Posts: 55
Joined: Mon Jul 09, 2012 11:56 am
by -rst- » Fri Jan 25, 2013 4:20 pm
Seems that sometimes RPi does not recognise the correct monitor resolution and the monitor then stretches the image to another resolution -> resizing artifacts = blurry.

Does your monitor have a 'on screen menu/display' that would tell you what the monitor resolution is?

Can you verify the monitor native resolution (is it full HD, or something else)?

Of course there is the chance of a bad monitor - tried with any other image source?
http://raspberrycompote.blogspot.com/ - Low-level graphics and 'Coding Gold Dust'
Posts: 898
Joined: Thu Nov 01, 2012 12:12 pm
Location: Dublin, Ireland
by hanzelpeter » Fri Feb 01, 2013 2:25 pm
Hello.

There is a menu on that LCD monitor. I checked it all and it says mode is 1920x1080.
I have also tried adjusting and it say Not available. Also for Auto Mode and also for manul mode.
There is in that OSD menu a menuitem for left/top aligment but is says Not available.

The monitor is: Samsung SyncMaster 2494HM.

Any ideas?
User avatar
Posts: 55
Joined: Mon Jul 09, 2012 11:56 am
by -rst- » Fri Feb 01, 2013 2:38 pm
I have a Samsung S22B350H full HD (1920 x 1080), which works with no issues at all - I bought it (mainly) for my RPi and having taken out of the box just plugged it in. Did not touch the overscan setting on RPi, so I assume it is off. I see no reason why yours would not work just as well with the defaults.

I would take everything overscan and resolution related out of the config.txt and try again...

There seems to be some troubleshooting info for "How To Resolve For Fuzzy Or Blurry Text On Your Monitor" at http://www.samsung.com/us/support/owners/product/2494HM
http://raspberrycompote.blogspot.com/ - Low-level graphics and 'Coding Gold Dust'
Posts: 898
Joined: Thu Nov 01, 2012 12:12 pm
Location: Dublin, Ireland
by hanzelpeter » Wed Feb 06, 2013 2:21 pm
Hello all.

I have found a solution. It is all about using Menu on LCD monitor and turning off AV Mode.
See this: http://www.overclock.net/t/579884/samsu ... n-problems

So now I am very happy. I have crystal clear texts in console.
User avatar
Posts: 55
Joined: Mon Jul 09, 2012 11:56 am