NFS Rpcbind issues


5 posts
by edrose » Mon Jan 21, 2013 7:33 pm
Im experiencing issues with rpcbind on debian on my raspberry pi. I want to set it up as a NFS server, however when I connect i get a:
Code: Select all
mount_nfs: can't mount /mnt/hdd from 192.168.1.95 onto /Volumes/raspi: Connection refused
I think this is an issue with rpcbind, as there are no configuration files in the /etc/default directory, however the package is actually installed. I've tried to remove and then install it again but this does nothing.
Here is my configuration file for /etc/exports, just in case i've made any mistakes in it.
Code: Select all
# /etc/exports: the access control list for filesystems which may be exported
#               to NFS clients.  See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_sub$
#
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)
#
/mnt/hdd/macbook *(rw,sync)

If anyone could help it would be amazing. I'm trying to run backups for my raspberry pi and for my macbook on the same hard drive and this was the only way I could think of doing it. If there is another workaround then I would be grateful for anyone who can help me.

Ed
Posts: 13
Joined: Fri Dec 28, 2012 3:35 pm
by PeterO » Mon Jan 21, 2013 8:00 pm
I have this note in my "getting stuff to work" notes...

Need to do this for nfsmounts to work!:
sudo update-rc.d rpcbind enable


HTH
PeterO
User avatar
Posts: 818
Joined: Sun Jul 22, 2012 4:14 pm
by edrose » Mon Jan 21, 2013 8:34 pm
Done that, now I get a:
Code: Select all
mount_nfs: can't mount /mnt/hdd/macbook from 192.168.1.95 onto /Volumes/raspi: Permission denied

I guess i'm a bit closer?
It's probably an issue with my /etc/exports file, which is currently
Code: Select all
# /etc/exports: the access control list for filesystems which may be exported
#               to NFS clients.  See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_sub$
#
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)
#
/mnt/hdd/macbook 192.168.1.0(rw,sync,no_subtree_check)
Posts: 13
Joined: Fri Dec 28, 2012 3:35 pm
by PeterO » Mon Jan 21, 2013 8:45 pm
Make the export explicit for your PI so change
/mnt/hdd/macbook 192.168.1.0(rw,sync,no_subtree_check)
to
/mnt/hdd/macbook 192.168.1.95(rw,sync,no_subtree_check)

I think you to run "exportfs -a" to get the nfs server to reread the exports file.


PeterO
User avatar
Posts: 818
Joined: Sun Jul 22, 2012 4:14 pm
by BeJay » Tue Aug 13, 2013 12:47 pm
Thanks PeterO it was the sudo update-rc.d rpcbind enable that saved my pi going out the window ;) I have never had this issue before on other distros because it's the fist time I've used RPCbind instead of portmapper....

Cheers

Bj
Posts: 24
Joined: Mon Aug 06, 2012 1:52 pm
Location: Western Australia