xbmc-rbp-git fails to load in


4 posts
by scorpiove » Thu Jan 17, 2013 11:56 pm
Hi everyone I am using the archlinux-hf-2012-09-18 image of arch linux, and I installed xbmc-rbp-git with pacman. But when I try to run xbmc I get this error.

/usr/lib/xbmc/xbmc.bin: error while loading shared libraries:
libcdio.so.13: cannot open shared object file: No such file or
directory


Before that I was gettin this error which was fixed wtih symbolic links

/usr/lib/xbmc/xbmc.bin: error while loading shared libraries:
libGLESv2.so: cannot open shared object file: No such file or
directory


Whats also strange is I get this output after everything as well
ldconfig: File /usr/lib/libgdk-1.2.so.0.9.1 is empty, not checked.
ldconfig: File /usr/lib/libgdk.so is empty, not checked.
ldconfig: File /usr/lib/libgtk.so is empty, not checked.
ldconfig: File /usr/lib/libgtk-1.2.so.0 is empty, not checked.
ldconfig: File /usr/lib/libgtk-1.2.so.0.9.1 is empty, not checked.
ldconfig: File /usr/lib/libgdk-1.2.so.0 is empty, not checked.


I installed and removed gtk with pacman so maybe thats why im getting the last error. Any help would be greatly appreciated! :)
Posts: 2
Joined: Thu Jan 17, 2013 11:47 pm
by pepedog » Fri Jan 18, 2013 1:29 am
Archlinux arm has a little problem with glibc at the moment, bit of a bugger which I'm sure will be fixed soon
2ways of running
Code: Select all
export LD_LIBRARY_PATH=/opt/vc/lib
xbmc

Or
Code: Select all
LD_LIBRARY_PATH=/opt/vc/lib xbmc

So sorry for inconvenience, reported upstream. ld cache is being ignored
Posts: 968
Joined: Fri Oct 07, 2011 9:55 am
by scorpiove » Fri Jan 18, 2013 3:00 am
Thank you, I can't wait to get home now and try it. :)
Posts: 2
Joined: Thu Jan 17, 2013 11:47 pm
by komodo » Fri Jan 18, 2013 7:39 am
The glibc/ld cache issue is not new; it's the same for the last few weeks.

The libcdio is brand new though. Here it is upstream https://bbs.archlinux.org/viewtopic.php?pid=1218896

Long story short, it looks like libcdio was updated upstream, and xbmc-rbp-git is linked against an old (now nonexistent) libcdio.so.13 now.

Bug will probably persist until the xbmc package is rebuilt against new libraries.

Where would be best to report this?
Posts: 5
Joined: Fri Jan 18, 2013 7:33 am