Receptor ISDB-T


34 posts   Page 1 of 2   1, 2
by dead » Thu Jan 17, 2013 10:32 am
Alguém ai tem o receptor Leadership 0090 Fullseg de TV Digital?
Eu estou tentando fazer funcionar aqui porém ainda não tive sucesso, gostaria de saber se alguém já conseguiu fazer funcionar o receptor.
O linux detectou e ativou o driver certinho porém quando eu tento dar scan de canais, aparece diversas mensagens de erro no dmesg.
Procurando na internet eu não consegui achar nada que solucionasse o problema. (Não estou em casa, quando eu chegar eu coloco os erros que estão dando)
(Estou utilizando o raspbmc mais recente)
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by dead » Fri Jan 18, 2013 10:38 am
Ao que parece o driver/usb foi reconhecido com sucesso...
dvb-usb: found a 'DiBcom STK8096GP reference design' in cold state, will try to load a firmware
dvb-usb: downloading firmware from file 'dvb-usb-dib0700-1.20.fw'
dib0700: firmware started successfully.
dvb-usb: found a 'DiBcom STK8096GP reference design' in warm state.
dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
DVB: registering new adapter (DiBcom STK8096GP reference design)
DVB: registering adapter 0 frontend 0 (DiBcom 8000 ISDB-T)...
DiB0090: successfully identified
Registered IR keymap rc-dib0700-rc5
input: IR-receiver inside an USB DVB receiver as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/rc/rc0/input0
rc0: IR-receiver inside an USB DVB receiver as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/rc/rc0
dvb-usb: schedule remote query interval to 50 msecs.
dvb-usb: DiBcom STK8096GP reference design successfully initialized and connected.
usbcore: registered new interface driver dvb_usb_dib0700


Porém ao executar o ./scan ch.config
Ocorre um monte de erro "dtv_property_cache_sync: doesn't know how to handle a DVBv3 call to delivery system 0" no dmesg e ele não consegue scanear nenhum canal.

Kernel:
Linux raspbmc 3.6.11 #1 PREEMPT Sat Dec 29 00:16:57 UTC 2012 armv6l GNU/Linux
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by pksato » Fri Jan 18, 2013 9:51 pm
Ola vizinho,
Nunca consegui fazer um receptor 1seg baseado no chip siano funcionar no Linux (pc, debian, não testei em outros, como o Ubuntu).
Pelo que andei lendo, e necessário uma versão recente (após 2009) ou ainda não liberado para que o ISDB-T funcione corretamente, ou não usando no Debian.
O suporte ao hardware esta correto, mas falta a parte do software para fazer a coisa funcionar.
Veja aqui um pouco mais de detalhes.
http://linuxtv.org/wiki/index.php/ISDB-T_Devices
Nas minhas tentativas, o scan nunca detectou uma emissora (se bem que só tem um aqui).

No raspberry pi também a mesma coisa, o modulo parece ter sido carregado corretamente, mas nada de pegar a RPCTV.

Seria interessante ver se o RPi consegue decodificar o full-seg (1080i) do ISDB-T Brasileiro.
Posts: 116
Joined: Fri Aug 03, 2012 5:25 pm
by dead » Tue Jan 22, 2013 8:19 pm
Consegui contornar o problema que estava dando...
Aquele problema ocorre devido uma falta de compatibilidade, os programas antigos utilizam o DVBv3, sendo que agora no kernel está implementado para utilizar o DVBv5, eles criaram algo para permitir uma retrocompatibilidade, mas pelo jeito não está funcionando em todos os casos.

Estou seguindo o passos daqui:
http://www.tdt-latinoamerica.tv/foro/s8 ... 31-50.html

Baixei o v4l-utils e compilei, executei o dvbv5-scan.
Ele funciona corretamente até a metade, depois começa retornar que o sinal está 100% sendo que não tem nenhum canal naquela frequência e falha..

Log do dmesg:
DiB0090 I2C write failed
DiB0090 I2C read failed
DiB0090 I2C write failed
DiB0090 I2C write failed


Mas acredito que esse problema pode estar ocorrendo devido ao fato de eu não estar utilizando um hub usb com fonte e sim direto no raspberry, acredito que o receptor esteja dando problema devido a falta de energia. (estou esperando minha compra chegar XD)
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by dead » Sat Feb 02, 2013 5:30 pm
Ae pessoal, como imaginei...
O problema que estava ocorrendo por ultimo era devido a falta energia... (ao conectar o receptor direto no rasp)

Meu hub-powered chegou hoje e já testei, agora o receptor consegue sincronizar canais tranquilamente (apesar que eu ainda estou com problema por causa da minha antena)

Obrigado a todos e quem tiver dúvida de como fazer funcionar no seu raspberry é só perguntar ai!
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by gatts » Wed Feb 27, 2013 2:21 am
Olá, dead! Você é o único que encontrei a ter conseguido sintonizar um receptor usb Full Seg padrão ISDB-T no Raspberry pi!

Será q seria possível instala-lo no Raspbmc, e acessá-lo pelo AdvancedLauncher no menu do XBMC??? *_*
utilizo um decodificador digital da Semp Toshiba pra esse trabalho, e se pudesse substitui-lo com o raspberry seria muito bom.

Vc me ajudaria na configuração? não manjo muito de Linux, só o básico

Desde já, muito obrigado!!! ^_^
Posts: 1
Joined: Wed Feb 27, 2013 1:51 am
by dead » Tue Apr 09, 2013 11:29 pm
Olá gatts,
Fique a vontade de perguntar o que quiser!
abraços
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by ludoman » Sat Jun 29, 2013 7:28 pm
Salve Dead

Cara.... Tem como você me dar um help???

Eu tenho o mesmo dispositivo que você, o receptor Leadership 0090 Fullseg de TV Digital....

Estou apanhando pra caramba e não estou conseguindo instalar esse treco no Raspibmc... Não sou muito bom em linux, mas estou me esforçando muito...

Minha versão é a Linux raspbmc 3.6.11

digitando dmesg | grep dvb obtenho:
dvb_hdhomerun: module is from the staging directory, the quality is unknown, you have been warned.
dvb-usb: found a 'DiBcom STK8096GP reference design' in cold state, will try to load a firmware
dvb-usb: downloading firmware from file 'dvb-usb-dib0700-1.20.fw'
dvb-usb: found a 'DiBcom STK8096GP reference design' in warm state.
dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
dvb-usb: schedule remote query interval to 50 msecs.
dvb-usb: DiBcom STK8096GP reference design successfully initialized and connected.
usbcore: registered new interface driver dvb_usb_dib0700


Aparentemente está funfano normal.

Baixei o v4l-utils utilizando apt-get install v4l-utils e baixei o dvb-apps utilizando apt-get install dvb-apps

Seguindo os passos do link que você postou aqui (http://www.tdt-latinoamerica.tv/foro/s8 ... 31-50.html) fiz:

pi@raspbmc:~$ sudo dvb-format-convert -I CHANNEL -O DVBV5 ch.config freq.conf
Reading file ch.config
Writing file freq.conf


O arquivo ch.config é a tabela de frequências que peguei daqui: http://www.linuxtv.org/wiki/index.php/I ... ency_Table

O arquivo criado freq.conf ficou com o seguinte formato:

[CHANNEL]
DELIVERY_SYSTEM = DVBT
FREQUENCY = 803142857
BANDWIDTH_HZ = 6000000
CODE_RATE_HP = AUTO
CODE_RATE_LP = AUTO
MODULATION = QAM/AUTO
TRANSMISSION_MODE = AUTO
GUARD_INTERVAL = AUTO
HIERARCHY = NONE
INVERSION = AUTO


Pelo que li, o formato está correto com o padrão do DVBV5-SCAN

Depois segui e fiz:

pi@raspbmc:~$ dvbv5-scan -F freq.conf
CODE_RATE_HP (36) command not found during store
CODE_RATE_LP (37) command not found during store
MODULATION (4) command not found during store
HIERARCHY (40) command not found during store
Scanning frequency #1 473142857


Ele demora uma vida para escrever essas linhas e não está saindo do Scanning frequency #1.

Travei aí... e já estou a uns 10 dias tentando instalar esse baguio no meu Raspberry para ver TV utilizando o TVHEADEND Addon...

Rola uma ajuda, um tutorial detalhado ou algo assim??? ehehhehe

Valew
Posts: 9
Joined: Fri Jun 28, 2013 2:38 am
by ludoman » Sun Jun 30, 2013 3:01 am
Fala ae, Dead

Dá um help pra "nóis".... tenho esse mesmo Receptor.... ele está carregando normal e dá tudo ok no dmseg

Segui o tuto daquele site que você tava seguindo... instalei o v4l-utils e o dvb-apps via apt-get e executei o dvbv5-scan, tudo seguindo o tuto do outro site que você postou.... o Problema é que não acha canal nenhum....

Você é o único kra que fez funfá esse treco no raspbmc (tvheadend???) que eu achei na net....

Rola um passo a passo detalhado do que você fez? Estou apanhando muito e quase desistindo...

Valeu!
Posts: 9
Joined: Fri Jun 28, 2013 2:38 am
by dead » Sun Jun 30, 2013 4:07 pm
Engraçado, vi esse tópico esses dias e não tinha postagem, agora vejo de novo e ta ai ^^

Até dias atrás eu tava sem sinal aqui no cabo, então eu não podia realmente testar se o receptor tava funcionando no rasp. Mas esses dias eu comprei um booster e o receptor conseguiu pegar o sinal.
E como imaginei, está funcionando no rasp!

Minha primeira dica é:
Aqui o arquivo de frenquências não funcionava, então eu coloquei na mão a frenquência que tem um canal garantido.

Eu não testei o receptor com o tvheadend, não sei se ele tem suporte ao dvbv5 (eu dei uma procurada e acho que tem, mas não tenho certeza)

Eu não tive esses problemas que você está tendo, como que é o sinal de tv ai?

Eu recomendo tentar compilar na mão o v4l-utils.
Se precisar de ajuda com isso eu também ajudo, só falar ai :D

Vou fazer um passo-a-passo mais detalhado, por enquanto segue essas dicas ai em cima ^^
(inclusive usando o tvheadend se der)
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by ludoman » Mon Jul 01, 2013 11:51 am
Obrigado pela resposta...

Hoje vou "formatar" o SD card e começar tudo novamente....

Vou postando meus resultados conforme for conseguindo evoluções...

Valeu!
Posts: 9
Joined: Fri Jun 28, 2013 2:38 am
by bucker » Mon Jul 01, 2013 8:37 pm
Dead, primeiramente parabéns pela iniciativa!

Estou interessado na compra de um receptor, mas precisaria que tivesse a função analógica também (aqui na minha cidade não tem muitos canais digitais) você tem algum pra me indicar que sabe que funciona no pi?

Desde já agradeço!
Winning is for losers.
Raspberry Pi Model B 512MB
--
User avatar
Posts: 70
Joined: Thu May 23, 2013 4:33 pm
Location: Uberlandia, Brazil
by ludoman » Wed Jul 03, 2013 7:57 pm
Salve, Dead!!!

Agora acho que evolui... ehehhhe

Compilei na mão o V4L-UTILS (dei uma patinada em vários momentos como dependências e outras mais, mas saiu)

Dei um reboot e fiz um dvbv5-scan:
pi@raspbmc:~$ sudo dvbv5-scan -F freq.conf
INFO Scanning frequency #1 497142857
Lock (0x17) Signal= 58.10% C/N= 0.25% UCB= 166 postBER= 2097151
Service #0 (59200) Globo HD channel 5.0
Service #1 (59201) Globo SD channel 5.1
Service #2 (59224) Globo 1Seg channel 5.2
Service ID 59201 not found on PMT!


Acho que agora funcionou!!!
O meu arquivo de frequências fiz na mão e só coloquei a da Globo mesmo ( a única que sabia ser esta mesma)

O segredo realmente foi compilar na mão o V4L-UTILS...

Como você faz para assistir o canal no Raspberry?

Queria poder "ver" o canal antes de tencar usar o TvHeadend

Valew!!!
Posts: 9
Joined: Fri Jun 28, 2013 2:38 am
by dead » Fri Jul 05, 2013 5:39 pm
bucker wrote:Dead, primeiramente parabéns pela iniciativa!

Estou interessado na compra de um receptor, mas precisaria que tivesse a função analógica também (aqui na minha cidade não tem muitos canais digitais) você tem algum pra me indicar que sabe que funciona no pi?

Desde já agradeço!


Não conheço um receptor que possua tanto analógico quanto digital... :/

ludoman wrote:Salve, Dead!!!

Agora acho que evolui... ehehhhe

Compilei na mão o V4L-UTILS (dei uma patinada em vários momentos como dependências e outras mais, mas saiu)

Dei um reboot e fiz um dvbv5-scan:
pi@raspbmc:~$ sudo dvbv5-scan -F freq.conf
INFO Scanning frequency #1 497142857
Lock (0x17) Signal= 58.10% C/N= 0.25% UCB= 166 postBER= 2097151
Service #0 (59200) Globo HD channel 5.0
Service #1 (59201) Globo SD channel 5.1
Service #2 (59224) Globo 1Seg channel 5.2
Service ID 59201 not found on PMT!


Acho que agora funcionou!!!
O meu arquivo de frequências fiz na mão e só coloquei a da Globo mesmo ( a única que sabia ser esta mesma)

O segredo realmente foi compilar na mão o V4L-UTILS...

Como você faz para assistir o canal no Raspberry?

Queria poder "ver" o canal antes de tencar usar o TvHeadend

Valew!!!


Tenta fazer o seguinte:
Execute o dvbv5-zap:
dvbv5-zap -rp -I DVBV5 -c dvb_channel.conf "Nome do canal"

Depois
curl -g "localhost:8080/jsonrpc?request={'jsonrpc':'2.0','method':'Player.Open','params':{'item':{'file'​:'/dev/dvb/adapter0/dvr0'},'resume':{'seconds':0}},'id':'1''}"

Não tenho certeza se funcionaria, precisa do curl instalado, com esse comando é pra fazer abrir o adaptador no player do próprio raspbmc. Vou tentar aqui e depois posto os resultados :D
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by ludoman » Sat Jul 06, 2013 8:39 pm
Salve, Dead!
Fiz o seguinte:

Execute o dvbv5-zap:
dvbv5-zap -rp -I DVBV5 -c dvb_channel.conf "Nome do canal"

Executei e a resposta foi essa:
pi@raspbmc:~$ sudo dvbv5-zap -rp -I DVBV5 -c dvb_channel.conf "MTV HD"
using demux '/dev/dvb/adapter0/demux0'
reading channels from file 'dvb_channel.conf'
service has pid type 05: 500
ERROR command VCHANNEL (261) not found during store
tuning to 575142857 Hz
video pid 512
dvb_set_pesfilter 512
audio pid 528
dvb_set_pesfilter 528
Lock (0x1f) Signal= 51.14% C/N= 0.24% UCB= 155 postBER= 0

A última linha fica "piscando" e trocando o valor do Signal (51,14%; 51,17%; 52,01% e assim vai)
Parece que o serviço está ativado e está dando Refresh

O que pensei: "Ta recebendo o sinal e está ativo".

Abri um novo terminal com o Putty e loguei novamente

Rodei
pi@raspbmc:~$ sudo curl -g "localhost:8080/jsonrpc?request={'jsonrpc':'2.0','method':'Player.Open','params':{'item':{'file'.:'/dev/dvb/adapter0/dvr0'},'resume':{'seconds':0}},'id':'1''}"
curl: (7) couldn't connect to host

OBS: tive que instalar o Curl antes (apt-get)

Como ele deu que não conseguiu conectar com o host, imaginei que um login não conversa com o outro, daí fui na primeira janela do Putty (onde está com o "REFRESH") e dei CTRL+C para parar de rodar e tentei colocar o comando do Curl nesta janela e a resposta foi a mesma.

Tentei pesquisar sobre o erro que aparece ("ERROR command VCHANNEL (261) not found during store") e só apareceram 2 sites no japão

E, para variar, travei novamente... ehehehe

Poste as mensagens que estão aparecendo para você...

Valeu!
Posts: 9
Joined: Fri Jun 28, 2013 2:38 am
by ludoman » Wed Jul 10, 2013 12:26 am
Opa...

Obtive algumas evoluções....

Abri um terminal via Putty e sintonizei o canal do SBT

sudo dvbv5-zap -rp -I DVBV5 -c dvb_channel.conf "SBT HD"
using demux '/dev/dvb/adapter0/demux0'
reading channels from file 'dvb_channel.conf'
service has pid type 05: 500
ERROR command VCHANNEL (261) not found during store
tuning to 557142857 Hz
video pid 513
dvb_set_pesfilter 513
audio pid 514
dvb_set_pesfilter 514
Lock (0x1f) Signal= 51.14% C/N= 0.28% UCB= 181 postBER= 0


Da mesma forma que anteriormente, a última linha (Lock (0x1f) Signal= 51.14% C/N= 0.28% UCB= 181 postBER= 0) fica dando "Refresh", como se estivesse sintonizando e atualizando.

Abri um outro terminal via Putty e gravei um arquivo de poucos segundos usando o comando:

cat /dev/dvb/adapter0/dvr0 > SBT.ts


Dei CTRL+C para parar a gravação e o arquivo gravou o que estava passando no canal.

Esse teste me animou porque mostra que o adaptador está funcionando certinho.... mas abriu algumas questões:

- Todos os videos gravados estavam sem áudio;
- Nem todos os canais "sincronizavam" (alguns ficavam parecendo que esperando sinal para sincronizar)
- Quando gravava vídeos de transmissões em 1Seg ficava tudo muito bom (sem áudio, mas imagem perfeita), quando gravava em Fullseg as cores ficaram ruins (bocas azuis e poucas cores) e alguns leves delays perceptíveis na imagem.

Ainda estou na busca para fazer funfar no XBMC Frodo em sistema operacional Raspbmc

Vou adquirir os seriais dos codecs para verificar se melhora alguma coisa no desempenho das gravações... (já ia adquirir mesmos.... ehehhe)

Qualquer ajuda com essas questões são muito bem vindas!!!!
Posts: 9
Joined: Fri Jun 28, 2013 2:38 am
by dead » Fri Jul 12, 2013 4:51 pm
olá ludoman!

então, acho que pra usar:
Code: Select all
curl -g "localhost:8080/jsonrpc?request={'jsonrpc':'2.0','method':'Player.Open','params':{'item':{'file'​:'/dev/dvb/adapter0/dvr0'},'resume':{'seconds':0}},'id':'1''}"

você precisa da interface web aberta.

enfim, salvando a ts do jeito que você fez também funciona.
só me diz uma coisa, onde você tentou reproduzir a ts?

se for no rasp, pode ser que ele não tenha suporte pra fazer o demux do áudio utilizado no padrão brasileiro, tendo que converter antes ou dar um jeito de instalar no linux.

se for no windows, baixa o Combined Community Codec Pack, com ele eu sei que da pra reproduzir a ts do padrão brasileiro XD

Eu ainda não testei a reprodução no rasp, estou sem tempo :|
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by ludoman » Sat Jul 13, 2013 1:53 am
:shock: :o

Funfou....

:shock: :shock: :o

Dei uma mexida na linha de comando e fiz assim:

http://192.168.0.152/jsonrpc?request={"jsonrpc":"2.0","id":"1","method":"Player.Open","params":{"item":{"file":"/dev/dvb/adapter0/dvr0"}}}


O IP 192.168.0.152 é o rasp na minha rede... colei essa linha no Browser e... FUNFOU!!!

No XBMC está configurado para usar a porta 80 e ta tudo habilitado.

Apareceu na TV o canal que estava sintonizado no RASP utilizando o comando:

sudo dvbv5-zap -rp -I DVBV5 -c dvb_channel.conf "SBT HD"


Detalhes técnicos:

- Exibições em 1SEG são muito muito ruins (baixa resolução)
- Exibições em FULLSEG estão saindo bem.... está quadriculando bastante, o som está com delay em relação à imagem, mas acredito ser problemas com o sinal que está fraco....
- Ao contrário das gravações, sai som normalmente e as cores estão corretas...

Vou descolar um booster para colocar no rasp e ver se melhora....

Os vídeos .ts estou abrindo no windows mesmo (acesso o SD Card via SAMBA e copio para o HD do PC).

Tenho um monte de Packs de Codecs, mas vou tentar esse que você descreveu.

Valeu pelos Helps!!! Estão ajudando bastante....

Vou chegar lá.... ehehehehe
Posts: 9
Joined: Fri Jun 28, 2013 2:38 am
by ludoman » Sat Jul 13, 2013 8:41 pm
Comprei um booster meia boca, mas me surpreendeu....

Achou novos canais que não estavam aparecendo... ainda não está 100%, (a Globo, por exemplo, ele acha, mas não sintoniza...)

O Booster que comprei foi este:

Image

Vou continuar meus testes....
Posts: 9
Joined: Fri Jun 28, 2013 2:38 am
by dead » Mon Jul 15, 2013 1:02 am
Também tenho esse booster, achei ele bom até :D
Posts: 13
Joined: Sat Aug 04, 2012 2:11 pm
Location: Maringá - PR
by ralexandrec » Tue Oct 08, 2013 1:44 pm
Olá sou novato no linux e estou tendo um pouco de dificuldades para configurar o meu ISDB-T.

Possuo dois raspiberry pi, um deles está com o sistema raspibian (onde eu instalei o dongle visus tv duos correspondente ao geniatech s2870, ele está em um hub amplificado).

No outro raspiberry esta instalado o raspibmc, onde pretendo por rede fazer uso do broadcast do geniatech do raspibian.

Meu problema está no raspibian onde tento configurar o dongle isdb-t, baixei media_build do site http://linuxtv.org/wiki/index.php/How_t ... ce_Drivers, baixei o fonte do kernel 3.6.11+ e consegui compilar.

O problema é que não consigo seguir o passo do modprobe (descrito na instalacao do site), não tenho conhecimento suficiente para instalar ou compilar o drive.

Informativos:

Comando cat /proc/version

Code: Select all
Linux version 3.6.11+ (dc4@dc4-arm-01) (gcc version 4.7.2 20120731 (prerelease) (crosstool-NG linaro-1.13.1+bzr2458 - Linaro GCC 2012.08) ) #474 PREEMPT Thu Jun 13 17:14:42 BST 2013


Comando lsmod:

Code: Select all
root@raspberrypi:~# lsmod
Module                  Size  Used by
asix                   18541  0
libphy                 25315  1 asix
snd_bcm2835            16304  0
snd_pcm                77560  1 snd_bcm2835
snd_page_alloc          5145  1 snd_pcm
snd_seq                53329  0
snd_seq_device          6438  1 snd_seq
snd_timer              19998  2 snd_pcm,snd_seq
snd                    58447  5 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
leds_gpio               2235  0
led_class               3562  1 leds_gpio


Comando: mesg | grep -i pvr

Code: Select all
[ 1183.482923] usb 1-1.3.2: Product: STK8096-PVR


Alguém consegue me ajudar neste ponto?

Muito grato,

Renato.
Posts: 3
Joined: Tue Oct 08, 2013 1:34 pm
by ralexandrec » Thu Oct 17, 2013 3:09 pm
dead wrote:Olá gatts,
Fique a vontade de perguntar o que quiser!
abraços


Olá dead.

Você conseguiu utilizar algum frontend no raspbmc? (Tipo mythTv ou o tvheadend)

Abraços,

ralexandrec.
Posts: 3
Joined: Tue Oct 08, 2013 1:34 pm
by ralexandrec » Thu Oct 24, 2013 2:11 pm
Consegui!!

Para configurar o tvheadend:

No raspbmc vá em raspbmc settings (Em programs) e ative o tvheadend na aba de configurações.

Ative o add on tvheadend no submenu PVR e reinicie o raspbmc.

Vá em configurações live tv -> player e configure em play um delay de +- 3 segundos (Vai depender da qualidade do sinal), este delay ajuda o player a ter um buffer no streaming e percebi que ajuda bastante na qualidade.

Mesmo assim ainda percebi que em São Paulo, zona leste, o canal que melhor sintoniza é a UNIVESP TV nos demais o hard decoder do rasp engasga um pouco, mas o streaming por rede usando uma máquina MACOS no player VLC rodou muito bem.

No ipad 4 o player OPLAYER para iphone consegue fazer decode dos canais fullseg com pequenas perdas de quadro.
Novamente o UNIVESP TV roda até no iphone 4 (acho que o streaming da emissora é mais leve para decodificar).

De resto estou feliz, algora consigo gravar e assistir os meus programas em qualquer lugar do mundo!

Valew!
Posts: 3
Joined: Tue Oct 08, 2013 1:34 pm
by fernandovg » Fri Nov 01, 2013 12:32 pm
uso o raspbmc tambem e queria saber se tem como alguem fazer um tutorial pois não entendi o que tem que fazer.
tenho um c3 tech TV-U100. alguem já conseguiu fazer ele funcionar no raspbmc/openelec no tvheadend?
valeu
Posts: 13
Joined: Wed Sep 26, 2012 6:59 pm
by fernandovg » Sat Nov 02, 2013 7:54 pm
Baixei o /home/pi/v4l-utils-1.0.0
fiz: 'bash configure'
e depois 'make':

Code: Select all
pi@raspbmc:~/v4l-utils-1.0.0$ make
make  all-recursive
make[1]: Entrando no diretório `/home/pi/v4l-utils-1.0.0'
Making all in lib
make[2]: Entrando no diretório `/home/pi/v4l-utils-1.0.0/lib'
Making all in libv4lconvert
make[3]: Entrando no diretório `/home/pi/v4l-utils-1.0.0/lib/libv4lconvert'
  CC       libv4lconvert_la-libv4lconvert.lo
../../libtool: 1566: ../../libtool: preserve_args+= --silent: not found
../../libtool: 1578: ../../libtool: preserve_args+= --tag CC: not found
../../libtool: 1: eval: base_compile+= gcc: not found
../../libtool: 1: eval: base_compile+= -DHAVE_CONFIG_H: not found
../../libtool: 1: eval: base_compile+= -I.: not found
../../libtool: 1: eval: base_compile+= -I../..: not found
../../libtool: 1: eval: base_compile+= -fvisibility=hidden: not found
../../libtool: 1: eval: base_compile+= -I../../lib/include: not found
../../libtool: 1: eval: base_compile+= -Wall: not found
../../libtool: 1: eval: base_compile+= -Wpointer-arith: not found
../../libtool: 1: eval: base_compile+= -D_GNU_SOURCE: not found
../../libtool: 1: eval: base_compile+= -I../../include: not found
../../libtool: 1: eval: base_compile+= -g: not found
../../libtool: 1: eval: base_compile+= -O2: not found
../../libtool: 1: eval: base_compile+= -MT: not found
../../libtool: 1: eval: base_compile+= libv4lconvert_la-libv4lconvert.lo: not found
../../libtool: 1: eval: base_compile+= -MD: not found
../../libtool: 1: eval: base_compile+= -MP: not found
../../libtool: 1: eval: base_compile+= -MF: not found
../../libtool: 1: eval: base_compile+= .deps/libv4lconvert_la-libv4lconvert.Tpo: not found
../../libtool: 1: eval: base_compile+= -c: not found
libtool: compile: you must specify a compilation command
libtool: compile: Try `libtool --help --mode=compile' for more information.
make[3]: ** [libv4lconvert_la-libv4lconvert.lo] Erro 1
make[3]: Saindo do diretório `/home/pi/v4l-utils-1.0.0/lib/libv4lconvert'
make[2]: ** [all-recursive] Erro 1
make[2]: Saindo do diretório `/home/pi/v4l-utils-1.0.0/lib'
make[1]: ** [all-recursive] Erro 1
make[1]: Saindo do diretório `/home/pi/v4l-utils-1.0.0'
make: ** [all] Erro 2


como procedo com os erros?
Posts: 13
Joined: Wed Sep 26, 2012 6:59 pm