Trouble running shairport.pl


2 posts
by v8media » Wed Jan 09, 2013 5:02 am
I've tried a few times now and haven't yet been able to run the shairport.pl script. I get an error on line 48, which is "Use Net::SDP;". Is something missing from the distributions or sets of instructions I've tried?

Thanks, Ian
Posts: 2
Joined: Wed Jan 09, 2013 4:37 am
by v8media » Thu Jan 10, 2013 8:57 am
Found a random page with a reference to "cpan". Tried loading that up and had errors near the end, and still have errors on line 48 when trying to run shairport. Any ideas?

The end of the cpan logs below:


Fetching with LWP:
http://cpan-sj.viaverio.com/modules/03modlist.data.gz
Going to read '/home/pi/.cpan/sources/modules/03modlist.data.gz'
............................................................................DONE
Going to write /home/pi/.cpan/Metadata
Running make for A/AP/APEIRON/local-lib-1.008004.tar.gz
Fetching with LWP:
http://cpan-sj.viaverio.com/authors/id/ ... 004.tar.gz
Fetching with LWP:
http://cpan-sj.viaverio.com/authors/id/ ... /CHECKSUMS
Checksum for /home/pi/.cpan/sources/authors/id/A/AP/APEIRON/local-lib-1.008004.tar.gz ok
Uncompressed /home/pi/.cpan/sources/authors/id/A/AP/APEIRON/local-lib-1.008004.tar.gz successfully
Using Tar:/bin/tar xf "local-lib-1.008004.tar":
Couldn't untar local-lib-1.008004.tar
Package seems to come without Makefile.PL.
(The test -f "/home/pi/.cpan/build/APEIRON-LKXNCS/Makefile.PL" returned false.)
Writing one on our own (setting NAME to unknown)
Had problems unarchiving. Please build manually
Running make test
Make had some problems, won't test
Running make install
Make had some problems, won't install
Can't locate local/lib.pm in @INC (@INC contains: /home/pi/perl5/lib/perl5 /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14 /usr/share/perl/5.14 /usr/local/lib/site_perl /home/pi/shairport) at /usr/share/perl/5.14/CPAN/FirstTime.pm line 1300.
Posts: 2
Joined: Wed Jan 09, 2013 4:37 am