cmus streams


4 posts
by martincheco » Sun Jan 06, 2013 12:29 pm
Hi,

I've been using cmus for some days now, works nice (except of the known popping issue on the 3.5mm jack output), but I failed to add streams using the :add command.

I think it can be a version-related problem, for example:

:add http://www.play.cz/radio/radio1-192.mp3.m3u

on 2.4.2 with ubuntu gets the stream into the list, on 2.5.0 with RPI has absolutely no effect

Any clue anyone?
Posts: 2
Joined: Sun Jan 06, 2013 12:21 pm
by sdjf » Sun Jan 06, 2013 6:31 pm
please post what version of arch you are running and when you last updated.

I suppose to see what is going wrong, you could try starting this from the command line using strace and examine the output to see where it dies. That is available in the repository.
FORUM TIP: To view just one person's posting history, sign in, click on their user name, then click on "Search User's Posts." || This Pi owner is running Arch on 512MB Model B.
Posts: 1258
Joined: Fri Mar 16, 2012 5:20 am
Location: California
by martincheco » Sun Jan 06, 2013 10:51 pm
uname -a:
Linux lego 3.6.11-2-ARCH+ #1 PREEMPT Mon Dec 31 23:00:25 UTC 2012 armv6l GNU/Linux
Last update I did yesterday.

At github I was advised to install libmad, which SOLVED the problem. :D I did not have any idea that it was needed and pacman did not install libmad as default. Maybe this was an obvious solution but not for me. Maybe it will help somebody else.
Posts: 2
Joined: Sun Jan 06, 2013 12:21 pm
by pepedog » Sun Jan 06, 2013 11:35 pm
Lets see which repo cmus in
http://archlinuxarm.org/packages
tells me it's community

So I go here
https://github.com/archlinuxarm/PKGBUILDs/tree/master/community
If it's in there it could possibly be an arm only problem, but it's not there

So now on main arch site (upstream)
https://www.archlinux.org/packages/community/i686/cmus/
Ah, libmad (optional)- for mp3 input plugin support
There would probably been a message when installing cmus
Posts: 940
Joined: Fri Oct 07, 2011 9:55 am