32Gb card but only 30Mb free. How to change?


8 posts
by samsung » Sat Jan 05, 2013 9:40 pm
I install the Raspbiam or XBMC .img file using the Win32 Disk Image software, but after doing so I'm only left with like 30Mb of free space.
It shows the whole disk as being something like 100Mb.

How can I get it to show the rest of the SD card?
Posts: 5
Joined: Sat Jan 05, 2013 2:52 pm
by ghans » Sat Jan 05, 2013 9:42 pm
Thats normal , Windows can't see the ext4 partition.

ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org
Posts: 3911
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany
by samsung » Sat Jan 05, 2013 10:34 pm
Right ok, Ive just installed Ubuntu on my main PC.
Ive got a 32GB sd card with Raspbian Wheezy on it.
When I insert it into my computer running Ubuntu I get two new devices:
-59 MB Volume
-1.9GB Volume

Is there anyway to get the 1.9GB Volume to show the full amount of unused space on the SD Card?
Posts: 5
Joined: Sat Jan 05, 2013 2:52 pm
by mahjongg » Sat Jan 05, 2013 10:43 pm
You are using the standard configuration of the image, (there is just one you can download, not separate ones for each card size, which would also increase download time unnecessary) . So, regardless of the actual size of the card, the image size will be the same (obviously).

After you first boot the card you will see a configuration window (raspi-config), which has an option to expand the image so that it occupies the whole of the card.

After you done that you will see that the ext4 partition is almost as large as the card size.
User avatar
Moderator
Moderator
Posts: 4495
Joined: Sun Mar 11, 2012 12:19 am
by Cromarty » Sat Jan 05, 2013 11:02 pm
Is there a command-line way to do what the 'expand root' option at the top of the config menu does? I ask because I just got going today via SSH in console mode because I'm blind, and I don't know if I will be able to get back out of the config menu once I'm in :-/
--
Michael Ray
Analyst/Programmer
Surrey, UK
3 x Model Bs, 512MB,
Creator and admin of:
raspberry-vi@freelists.org
Ham radio call: G4XBF
Posts: 52
Joined: Thu Jan 03, 2013 5:03 pm
Location: Godalming, South-east UK
by mahjongg » Sat Jan 05, 2013 11:20 pm
I suggest you post this as a separate question, as it really is a different issue altogether, and won't have much exposure here. And, sorry but I have no idea how to do this!
User avatar
Moderator
Moderator
Posts: 4495
Joined: Sun Mar 11, 2012 12:19 am
by rurwin » Sat Jan 05, 2013 11:24 pm
You can get the initial menu with the command
Code: Select all
sudo raspi-config

It works over SSH too.
User avatar
Moderator
Moderator
Posts: 2890
Joined: Mon Jan 09, 2012 3:16 pm
by mahjongg » Sat Jan 05, 2013 11:31 pm
As he's blind, navigating a graphical menu may be difficult!
Correct me if i'm wrong, but I think that it will work if you just press enter to start the first option (expanding the file system), wait 5 minutes, or so, then press F for finish and enter to exit raspi-config. (or just wait some more, and reboot the PI).
User avatar
Moderator
Moderator
Posts: 4495
Joined: Sun Mar 11, 2012 12:19 am