RPi with Raspbian - can hardly read text


11 posts
by nigel-ph » Thu Dec 27, 2012 8:25 pm
I have my new RPi working, but the text beneath icons within the GUI and within LXTerminal and LeafPad is very blurred. I can't adequately describe the effect (and I have no idea how to get a screen shot) but one obvious thing is that every m looks like n. It's as if the LCD phasing/timing is off, but I have no control over it. I'm connected to a 21" Technica LCD TV that has a very clear HDMI TV and DVD picture.

With everything in /boot/config.txt as default (commented out) tvservice shows the resolution is 1920x1080 @ 50Hz progressive (yes - I've been googling). I tried changing the framebuffer_width/height for 1080p and the text was bigger, but then I would need to fiddle with overscan settings to get rid of the black borders, however, the text was no better anyway so I figured that was not the solution.

I can hardly read what I'm editing and the experience as a new user is somewhat disappointing, so any idea how I can get legible text?
Posts: 6
Joined: Thu Dec 27, 2012 7:53 pm
by hop » Thu Dec 27, 2012 8:41 pm
I am getting this as well :(
It would be useful if someone had a solution.
User avatar
Posts: 87
Joined: Thu Nov 22, 2012 9:40 pm
by Jim JKla » Thu Dec 27, 2012 8:46 pm
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 1935
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by nigel-ph » Thu Dec 27, 2012 9:51 pm
Thanks for that - I went to the link and changed the font settings. This produces huge text just after the boot sequence and before the GUI appears and I can see what it has done, but nothing has changed within the GUI. I still can barely read the text in LXTerminal or Leafpad. Is it simply that I'm viewing at 1920x720 resolution and need to change it to something less?
Posts: 6
Joined: Thu Dec 27, 2012 7:53 pm
by Jim JKla » Thu Dec 27, 2012 9:58 pm
Remember just close the xwindow and you are back to command line then re-run startx once you have made the changes.
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 1935
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by KenT » Fri Dec 28, 2012 10:16 am
Ah your last post gave away the real problem. It looks like you may not be running the monitor at its native resolution. With LCD monitors this produces much fuzziness.

Suggest you change config.txt to run at the native resolution and then adjust text size in leafpad, lxterminal etc to suit.
Pi Presents - A display package for museums, visitor centres, and more
Download from http://pipresents.wordpress.com
Posts: 535
Joined: Tue Jan 24, 2012 9:30 am
Location: Hertfordshire, UK
by Burngate » Fri Dec 28, 2012 11:01 am
nigel-ph wrote:... 21" Technica LCD TV ...

I've got a couple of smaller Technika TVs, and both said they were 1080p. According to Pi their native resolution is that, and that's what the Pi is sending them.
But I think they're lying.

They seem much sharper at 720p. If that's the real native resolution, and they're just down-scaling 1080p, that would explain the fuzzyness on text

Of course 1080p pictures won't look much worse down-scaled on a 720p screen, particularly if they were generated at 720p or lower, so the average punter won't know the difference
Hardware ace - level: Cowboy
User avatar
Posts: 2351
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK
by BerryPicker » Fri Dec 28, 2012 12:22 pm
nigel-ph wrote:I can hardly read what I'm editing and the experience as a new user is somewhat disappointing, so any idea how I can get legible text?

The debian wheezy image has overscan set to re-render everything displayed using just the central area of your monitor screen. Overscan can make what you see appear small and blurred. If you don't need the pi to apply overscan, you can enter 'sudo raspi-config' and use the option to stop overscan. The display will then be edge to edge and sharp.
Posts: 114
Joined: Tue Oct 16, 2012 3:03 pm
Location: The East of England
by Jim JKla » Fri Dec 28, 2012 4:20 pm
This is a quick way to get back to a start position.
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 1935
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by nigel-ph » Fri Dec 28, 2012 7:42 pm
BerryPicker wrote:
nigel-ph wrote:I can hardly read what I'm editing and the experience as a new user is somewhat disappointing, so any idea how I can get legible text?

The debian wheezy image has overscan set to re-render everything displayed using just the central area of your monitor screen. Overscan can make what you see appear small and blurred. If you don't need the pi to apply overscan, you can enter 'sudo raspi-config' and use the option to stop overscan. The display will then be edge to edge and sharp.


I turned off overscan via raspi-config as suggested, but it made no difference that I could see. Thanks for the suggestion though, at least I have learned about the overscan setting.
Posts: 6
Joined: Thu Dec 27, 2012 7:53 pm
by nigel-ph » Fri Dec 28, 2012 8:28 pm
Many thanks for all your input and I now appear to have a solution. Although the automatically detected resolution for my display was encouragingly high, the native resolution was a more modest 720p. Sadly my initial impression of acres of desktop was not achievable.

In addition to your help I today received the Eben Upon/Gareth Halfacre Raspberry Pi User Guide, where Chapter 6 provides invaluable insights. What an excellent book!

In config.txt I have set...

hdmi_group=1
hdmi_mode=19 (720p 50Hz)

...then I had to fiddle with the overscan_left/right/top/bottom settings to get a full screen. I must say these values hard hard to estimate because changing top/bottom affects left/right, and vice versa - most odd.

Thanks again for your help and if anyone else has similar problems then buying the User Guide and reading Chapter 6 would be a good starting point.

Note to self - go find a better HDMI display or DVI monitor in the sales!
Posts: 6
Joined: Thu Dec 27, 2012 7:53 pm