Fail to install libpng-1.5.13 on RPI


3 posts
by jiapei100 » Tue Dec 25, 2012 8:34 am
Hi, all:

It seems original RPI Wheezy comes with libpng12 ? I successfully built libpng-1.5.13, but fail to install it with the following error message:

(Reading database ... 76415 files and directories currently installed.)
Unpacking libpng (from .../libpng_1.5.13-1_armel.deb) ...
dpkg: error processing /home/pi/Download/ffmpeg/libpng-1.5.13/build/libpng_1.5.13-1_armel.deb (--install):
trying to overwrite '/usr/share/man/man5/png.5.gz', which is also in package libpng12-dev 1.2.49-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db ...
locale: Cannot set LC_ALL to default locale: No such file or directory
Errors were encountered while processing:
/home/pi/Download/ffmpeg/libpng-1.5.13/build/libpng_1.5.13-1_armel.deb




Can anybody help to explain how to solve the problem?


Cheers
Pei
Welcome to Vision Open
http://www.visionopen.com
Posts: 52
Joined: Sun Mar 04, 2012 10:16 am
Location: Surrey, BC, Canada
by fcatrin » Thu Feb 06, 2014 8:05 pm
This is the relevant part:
Code: Select all
trying to overwrite '/usr/share/man/man5/png.5.gz', which is also in package libpng12-dev 1.2.49-1

It means that libpng12 and libpng-1.5 include the same file, so you can't install both at the same time.

If you want to install libpng1.5, you have to uninstall libpng12 first.

--
Franco
Posts: 1
Joined: Thu Feb 06, 2014 8:03 pm
by plugwash » Fri Feb 07, 2014 12:50 pm
jiapei100 wrote:It seems original RPI Wheezy comes with libpng12 ? I successfully built libpng-1.5.13,

Where did you get it from? how did you build it?
Forum Moderator
Forum Moderator
Posts: 2231
Joined: Wed Dec 28, 2011 11:45 pm