Loosing HDMI Signal When changing Source


10 posts
by Ratking » Mon Dec 24, 2012 9:11 am
Hi,

The problem I am having is that when I start the R-Pi and my Samsung TV is switched to the right source I get the right output and everthing is fine.
When I change the source of my TV while the R-Pi is running (whatching tv) and then try to go back to the R-Pi source there is no picture unles I dis. and reconnect the HDMI cable.

I would realy appreciate if someone could help me.

Thanks
Posts: 3
Joined: Mon Dec 24, 2012 8:40 am
by alexeames » Mon Dec 24, 2012 12:23 pm
Have you tried moving the mouse? It can happen with my Samsung TV that when switching back to the Pi it's "gone to sleep" and a quick move of the mouse brings it back. :D
My Pi uses 2 watts - what what? ---- HiRes early production Pi photos RS Front Back | Farnell Front Back
User avatar
Posts: 2018
Joined: Sat Mar 03, 2012 11:57 am
Location: UK
by Ratking » Mon Dec 24, 2012 1:05 pm
I am running rasbian. If I change the source even just for a few seconds and then back to the pi the picture is gone.
I am using the iPad remote and I scroll through the menu but the picture is not coming back.

:?:
Posts: 3
Joined: Mon Dec 24, 2012 8:40 am
by ahstwin » Mon Dec 24, 2012 1:18 pm
Have you tried a different HDMI cable? It may have issues with the idea of hotplugging.
Posts: 42
Joined: Fri Nov 30, 2012 8:40 am
Location: Adelaide
by dom » Mon Dec 24, 2012 1:35 pm
ahstwin wrote:Have you tried a different HDMI cable? It may have issues with the idea of hotplugging.

hdmi_force_hotplug=1
in config.txt may be worth trying.
http://elinux.org/RPi_config.txt
Moderator
Moderator
Posts: 3862
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by efflandt » Mon Dec 24, 2012 3:14 pm
Maybe your TV is too "smart" if it makes a device think it is not even connected when switching to a different input. Or CEC from the TV could be telling your Pi to shutdown when it is not the active input. So something else to try in /boot/config.txt is hdmi_ignore_cec=1 to ignore CEC commands from your TV.

Those of us with less smart HDTV's have no way to test that. My 32" LG HDTV remote can do basic CEC things in Raspbmc (just scrolling and selecting so far). It has no problems switching inputs between Raspbian or Raspbmc and my Linux desktop PC, or booting any OS when off or that input is not selected. My little 22" Samsung HDTV has no issues switching inputs or being off either, but it does not do CEC (its remote cannot do anything in Raspbian).
Posts: 359
Joined: Mon Dec 03, 2012 2:47 am
Location: Elgin, IL USA
by Ratking » Wed Dec 26, 2012 1:50 am
This is my config.txt

hdmi_group=1
hdmi_mode=4
hdmi_ignore_cec_init=1
hdmi_ignore_cec=1
hdmi_force_hotplug=1
hdmi_boost=5

I also tried it without hdmi_ignore_cec_init=1.

My intore setup is a samsung HT-C9950W soundsystem and A samsung TV.
The Pi is wiring into the second input of the sound system.
when i change the source on my sound system from hdmi input 2 to 1 (1 being my receiver) and then back i get the sound coming out of sound system from the pi but not the picture.

To get the picture i have to disconect the hdmi cable from the pi and then re-connect it.

I think my tv is waiting for the active source message.
Posts: 3
Joined: Mon Dec 24, 2012 8:40 am
by gingerrob » Fri Jan 04, 2013 10:21 pm
I have this on both my Tvs, a Sharp LCD and a cheapy DMTech one..

Bit annoying really any suggestions?
Posts: 1
Joined: Fri Jan 04, 2013 10:19 pm
by efflandt » Sat Jan 05, 2013 8:09 am
A poster on ubuntuforms.org seems to have the same issue with a Samsung HDTV connected to Ubuntu Linux on a PC. Likewise in that case, HDMI is being run through a receiver (sound system). So maybe the receiver interrupts communication between the computer and TV when the TV is switched off or to a different HDMI input, and does not restore that when the TV is switched back on or to that HDMI input.
Posts: 359
Joined: Mon Dec 03, 2012 2:47 am
Location: Elgin, IL USA
by pjc123 » Sat Jan 05, 2013 12:49 pm
I have a similar problem with my Samsung TV. When I boot the pi, the HDMI input is activated as noted by the "HDMI" text on the corner of the screen (Or I manually select HDMI with the screen settings button), but then I get a "No Signal" message on the screen. To get it to work I have to boot and let the pi run through a couple of seconds of the boot process (but way less time than having the filesystems mount and cause corruption), and then when I unplug the pi and reboot, the screen comes up immediately. I have been doing this for several months now........Very annoying indeed.
Posts: 911
Joined: Thu Mar 29, 2012 3:37 pm