Raspbmc GUI screen goes blank


3 posts
by Stu42 » Sun Dec 23, 2012 5:38 am
Hi,

I had my Rpi up and running using Raspbian, connected via HDMI to the TV and running at 1920x1080p.

Everything was working fine, then I installed Raspbmc on a separate SD card and switched to using that. It installed and started up fine, but whenever I use the keyboard to navigate the UI, the screen goes blank for 1-2 seconds before reappearing. If I try to use the mouse, the screen goes blank every time the mouse moves. It's as if redrawing the screen is taking seconds rather than milliseconds.

Worse, if I navigate to the Appearance screen, the screen goes blank and doesn't recover until I hit Esc to navigate away from that screen.

I've edited the config.txt file to reduce the startup resolution, first to 1280x720, then to 640x480, but it hasn't fixed the issue. I've searched these forums, and the Raspbmc forums but haven't seen this issue reported.

Is there something else I can try? Maybe installing a more lightweight skin via SSH rather than via the GUI?
Posts: 3
Joined: Sun Dec 23, 2012 5:25 am
by Stu42 » Sun Dec 23, 2012 8:03 pm
Well I swapped out all the parts of my system one at a time with no improvement, until I switched from my HDMI TV to an HDMI monitor. All works perfectly now.

Sadly, I really want the media centre to work on the TV.

It's a Samsung "smart" TV. I've tried switching to "gaming mode" which removes most of the image processing the TV does. I'll dive in further and see what other features I can disable...
Posts: 3
Joined: Sun Dec 23, 2012 5:25 am
by bpelhos » Sat Nov 23, 2013 5:36 pm
Did you find a solution for your problem?

My Rpi is connected to a new LG LCD TV via HDMI and running at 1920x1080p. After the GUI starts it immediately starts to go black. When I use the remote controller (of the TV, works via CEC fine) the full display appears but after 1 second it goes black again.
When I say "it goes black" it means, that only the "inactive" part of the display goes black. For example the time int the top right corner is always visible. If I choose the Movies in the main menu, the movie images are shown, and the display doesn't disappear.
Posts: 1
Joined: Sat Nov 23, 2013 5:19 pm