Firmware update problem


2 posts
by superdexter » Sat Dec 22, 2012 4:43 pm
Hello Everyone,

This is a long story of woe - apologies!

I was trying to get the game Iridium Rising installed, and it said that I needed to change the amount of memory dedicated to graphics to 128Mb. So I ran raspi-config and made the change. I rebooted, the change was good, but Iridium Rising still would not run.

I checked the IR website and it said that I should update my Pi. So I ran rpi-update but this gave me errors about missing files.

Ok, so next step was to load all the missing files, which I did, and then I ran rpi-update and this time it said that it worked and said it was doing a firmware update and it may take a few mins, but an hour later I realised that it had just hung, and it continues to do this each time I run it.

Of course Iridium Rising still won't run, because I now find out that it only works on Debian and not Raspbian (!!), but I want to get the firmware upgrade sorted anyway...

Any ideas? All help much appreciated, cheers,

Michael.
Posts: 5
Joined: Fri Dec 21, 2012 1:54 pm
by malakai » Sat Dec 22, 2012 5:47 pm
rpi-update is more for development testing purposes and is not available unless you install it .It will update beta and not fully tested apps to update run

sudo apt-get update && sudo apt-get upgrade
http://www.raspians.com - always looking for content feel free to ask to have it posted. Or sign up and message me to become a contributor to the site. Raspians is not affiliated with the Raspberry Pi Foundation. (RPi's + You = Raspians)
User avatar
Posts: 1383
Joined: Sat Sep 15, 2012 10:35 am