raspian not making sounds


8 posts
by jorsantander » Thu Dec 20, 2012 4:00 pm
Dear friend my wheezy raspina do not make any sound, maybe i need to install a driver but a do not know what driver or how. help me ou here please
Posts: 15
Joined: Mon Dec 17, 2012 7:34 pm
by Joe Schmoe » Thu Dec 20, 2012 4:09 pm
I think the magic bullet is to put "hdmi_drive=2" in config.txt (actually, this should actually be "uncomment this line", because they put it in there for you)

And, no, no one can explain why. It is voodoo.
Never answer the question you are asked. Rather, answer the question you wish you had been asked.

- Robert S. McNamara - quoted in "Fog of War" -
Posts: 2246
Joined: Sun Jan 15, 2012 1:11 pm
by jorsantander » Thu Dec 20, 2012 9:05 pm
where exactly my friend

I have this:
# uncomment if you get no picture on HDMI for a default
"safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border
of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

#
uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen,
and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

#
uncomment to force a console size. By default it will be display's size minus
#
overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is
not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific
HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI.
This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI,
if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment
to overclock the arm. 700 MHz is the default.
#arm_freq=800

# for more options see http://elinux.org/RPi_config.txt
gpu_mem=64
Posts: 15
Joined: Mon Dec 17, 2012 7:34 pm
by Joe Schmoe » Thu Dec 20, 2012 9:29 pm
# uncomment to force a HDMI mode rather than DVI.
This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2


On my system, I just uncommented that line, rebooted, and sound started working.
Never answer the question you are asked. Rather, answer the question you wish you had been asked.

- Robert S. McNamara - quoted in "Fog of War" -
Posts: 2246
Joined: Sun Jan 15, 2012 1:11 pm
by jorsantander » Thu Dec 20, 2012 10:48 pm
it supposed to be just like the paragraph you just pueblished to me,?? it was already like that in my config
Posts: 15
Joined: Mon Dec 17, 2012 7:34 pm
by Joe Schmoe » Fri Dec 21, 2012 10:43 am
jorsantander wrote:it supposed to be just like the paragraph you just pueblished to me,?? it was already like that in my config


I hope I'm not belaboring the obvious - but you have to go in (to your config.txt) file and remove the # from the line that says "hdmi_drive=2".

I.e., the way it is shown above is the way it is by default. You do have to make the change, using whatever editor you are comfortable with. The easiest way, assuming your Pi is working (albeit without sound), is to boot up the Pi and edit the file with "vi" on the Pi. Then reboot - and hopefully after that, sound will be working.
Never answer the question you are asked. Rather, answer the question you wish you had been asked.

- Robert S. McNamara - quoted in "Fog of War" -
Posts: 2246
Joined: Sun Jan 15, 2012 1:11 pm
by plugwash » Wed Dec 26, 2012 12:26 am
Joe Schmoe wrote:And, no, no one can explain why.

Audio requires "HDMI drive".

AIUI The default behaviour of the firmware is designed to maximise the chance of selecting a combination the screen will display. As such by default it uses "DVI drive" when using a "DMT mode" (basically a PC monitor mode) and "HDMI drive" when using a "CEA mode" (basically a TV mode).

Unfortunately this means that if you have a screen that can accept HDMI audio but prefers PC monitor modes you get no audio by default until you explicitly change the drive setting.

It is voodoo.

No it isn't.
Moderator
Posts: 1964
Joined: Wed Dec 28, 2011 11:45 pm
by jfornango » Tue Feb 12, 2013 5:29 pm
In short, make it look like this:
Code: Select all
# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2
I'm only wearing black until they find something darker.
Posts: 113
Joined: Fri Sep 14, 2012 7:46 pm
Location: St. Louis, MO USA