dd or ImageWriter on Ubuntu


6 posts
by nmalservet » Wed Dec 19, 2012 10:21 pm
Hi!

i share my first experience because i don't really understand why this solution works but it works.

I've tried to install raspbian and archlinux on 2 sd cards with the command line dd but my raspberry doesn't boot. Always the red light, without nothing more...

I think it was a problem of cards but i have tried to use ImageWriter on Ubuntu, and these 2 cards works, with these 2 systems.

So if ImageWriter solve my problem, i don't know why, because this tool use dd...
Posts: 1
Joined: Wed Dec 19, 2012 10:15 pm
by Jim JKla » Thu Dec 20, 2012 5:21 pm
I have used both with Ubuntu an i've had no issues since however I have been using Win32DiskImage on windows I did find dd harder than ImageWriter but that was down to Gui versus Command line. ;)
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 1935
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by jackokring » Thu Dec 20, 2012 5:30 pm
dd worked with Mint linux (Ubuntu debian fork), the hardest part was working out which device in /dev was the correct device, and not using a subpartition device. i.e. /dev/sdc not /dev/sdc1. I had no such luck with the RISCOS image though, and spent little time figuring it out.
Pi=B256R0USB CL4SD8GB Raspbian Stock. https://sites.google.com/site/rubikcompression/strictly-long
User avatar
Posts: 754
Joined: Tue Jul 31, 2012 8:27 am
Location: London, UK
by jamesh » Thu Dec 20, 2012 5:34 pm
I use dd on Ubuntu. Works for me.
Raspberry Pi Engineer
Raspberry Pi Engineer
Posts: 10601
Joined: Sat Jul 30, 2011 7:41 pm
by adamd1008 » Mon Jan 21, 2013 12:07 am
Hi,

I just wanted to add that I've also had the same experience as nmalservet. Using the dd command with the bs=XX switch set to 4M and again to 1M, as per the instructions, didn't work for me for either 2012-09-18-wheezy-raspbian or 2012-12-16-wheezy-raspbian. After having another thought about fixing the pi and suspecting my SD card was broke, I used Win32DiskImager (on Windows, of course) and, surprisingly, this actually worked (for 2012-12-16; I didn't bother with the older one).

Is it possible that those in this thread that dd worked for changed the command-line arguments from what the instructions specified?

Cheers,
Adam
Posts: 1
Joined: Sun Jan 20, 2013 11:57 pm
by Spid » Mon Jan 21, 2013 8:06 am
As Lubuntu is my main Distro, use ImageWriter and it always works, though use GParted first to create one partition on SD Card.
I will always assume you are running Raspbian for desktop and Raspbmc for XMBC !
Posts: 525
Joined: Sat Jan 19, 2013 12:47 pm