Why isn't my custom USB data cable working?


29 posts   Page 2 of 2   1, 2
by doveman » Fri Dec 21, 2012 11:39 pm
Well I tried with Cat5 and it still didn't work. I was about to give up when I remembered I was going to try another plug in case this one was dodgy. I thought I'd buzz it out first and found that pin 3/D+ on the plug wasn't connecting to the underside of the board for whatever reason.

So I got another plug, soldered it up, buzzed it out and confirmed all 4 pins connect to the underside of the board and it still didn't work :evil:

I've had to give up now and just resort to having a captive cable hanging out the side :cry:
Posts: 163
Joined: Wed Dec 07, 2011 11:52 am
by doveman » Sun Dec 23, 2012 9:47 pm
Wow. Now my uncut USB cable has died. At least that's what appears to have happened as using it my hub and devices aren't working, so that with my USB stick plugged in Raspbmc can't boot from it. If I plug the USB stick directly into the Pi it boots. I swapped out the hub with a spare one and the same with that.

I also checked without the power cable going into the hub and it's not even getting any power from the Pi (with the power cable the lights come on and the USB stick flashes). I did try buzzing out the cable and managed with a bit of difficulty to get a trace on at least some of the pins (it's not easy to trace without a spare socket to plug each end into) but perhaps it's a dodgy connection in the cable that only manifests when it's in a certain position.

I've been drilling and wiring up the case for the last couple of days and thought I might get to do some configuration tonight but I don't have a spare cable lying around so will have to go and buy one from somewhere tomorrow (which will no doubt cost me stupid money, compared to buying online).
Posts: 163
Joined: Wed Dec 07, 2011 11:52 am
by doveman » Mon Dec 24, 2012 4:14 pm
Well I went cable shopping today and bought a 1.5m cable from the 99p shop and a 30cm cable that was lying around in a small computer shop for £3 (they also tested my cable and confirmed it was faulty).

Everything works fine with the 30cm cable. With the 99p one, I noticed the lights on the hub flicker which they don't do with the other cable so I guess it can't cope with the current. It might work fine using the UBEC power instead of from the Pi but I didn't bother testing it any further. They both claim to be 28AWG on the cables but maybe that can only cope with the current I'm drawing (whatever it is) at short distances like 30cm rather than 1.5m. The previous cable I was using was about 60cm.

Anyway, great as it is that it works, the 30cm cable has a massive moulded plug on the USB end so it won't fit in my case. I was going to cut a big hole in the side to accomodate it but then I decided to have another go with my bare plug wired to the miniUSB end of the cable with no DIN plug in between. So I joined the three 24AWG wires (D+, D-, GND) coming from the USB plug to the miniUSB cable with screw terminals. No joy. So then I removed the 24AWG and screw terminals and soldered the miniUSB cable directly to the plug. Still no joy.

The only thing I could think is that the hub must look for +5v and if it doesn't find it, doesn't enable the data connection. So I soldered the +5v wire on to the USB plug and hey presto, it works.
Posts: 163
Joined: Wed Dec 07, 2011 11:52 am
by doveman » Tue Feb 26, 2013 11:17 am
If the hub just needs to see +5v on the miniUSB port as well as the PSU plug, perhaps I can solder the miniUSB +5v to the +5v coming from my UBEC, rather than the USB plug in the RPi? Then there's no way that it can draw any power through the RPi, not that it should be anyway with the hub powered directly from the UBEC (when this power is connected the lights on the hub get a lot brighter so I can tell it's drawing from the UBEC) but you never know I guess.

I've been having a mare with it recently anyway. Whereas before Christmas the hub was working fine with three devices (remote receiver, USB tuner and USB stick) in the three inside ports on the hub, now I can only get it to work with the remote receiver on port1 and the USB stick on port3 (I'm not using the tuner anymore). Any other combination and it won't boot.

Then even this stopped working and I had to put the remote receiver on the other, outer, side of the hub. If I use a ready-made cable however, it works with both devices on the inside of the hub again, so I may just have to cut a big hole in my case to fit the moulded-plug on this cable.

I also tried my home-made cable in the bottom port on the RPi and that didn't work, so I can only assume the connector doesn't made a good connection in that for some reason. The ready-made cable works OK in it.
Posts: 163
Joined: Wed Dec 07, 2011 11:52 am